LINUX.ORG.RU
ФорумAdmin

Где скачать старые версии php и httpd?

 , , ,


0

1

Есть Centos 5.6, и есть задача установить на него apache 2.0 в связке с php 4.3.x, в репозиториях понятное дело ничего подобного давно нет. PHP я нашел для компиляции на сайте museum.php.net а вот апач где взять – понятия не имею... Может у уого-то есть, или подскажете где скачать? В идеале хотелось бы из репы поставить, но я готов и собрать, это весело.

Насколько я забыл, на RH иногда можно ставить пакеты от предыдущей версии поделия напрямую, приполировав пакетами compat-*.

berrywizard ★★★★★ ()

Я пробовала компилить на центос7, только вот так и не вышло. И я заюзала докер, правда не долго

gssomi ★★ ()
Ответ на: комментарий от KRoN73

Тот случай когда даже я за докер. Такой свежий хлебушек лучше изолировать, да и марать об него руки как-то не хочется.

MrClon ★★★★★ ()

а вот апач где взять – понятия не имею...

apache.org - ну прямо трудно не заметить...

anc ★★★★★ ()
Ответ на: комментарий от berrywizard

к сожалению это оказалось нерабочим способом. там даже просто rpm-ки есть, но и они не ставятся из-за неразрешимых даже руками зависимостей

emostar ()
Ответ на: комментарий от emostar

Во-первых, «rpm -i --force --nodeps ./http*rpm ./php*rpm», во-вторых, я дал ссылки на SRPM, сам пересобирать я их не буду, по крайней мере, забесплатно.

berrywizard ★★★★★ ()
Последнее исправление: berrywizard (всего исправлений: 1)
Ответ на: комментарий от berrywizard

пробовал как SRPM так и просто исходники, вечно всё упирается в какую-то ерунду которую не то что пофиксить, нагуглить даже невозможно. сейчас ковыряю в сторону докера, он по идее заработает на centos 5.11 но всё пока что упёрлось в отсутствие нормального libcgroup

emostar ()
Ответ на: комментарий от emostar

поставил libcgroup, осталось только поставить glibc 2.7 который centos 5.x тупо совершенно не поддерживает, и никакого решения совершенно нет, как и с переходом на centos 6. Ну как можно делать такие дистрибутивы? о_0

emostar ()

PHP 4.3 я ещё как-то могу понять, хотя всё равно с трудом (так сложно адаптировать код под PHP 5?), а какой смысл в Apache 2.0, если он почти ничем принципиально не отличается от 2.2?

frozen_twilight ★★ ()

Всё есть, просто ты не ищешь.
Однако, с Центосом 5.6 шли уже Апач 2.2.3 и похапэ 5.1.6: http://vault.centos.org/5.6/os/x86_64/CentOS/
Хотя, скорее всего, это просто их последние обновления к 5.6.

blexey ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.