LINUX.ORG.RU
решено ФорумAdmin

как в openwrt настроить две локальные сети средствами одного роутера

 , ,


0

1

Имеется роутер tp-link3220 прошитый openwrt. Он раздает интернет через USB 3g modem. В нем есть 1 порт wan и 4 порта lan. Порт wan свободен. к порту №1 Lan подключена подсеть 10.0.0.0/24 для пользования прокси-сервером (который стоит на этом роутере). На этом интерфейсе адрес прописан статически допустим 10.0.0.41. Инет из этой подсети через роутер раздается.

Задача:

1)хочу распределить Остальные три порта в подсеть 192.168.1.0/24 и включить на них dhcp сервер, чтобы при подключении устройства к этим портам выдавался динамический ip.

2) Включить wifi и чтобы wifi устройствам выдавался ip из подсети 192.168.1.0/24.

3) Подсети 10.0.0.0 и 192.168.1.0 видеть друг друга не должны.

4) в интернет через прокси должны выходить из обеих подсетей.

Как это можно сделать? Я так понимаю это как-то через vlan делается, но я не понял как.

Ответ на: комментарий от Dark_SavanT

шибко яснее не стало. со switchconfig я игрался через luci (Network\switch). но рабочего варианта не получил.

testik777 ()
Ответ на: комментарий от testik777

суть:

тебе нужно сделать два vlan в которые включить нужные порты. дальше на каждый vlan вешаешь по айпишнику и поехали.

Dark_SavanT ★★★★★ ()
Ответ на: комментарий от Dark_SavanT

спасибо. Разобрался я с вланами помогла статья и ваше второе сообщение.

Оказалось что тут нужно теги использовать. Хотя я думал, что в пределах одного коммутатора они не нужны. Но это видимо специфика openwrt, у него есть один порт который привязан к cpu и его нужно включать во все вланы роутера, у меня это оказался порт 0. Кому интересно раб конфиг выглядит так:


config interface 'lan'
        option force_link '1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '10.0.0.1'
        option _orig_ifname 'eth0 radio0.network1'
        option _orig_bridge 'true'
        option ifname 'eth0.5'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '5'
        option ports '0t 1'

config interface 'wan'
        option ifname 'usb0'
        option proto 'dhcp'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '6'
        option ports '0t 2 3 4'

config interface 'vlan6'
        option proto 'static'
        option ifname 'eth0.6'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option type 'bridge'

testik777 ()
Ответ на: комментарий от testik777

ну и в фаерволе прописал правило для vlan6 (4 пункт передумал делать).


config zone
        option input 'ACCEPT'
        option output 'ACCEPT'
        option name 'vlan6'
        option forward 'ACCEPT'
        option network 'vlan6'

config forwarding
        option dest 'wan'
        option src 'vlan6'

testik777 ()
Ответ на: комментарий от testik777

вланы нужны для того, чтобы свитч в роутере понимал какой порт какой локалке принадлежит и не отдавал всё подряд во все порты.

при этом в linux трафик входит и выходит тегованый.

Dark_SavanT ★★★★★ ()
Ответ на: комментарий от Dark_SavanT

я же специально ссылку дал на статью с оф. сайта openwrt. Там видно что теги навешиваются в любом случае на спец. порт 5. У меня это 0 оказался.По другому у меня никак не работало.

testik777 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.