LINUX.ORG.RU
решено ФорумAdmin

настроить bind на работу в сети

 , ,


1

2

Здравствуйте. Я настроил локально bind. nslookup, dig работают исправно. На сайте регистратора домена сделал glue запись, чтобы ns был ns1.mydomain.com. Указал, чтобы ns1.mydomain указывал на мой статический ip. Везде в bind вместо локально ip(где установлен bind) прописал статический ip(который виден в сети). Сервер работает локально, но в браузере на другом компьютере не загружается (долго долго что-то грузит и выдаёт ошибку). bind и apache на одном компе(соответственно используют один ip). Может кто-нибудь помочь, буду очень благодарен ?

Ответ на: комментарий от ne-vlezay

Конфиги

db.mainserver.tk

 ;
; BIND data file for local loopback interface
;
$TTL	604800
@	IN	SOA	ns1.mainserver.tk. root.mainserver.tk. (
			      3		; Serial
			 604800		; Refresh
			  86400		; Retry
			2419200		; Expire
			 604800 )	; Negative Cache TTL
@	IN	NS	ns1.mainserver.tk.
@	IN	A	95.134.130.21
ns1.mainserver.tk.	IN	A	95.134.130.21 

named.conf.local

zone "mainserver.tk" {
	type master;
	file "/etc/bind/db.mainserver.tk";
	allow-query { any;};
};

zone "130.134.95.in-addr.arpa" {
	type master;
	file "/etc/bind/rev.130.134.95.in-addr.arpa";
};
 

rev.130.134.95.in-addr.arpa

 
@	IN	SOA	ns1.mainserver.tk. root.mainserver.tk. (
			      2		; Serial
			 604800		; Refresh
			  86400		; Retry
			2419200		; Expire
			 604800 )	; Negative Cache TTL
@	IN	NS	ns1.mainserver.tk.
21	IN	PTR		mainserver.tk.

resolv.conf

nameserver 127.0.1.1
search mainserver.tk
nameserver 192.168.100.5
nameserver (ip dns сервера провайдера)
 
user324 ()
Ответ на: комментарий от user324

Безопасности от чего? Есть домен который известен в инете, есть ip адреса dns серверов которые должны отвечать по запросу. Шапочку из фольги еще наденьте.

anc ★★★★★ ()
Ответ на: комментарий от anc

95.165.130.21. Не думал, что он как-то может повлиять на проблему.

user324 ()
Ответ на: комментарий от ne-vlezay

порт

Может проблема в том, что я не пробросил 53 порт на комп с bind. Но когда пробрасываю, у меня все падает, даже апач.

user324 ()
Ответ на: комментарий от ne-vlezay

port

Сейчас стало всё норм. Я добавил в файл named.conf.options

 listen-on {192.168.100.1/24; 95.165.130.21; 127.0.1.1; }; 
Теперь у меня такое чувство, что проблема в ns сервере. Потому что если сделать nslookup ns1.mainserver.tk, то у него даже ip нет. Он же должен указывать на мой статический ip?

user324 ()
Ответ на: port от user324

port

не nslookup, а iplookup

user324 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.