LINUX.ORG.RU
ФорумAdmin

Не получается установить phpmyadmin

 ,


0

2

Вот что пишет

--> Проверка зависимостей окончена
Ошибка: Пакет: php-process-5.4.16-36.el7_1.x86_64 (base)
            Необходимо: php-common(x86-64) = 5.4.16-36.el7_1
            Установлено: php-common-5.6.21-1.el7.remi.x86_64 (@remi-php56)
                php-common(x86-64) = 5.6.21-1.el7.remi
            Доступно: php-common-5.4.16-36.el7_1.x86_64 (base)
                php-common(x86-64) = 5.4.16-36.el7_1
Ошибка: Пакет: php-tidy-5.4.16-4.el7.x86_64 (epel)
            Необходимо: php(zend-abi) = 20100525-64
            Установлено: php-common-5.6.21-1.el7.remi.x86_64 (@remi-php56)
                php(zend-abi) = 20131226-64
            Доступно: php-common-5.4.16-36.el7_1.x86_64 (base)
                php(zend-abi) = 20100525-64
Ошибка: Пакет: php-bcmath-5.4.16-36.el7_1.x86_64 (base)
            Необходимо: php-common(x86-64) = 5.4.16-36.el7_1
            Установлено: php-common-5.6.21-1.el7.remi.x86_64 (@remi-php56)
                php-common(x86-64) = 5.6.21-1.el7.remi
            Доступно: php-common-5.4.16-36.el7_1.x86_64 (base)
                php-common(x86-64) = 5.4.16-36.el7_1
Ошибка: Пакет: php-tidy-5.4.16-4.el7.x86_64 (epel)
            Необходимо: php(api) = 20100412-64
            Установлено: php-common-5.6.21-1.el7.remi.x86_64 (@remi-php56)
                php(api) = 20131106-64
            Доступно: php-common-5.4.16-36.el7_1.x86_64 (base)
                php(api) = 20100412-64
 Вы можете попробовать --skip-broken чтобы обойти проблему
 Вы можете попробовать запустить: rpm -Va --nofiles --nodigest

Cent OS 7

Перемещено leave из general

Ответ на: комментарий от Goury

ну да на каждый чих нанять админа) нашли выход, откуда я по вашему должен узреть как чего делать) сложно ответить уже

Cdelfi78 ()
Ответ на: комментарий от Cdelfi78

Найми админа чтобы он тебе рассказал как мануалы читать, если на такой примитивный вопрос ответ не приходит сам

Goury ★★★★★ ()
Ответ на: комментарий от Cdelfi78

Ответ простой, если тебе дали ссылку на какой-либо файл, то в начале скачай его, затем, определи что это за файл, в данном случае это zip архив, архив нужно распаковать, затем ты должен посмотреть содержимое архива и определить какой файл тебе поможет понять что с файлами в архиве нужно сделать, общепринято называть такие файлы README. Открыв файл ты увидишь вот такой текст:

Summary
-------

phpMyAdmin is intended to handle the administration of MySQL over the web.
For a summary of features, list of requirements, and installation instructions,
please see the documentation in the ./doc/ folder or at http://docs.phpmyadmin.net/

В тексте стоит обратить внимание на строку: «For a summary of features, list of requirements, and installation instructions, please see the documentation in the ./doc/ folder or at http://docs.phpmyadmin.net/"

Либо в директории в архиве либо пройдя по ссылке ты откроешь документацию и почитаешь инструкцию из раздела „Installation“, а там как минимум раздел „Quick Install“.

Удачи, не забывай использовать голову.

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от KRoN73

Можно, но уж если полез в них, тогда и думать надо к чему это может привести.
Свежий пых, рельсы, гцц и прочее кстати можно ставить не из помоек типа remi, а из официальных CentOS Software Collections.

whoami ()
Ответ на: комментарий от KRoN73

А в CentOS без них можно? :)

First step: EPEL

Second step:

rpmbuild --rebuild XXX_from_fedoreno_gore

:)

З.Ы.: Только вот обновления потом забываются ставиться

З.З.Ы.: По теме:

Не получается установить phpmyadmin

И не ставь, ей богу не ставь.

AlexVR ★★★★★ ()
Ответ на: комментарий от Cdelfi78

Иди на работу устройся, с зарплаты будет чем

Goury ★★★★★ ()
Ответ на: комментарий от Goury

ok, далее вот это хорошо или плохо: Хранилище конфигурации phpMyAdmin не полностью настроено, некоторые расширенные функции были отключены. Для определения причины. Или перейдите на вкладку 'Операции' любой базы данных, чтобы настроить там.

В конфигурационном файле необходимо задать парольную фразу (blowfish_secret).

Cdelfi78 ()
Ответ на: комментарий от Cdelfi78

Опять тоже самое

Обновление / установка... 1:zabbix-release-3.0-1.el7 ################################# [100%] [root@centos7 Cdelphi]# yum install -y zabbix-server-mysql zabbix-web-mysql Загружены модули: fastestmirror, langpacks base | 3.6 kB 00:00 epel/x86_64/metalink | 19 kB 00:00 epel | 4.3 kB 00:00 extras | 3.4 kB 00:00 remi-safe | 2.9 kB 00:00 rpmforge | 1.9 kB 00:00 updates | 3.4 kB 00:00 zabbix | 951 B 00:00 zabbix-non-supported | 951 B 00:00 (1/3): extras/7/x86_64/primary_db | 117 kB 00:00 (2/3): epel/x86_64/updateinfo | 545 kB 00:02 (3/3): epel/x86_64/primary_db | 4.1 MB 00:06 (1/2): zabbix-non-supported/x86_64/primary | 1.6 kB 00:00 (2/2): zabbix/x86_64/primary | 6.4 kB 00:00 Loading mirror speeds from cached hostfile * base: mirror.awanti.com * epel: ftp://ftp.colocall.net * extras: mirror.awanti.com * remi-safe: mirror.awanti.com * rpmforge: mirror.awanti.com * updates: mirror.tversu.ru zabbix 40/40 zabbix-non-supported 4/4 Разрешение зависимостей --> Проверка сценария ---> Пакет zabbix-server-mysql.x86_64 0:3.0.2-1.el7 помечен для установки --> Обработка зависимостей: fping пакета: zabbix-server-mysql-3.0.2-1.el7.x86_64 --> Обработка зависимостей: libiksemel.so.3()(64bit) пакета: zabbix-server-mysql-3.0.2-1.el7.x86_64 --> Обработка зависимостей: libOpenIPMIposix.so.0()(64bit) пакета: zabbix-server-mysql-3.0.2-1.el7.x86_64 --> Обработка зависимостей: libodbc.so.2()(64bit) пакета: zabbix-server-mysql-3.0.2-1.el7.x86_64 --> Обработка зависимостей: libOpenIPMI.so.0()(64bit) пакета: zabbix-server-mysql-3.0.2-1.el7.x86_64 ---> Пакет zabbix-web-mysql.noarch 0:3.0.2-1.el7 помечен для установки --> Обработка зависимостей: zabbix-web = 3.0.2-1.el7 пакета: zabbix-web-mysql-3.0.2-1.el7.noarch --> Проверка сценария ---> Пакет OpenIPMI-libs.x86_64 0:2.0.19-11.el7 помечен для установки --> Обработка зависимостей: OpenIPMI-modalias = 2.0.19-11.el7 пакета: OpenIPMI-libs-2.0.19-11.el7.x86_64 ---> Пакет fping.x86_64 0:3.10-4.el7 помечен для установки ---> Пакет iksemel.x86_64 0:1.4-6.el7 помечен для установки ---> Пакет unixODBC.x86_64 0:2.3.1-11.el7 помечен для установки ---> Пакет zabbix-web.noarch 0:3.0.2-1.el7 помечен для установки --> Обработка зависимостей: php-bcmath пакета: zabbix-web-3.0.2-1.el7.noarch --> Обработка зависимостей: php-ldap пакета: zabbix-web-3.0.2-1.el7.noarch --> Проверка сценария ---> Пакет OpenIPMI-modalias.x86_64 0:2.0.19-11.el7 помечен для установки ---> Пакет php-bcmath.x86_64 0:5.4.16-36.el7_1 помечен для установки --> Обработка зависимостей: php-common(x86-64) = 5.4.16-36.el7_1 пакета: php-bcmath-5.4.16-36.el7_1.x86_64 ---> Пакет php-ldap.x86_64 0:5.4.16-36.el7_1 помечен для установки --> Обработка зависимостей: php-common(x86-64) = 5.4.16-36.el7_1 пакета: php-ldap-5.4.16-36.el7_1.x86_64 --> Проверка зависимостей окончена Ошибка: Пакет: php-bcmath-5.4.16-36.el7_1.x86_64 (base) Необходимо: php-common(x86-64) = 5.4.16-36.el7_1 Установлено: php-common-5.6.21-1.el7.remi.x86_64 (@remi-php56) php-common(x86-64) = 5.6.21-1.el7.remi Доступно: php-common-5.4.16-36.el7_1.x86_64 (base) php-common(x86-64) = 5.4.16-36.el7_1 Ошибка: Пакет: php-ldap-5.4.16-36.el7_1.x86_64 (base) Необходимо: php-common(x86-64) = 5.4.16-36.el7_1 Установлено: php-common-5.6.21-1.el7.remi.x86_64 (@remi-php56) php-common(x86-64) = 5.6.21-1.el7.remi Доступно: php-common-5.4.16-36.el7_1.x86_64 (base) php-common(x86-64) = 5.4.16-36.el7_1 Вы можете попробовать --skip-broken чтобы обойти проблему Вы можете попробовать запустить: rpm -Va --nofiles --nodigest

Cdelfi78 ()
Ответ на: комментарий от Cdelfi78

ничего не получается

[root@centos7 yum.repos.d]# rm remi-release-7.rpm

rm: удалить обычный файл «remi-release-7.rpm»?

[root@centos7 yum.repos.d]# rm remi.repo

rm: удалить обычный файл «remi.repo»?

[root@centos7 yum.repos.d]# rpm -e remi

ошибка: пакет remi не установлен

[root@centos7 yum.repos.d]# rpm -e remi.repo

ошибка: пакет remi.repo не установлен

[root@centos7 yum.repos.d]# rpm -e remi-release

ошибка: пакет remi-release не установлен

[root@centos7 yum.repos.d]#

Cdelfi78 ()
Ответ на: комментарий от Goury

https://files.phpmyadmin.net/phpMyAdmin/4.6.1/phpMyAdmin-4.6.1-all-languages.zip и не страдай хернёй

Ага, а потом «Ваш сайт взломали через phpMyAdmin 2.2».

И кто здесь страдает хернёй? Вы когда-то не справились с репозиторием и теперь учите плохому людей, находящихся на правильном пути.


ТС: у тебя проблема не в пхпадмине, а в репах, намешаны php 5.4 и php 5.6, разберись с этим и все нормально будет.

UPD: хотя не, вроде у тебя phpmyadmin просит php 5.4, а установлен php 5.6, значит найди обновленный пакет админа.

BaBL ★★★★★ ()
Ответ на: комментарий от Cdelfi78

значит найди обновленный пакет админа.

Спасибо, но phpMyAdmin 4.6.1 последний вроде?

Я имел ввиду пакет с поддержкой php 5.6, откуда то ты его взял же в дистрибутиве. Или откатывайся на php 5.4

BaBL ★★★★★ ()
Ответ на: комментарий от Cdelfi78

Хранилище конфигурации phpMyAdmin

Если тебе нужны расширенные функции — включи его.
Если не нужны — забей.

необходимо задать парольную фразу

Лучше задать, хуже не будет

Goury ★★★★★ ()
Ответ на: комментарий от BaBL

Ваш сайт взломали через phpMyAdmin 2.2

Если не хватило мозгов хотя бы закрыть его от кулхацкеров или просто доступ давать исключительно с локалхоста — ССЗБ.

У криворуких одминов сайт найдут через что ломануть.

Goury ★★★★★ ()
Ответ на: комментарий от Cdelfi78

Current version compatible with PHP 5.5 to 7.0 and MySQL 5.5.

тут разве есть версия с поддержкой php 5.6?

Может хотя бы переводчика себе наймёшь?

Goury ★★★★★ ()
Ответ на: комментарий от Cdelfi78

Посмотри системные требования для представленных версий и узнаешь, ну и как бы это официальный сайт, так что все версии есть на нём.

Удачи, учись думать головой.

kostik87 ★★★★★ ()
Ответ на: комментарий от Goury

Если не хватило мозгов хотя бы закрыть его от кулхацкеров или просто доступ давать исключительно с локалхоста — ССЗБ.

У криворуких одминов сайт найдут через что ломануть.

Ой, всё...

не продолжай

BaBL ★★★★★ ()
Ответ на: комментарий от BaBL

Что то я никак не врублюсь как взять скачать там не нашел что за remi test его подключить надо?

Cdelfi78 ()

Дааааа.... Тут только снос системы поможет. Потом подключишь привильные репозитории, установишь nginx, php, марию, и уже в конце phpmyadmin.

nite2kk8 ()
Ответ на: комментарий от anonymous

Все заработало! Каким то чудом все заработало. Еще нашел один косяк при импорте конфигурации)

Cdelfi78 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.