LINUX.ORG.RU
решено ФорумAdmin

nfs не монтирует

 , ,


0

1

Всем привет.

Два свежепоставленных Centos 7, на одном сервер, на втором клиент.

На сервере:

cat /etc/exports
/static/assets/cache        192.168.0.5(rw,sync,no_root_squash,no_subtree_check)

Монтирую на клиенте:

mount -v 192.168.0.8:/static/assets/cache /var/www/static/assets/cache
mount.nfs: timeout set for Thu Apr  7 16:09:20 2016
mount.nfs: trying text-based options 'vers=4,addr=192.168.0.8,clientaddr=192.168.0.5'
mount.nfs: mount(2): Invalid argument
mount.nfs: an incorrect mount option was specified

selinux отключен, в iptables правило добавлено, telnet'ом с клиента к серверу по nfs портам подключаюсь, версия nfs и ядра:

rpm -qa|grep nfs
libnfsidmap-0.25-12.el7.x86_64
nfs-utils-1.3.0-0.21.el7_2.x86_64
----
uname -a
Linux localhost 3.10.0-123.20.1.el7.x86_64 #1 SMP Thu Jan 29 18:05:33 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
----
lsmod|grep nfs
nfsv4                 474203  0 
dns_resolver           13140  1 nfsv4
nfs                   241266  1 nfsv4
fscache                57813  2 nfs,nfsv4
nfsd                  284378  13 
auth_rpcgss            59368  2 nfsd,rpcsec_gss_krb5
nfs_acl                12837  1 nfsd
lockd                  93977  2 nfs,nfsd
sunrpc                293453  5040 nfs,nfsd,rpcsec_gss_krb5,auth_rpcgss,lockd,nfsv4,nfs_acl

Подскажите пожалуйста с какой стороны такую проблему решать?

Спасибо.

★★★

Ответ на: комментарий от Deleted

Да выключен (и на клиенте и на сервере):

systemctl status firewalld 
● firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: enabled)
   Active: inactive (dead)

Список открытых портов:

ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0            multiport dports 111,662,875,892,2049,32769,32803 /* 300 allow nfs-tcp access */
ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0            multiport dports 111,662,875,892,2049,32769,32803 /* 310 allow nfs-udp access */

пробовал останавливать iptables - есессно нет эффекта

fura13 ★★★
() автор топика
Последнее исправление: fura13 (всего исправлений: 1)
Ответ на: комментарий от fura13

Ну не знаю. Добавь в /etc/exports ip сервера, exportfs -r после этого, и попробуй с него самого смонтировать шару.

И еще, ты там обновлений не устанавливал без перезагрузки? А то в арче после обновлений ядра nfs не монтируется(без перезагрузки), хотя тут такого быть не должно.

Deleted
()
Последнее исправление: MyLittleLoli (всего исправлений: 1)
Ответ на: комментарий от Deleted

Сделал полный yum update и перезагрузил на клиенте и сервере. Тоже самое.

Внезапно, но сервер сам себя монтирует.

fura13 ★★★
() автор топика
Ответ на: комментарий от fura13

Вероятно, проблема не в сети, а между утилитами и ядром на клиенте. Смотри dmesg, сравни конфиг ядра вокруг NFS на клиенте и сервере.

Elyas ★★★★★
()
Ответ на: комментарий от Deleted

поторопился - после повторной перезагрузки, всё монтируется

спасибо большое за помощь!

fura13 ★★★
() автор топика
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.