LINUX.ORG.RU
Форум — Admin  

Не стартует MySQL в CentOS7

 ,


0

1

Здравствуйте,

такая проблемка:

После удаления MariaDB и установки MySQL my.cnf оказался почти пустым, что меня несколько ввело в легкий конфуз:

datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
Вроде, я все внес по образу и подобию предыдущих установок MySQL в Debian: https://www.dropbox.com/s/t608765mc0mjl1p/my.cnf.txt?dl=0

Но падает, зараза.

[root@dc ~]# service mysqld start
Redirecting to /bin/systemctl start  mysqld.service
Job for mysqld.service failed because the control process exited with error code. See "systemctl status mysqld.service" and "journalctl -xe" for details.
[root@dc ~]# systemctl status mysqld.service
● mysqld.service - MySQL Server
   Loaded: loaded (/usr/lib/systemd/system/mysqld.service; enabled; vendor preset: disabled)
   Active: deactivating (final-sigterm) (Result: exit-code)
  Process: 32327 ExecStart=/usr/sbin/mysqld --daemonize --pid-file=/var/run/mysqld/mysqld.pid $MYSQLD_OPTS (code=exited, status=1/FAILURE)
  Process: 32309 ExecStartPre=/usr/bin/mysqld_pre_systemd (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/mysqld.service
           └─32330 /usr/sbin/mysqld --daemonize --pid-file=/var/run/mysqld/mysqld.pid

Apr 06 17:23:07 dc systemd[1]: Starting MySQL Server...
Apr 06 17:23:07 dc mysqld[32327]: Initialization of mysqld failed: 0
Apr 06 17:23:07 dc systemd[1]: mysqld.service: control process exited, code=exited status=1
strace log: https://www.dropbox.com/s/ue54v5t43h4dwp9/mysql_strace_out.txt?dl=0

Не могу понять, чего ж он на сокет ругается? Или я не в ту сторону смотрю?

Заранее спасибо за любые мысли и советы.


Ответ на: комментарий от shell-script

системцтл статус выше, а journalctl

Apr 06 17:59:04 dc systemd[1]: Failed to start MySQL Server.
-- Subject: Unit mysqld.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit mysqld.service has failed.
--
-- The result is failed.
Apr 06 17:59:04 dc systemd[1]: Unit mysqld.service entered failed state.
Apr 06 17:59:04 dc systemd[1]: mysqld.service failed.
Apr 06 17:59:05 dc systemd[1]: mysqld.service holdoff time over, scheduling restart.
Apr 06 17:59:05 dc systemd[1]: Starting MySQL Server...
-- Subject: Unit mysqld.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit mysqld.service has begun starting up.
Apr 06 17:59:05 dc mysqld[15058]: Initialization of mysqld failed: 0
Apr 06 17:59:05 dc systemd[1]: mysqld.service: control process exited, code=exited status=1
Apr 06 17:59:05 dc NetworkManager[731]: <error> [1459954745.930759] [rdisc/nm-lndp-rdisc.c:68] send_rs(): (eno
Apr 06 17:59:07 dc systemd[1]: Failed to start MySQL Server.
-- Subject: Unit mysqld.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit mysqld.service has failed.
--
-- The result is failed.
Apr 06 17:59:07 dc systemd[1]: Unit mysqld.service entered failed state.
Apr 06 17:59:07 dc systemd[1]: mysqld.service failed.
Apr 06 17:59:07 dc systemd[1]: mysqld.service holdoff time over, scheduling restart.
Apr 06 17:59:07 dc systemd[1]: Starting MySQL Server...
-- Subject: Unit mysqld.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit mysqld.service has begun starting up.
Apr 06 17:59:07 dc mysqld[15106]: Initialization of mysqld failed: 0
Apr 06 17:59:07 dc systemd[1]: mysqld.service: control process exited, code=exited status=1

/var/log/mysqld.log: https://www.dropbox.com/s/e3ba5hauprw896m/mysql.log.txt

zuxla
() автор топика
Ответ на: комментарий от zuxla

PS: Меня пугает размер лога, при том что:

# systemctl status mysqld
● mysqld.service - MySQL Server
   Loaded: loaded (/usr/lib/systemd/system/mysqld.service; enabled; vendor preset: disabled)
   Active: activating (start-pre) since Wed 2016-04-06 19:30:44 MSK; 5ms ago
  Process: 6491 ExecStart=/usr/sbin/mysqld --daemonize --pid-file=/var/run/mysqld/mysqld.pid $MYSQLD_OPTS (code=exited, status=1/FAILURE)
  Control: 6522 (mysqld_pre_syst)
   CGroup: /system.slice/mysqld.service
           └─control
             ├─6522 /bin/bash /usr/bin/mysqld_pre_systemd
             ├─6529 /bin/bash /usr/bin/mysqld_pre_systemd
             ├─6530 /bin/bash /usr/bin/mysqld_pre_systemd
             ├─6531 /usr/bin/my_print_defaults mysqld
             ├─6532 grep ^--log-error=
             ├─6533 cut -d= -f2-
             └─6534 tail -n 1

Apr 06 19:30:44 dc systemd[1]: Starting MySQL Server...

zuxla
() автор топика
Ответ на: комментарий от Nirvandil

Убрал, не спасло.

Вопрос решен методом отката до установки MariaDB и переустановки MySQL. Теперь стартует, но меня по прежнему смущает почти пустой конфиг my.cnf. Добавляю нужное понемногу и смотрю, не падает ли :)

Всем спасибо за помощь.

zuxla
() автор топика
Ответ на: комментарий от zuxla

не спасло.

Скорее всего, потому что это была не единственная ошибка. Но хорошо, что всё решилось. Можно mysqltuner'ом погонять, если сильно руки чешутся конфиг поправить.

Nirvandil ★
()
Ответ на: комментарий от Nirvandil

Спасибо за наводку, гляну позже.

zuxla
() автор топика
Вы не можете добавлять комментарии в эту тему: топик перемещен в архив.