LINUX.ORG.RU
решено ФорумAdmin

SLURM - вопрос доступа

 ,


0

1

Возникла трудность с SLURM.

Когда поставил - работало. Теперь началось что-то непонятное:

От root: sinfo - вывод ok;

root -> su user -> user:

sinfo - вывод ok;

От user:

sinfo:

sinfo: /usr/lib64/slurm/auth_munge.so: Incompatible Slurm plugin version (15.8.4)
sinfo: error: Couldn't load specified plugin name for auth/munge: Incompatible plugin version
sinfo: error: cannot create auth context for auth/munge
sinfo: /usr/lib64/slurm/auth_munge.so: Incompatible Slurm plugin version (15.8.4)
sinfo: error: Couldn't load specified plugin name for auth/munge: Incompatible plugin version
sinfo: error: cannot create auth context for auth/munge
sinfo: /usr/lib64/slurm/auth_munge.so: Incompatible Slurm plugin version (15.8.4)
sinfo: error: Couldn't load specified plugin name for auth/munge: Incompatible plugin version
sinfo: error: cannot create auth context for auth/munge
sinfo: error: authentication: authentication initialization failure
slurm_load_partitions: Protocol authentication error

Я уже и в /etc/slurm/slurm.conf указал

PluginDir=/usr/lib64/slurm

К выводу прибавилась инфа о несовместимой версии. К чему оно не может получить доступ?


Ответ на: комментарий от NOPA

Разобрался. Причина в переменных окружения: Работает только так:

echo $PATH
/usr/bin:/usr/local/bin:/usr/bin:/bin:/sbin:/usr/sbin:

Если же на первом месте /usr/local/bin, то ошибка.

NOPA ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.