LINUX.ORG.RU
ФорумAdmin

php5

 


0

1

Был у меня Debian Lenny (долго) и Windows Server 2003 Вздумалось перенести некоторые сервисы на Linux , мудохался, но безрезультатно и подсказали мне снести lenny и поставить поновей чтоб все шло «как по маслу» (и в принципе правильно). Взял Life CD c Jessie, установил, настроил сеть хотя было не просто с bnx2. Тоже не просто поставил apache2 . Уже обрадовалсяю Стал ставить php5 и на тебе по всей морде

The following packages have unmet dependencies:
 mc : Depends: mc-data (= 3:4.8.13-3) but it is not installable
 php5 : Depends: libapache2-mod-php5 (>= 5.6.17+dfsg-0+deb8u1~) but it is not going to be installed or
                 libapache2-mod-php5filter (>= 5.6.17+dfsg-0+deb8u1~) but it is not going to be installed or
                 php5-cgi (>= 5.6.17+dfsg-0+deb8u1~) but it is not going to be installed or
                 php5-fpm (>= 5.6.17+dfsg-0+deb8u1~) but it is not going to be installed
        Depends: php5-common (>= 5.6.17+dfsg-0+deb8u1~) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Ну конечно же apt-get -f install ничего не дал. Обидно то что убито много времени, а толком ничего еще и не поставлено. Если у кого есть разгадка , отрпишитесь , пожалуйста . Ато нервов уже нет.


Если ставил с livecd, то проверь, указал ли ты онлайн-репы для apt. ЕМНИП, при установке с cd они по дефолту отключены.

Ерунду написал, сорян.

l0stparadise ★★★★★ ()
Последнее исправление: l0stparadise (всего исправлений: 1)

5.6.17+dfsg-0+deb8u1

Репы какие-то нестандартные подключал?

goingUp ★★★★★ ()
Ответ на: комментарий от l0stparadise

php5

Да указал.

deb http://ftp.ru.debian.org/debian jessie-proposed-updates main contrib non-free
deb-src http://ftp.ru.debian.org/debian jessie-proposed-updates main contrib non-free
Может не те?

fbb ()
Ответ на: комментарий от shooter93

php5

Поменял , сделал update и :

root@debian:~# apt-get install php5
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php5

Может еще с каким бубном походить надо?

fbb ()
Ответ на: php5 от fbb

Unable to locate package php5

А оно точно там под таким именем? В более других дистрибутивах оно обычно идёт разными пакетами: php5-cli, php5-fpm и php5-cgi.

KRoN73 ★★★★★ ()
Ответ на: php5 от fbb

Ты зачем вообще в sources.list лазил? На сколько я помню там по дефолту должно быть только это:

deb http://ftp.ru.debian.org/debian jessie main
deb http://ftp.debian.org/debian/ jessie-updates main
deb http://security.debian.org/ jessie/updates main

shooter93 ★★ ()
Последнее исправление: shooter93 (всего исправлений: 1)

Чего только не придумают, чтобы не писать apt-get install lamp-server^

no-such-file ★★★★★ ()
Ответ на: комментарий от shooter93

php5

Да именно здесь собака и порылась. Черт дернул, позарился на porposed . Огромное спасибо всем, особенно shooter93 (натолкнул на мысль)

fbb ()
Ответ на: php5 от fbb

Если нужна та версия похапе, которой нет в доебане - элементарно прилепляются к делу убунтовые ppa (но не все).

svr4 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.