LINUX.ORG.RU
ФорумAdmin

Asterisk Provisioning

 


0

3

Всем привет!

Есть такая проблемка, настраиваю провижининг на аппаратах Fanvil F52, при явно указанных в cfg файле параметров пользователя провижининг проходит без проблем, аппаратики регистрируются на сервере, настройки применяются. Пример конфига:

<ID>SIP1</ID>
<Phone_Number>111</Phone_Number>
<Display_Name>test</Display_Name>
<Sip_Name></Sip_Name>
<Register_Addr>192.168.1.1</Register_Addr>
<Register_Port>5060</Register_Port>
<Register_User>111</Register_User>
<Register_Pswd>******</Register_Pswd>
<Register_TTL>3600</Register_TTL>
<Enable_Reg>1</Enable_Reg>
<Proxy_Addr>192.168.1.1</Proxy_Addr>
<Proxy_Port>5060</Proxy_Port>
<Proxy_User>111</Proxy_User>
<Proxy_Pswd>******</Proxy_Pswd>
как только я ставлю в данные для регистрации переменные, телефон перестает применять провижининг. При этом содержимое cfg видно при http запросе. пример:
<ID>SIP1</ID>
<Phone_Number>${USERNAME}</Phone_Number>
<Display_Name>${DISPLAY_NAME}</Display_Name>
<Sip_Name></Sip_Name>
<Register_Addr>192.168.1.1</Register_Addr>
<Register_Port>5060</Register_Port>
<Register_User>111</Register_User>
<Register_Pswd>${SECRET}</Register_Pswd>
<Register_TTL>3600</Register_TTL>
<Enable_Reg>1</Enable_Reg>
<Proxy_Addr>192.168.1.1</Proxy_Addr>
<Proxy_Port>5060</Proxy_Port>
<Proxy_User>${USERNAME}</Proxy_User>
<Proxy_Pswd>${SECRET}</Proxy_Pswd>
С провижинингом сталкиваюсь в первый раз. У кого-нибудь может будут предположения почему не срабатывает провижининг?

У кого-нибудь может будут предположения почему не срабатывает провижининг?

Я обычно начинаю с чтения документации к телефонам.

А если и спрашиваю на форуме, то объясняю, почему например я жду что какие-то переменные внезапно станут тем, что мне нужно.

zgen ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.