LINUX.ORG.RU
ФорумAdmin

Проблема с установкой Drupal 8

 


0

1

При установки Drupal 8 выходит такое предупреждение: Your server is capable of using clean URLs, but it is not enabled.

Нужный модуль есть и включен. Файл .htaccess есть. В нем такое вот содержимое:

  RewriteEngine on
  RewriteBase /
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteCond %{REQUEST_URI} !=/favicon.ico
  RewriteRule ^ index.php [L]

В конфигурационном файле (/etc/apache2/sites-available/site.conf) добавлено AccessFileName .htaccess. А в /etc/apache2/apache2.conf прописано:

<Directory /var/www/>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
</Directory>

Однако предупреждение все равно не уходит. В чем загвоздка?

Ответ на: комментарий от luk911

Каким образом я могу включить в самом друпале чистые ссылки, если он не установлен? Это только в конфиги нужно лезть. Вопрос — в какие? Да и официальная документация об этом ничего не говорит. Она только предлагает те настройки, что я и так применил.

Чистка кеша (браузера) не приносит плодов. А так, друпал еще не установлен и с админ-панели почистить кеш естественно я не могу, если Вы это имели в виду.

djemNa ()
Ответ на: комментарий от djemNa
<Directory /var/www/>
AllowOverride All
AccessFileName .htaccess
...

или попробуйте прям в конфиг хоста прописать

  RewriteEngine on
  RewriteBase /
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteCond %{REQUEST_URI} !=/favicon.ico
  RewriteRule ^ index.php [L]

ну и на RewriteBase / обратите внимание если там в папку ставится ...

luk911 ()
Ответ на: комментарий от luk911

Пробовал уже в apache2.conf прописывать уже так:

<Directory /var/www/>
  Options Indexes FollowSymLinks
  AllowOverride All
  Require all granted
  RewriteEngine on
  RewriteBase /
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteCond %{REQUEST_URI} !=/favicon.ico
  RewriteRule ^ index.php [L]
</Directory>

Не работает. Пробовал и так:

<Directory /var/www/>
  RewriteEngine on
  RewriteBase /
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteCond %{REQUEST_URI} !=/favicon.ico
  RewriteRule ^ index.php [L]
</Directory>

Тоже не работает.

ну и на RewriteBase / обратите внимание если там в папку ставится ...

Что Вы имеет в виду?

djemNa ()
Ответ на: комментарий от djemNa

когда друпал скажем ставится в раздел сайта, а не как основной, то RewriteBase /раздел сайта

luk911 ()
Ответ на: комментарий от luk911

Спасибо! :) Как бы не было так, что и с nginx будут проблемы, ведь с апачем тоже проблем типо быть не должно. Мол, подумаешь, прописать нужные настройки в конфиге. Ага, ну тут то было.

djemNa ()
Ответ на: комментарий от djemNa

ну смотря какое окружение, попробуй с чистого листа в виртуалке, или mamp pro если на маке. А проскочить это сообщение пробовал ?

конфиги для nginx от профи, в восьмерке не смотрел, но не должно особо поменяться. По умолчанию сделаны по debian/ubuntu

luk911 ()
Ответ на: комментарий от luk911

Проблему решил. Прописал в /etc/apache2/apache2.conf

<Directory /var/www/my.site/public_html/>
  RewriteEngine on
  RewriteBase /var/www/mv.loc/public_html
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule ^(.*)$ /index.php?q=$1 [L,QSA]
</Directory>

Но предупреждение так и не ушло. Просто проигнорировал его и установил друпал. После установки проверил работу сайта и вауля — чистые ссылки работают. Видимо пока это баг такой. В конце-концов это бетка друпала 8. Спасибо всем за помощь!

djemNa ()
Ответ на: комментарий от djemNa

Предполагаю, что куча других вариантов тоже работает. Потом настрою уже другие конфиги. Просто это предупреждение вводило в заблуждение.

djemNa ()
Ответ на: комментарий от djemNa

странно что работате. RewriteBase / предполагается относительно домена example.ru если домен привязан к папке /var/www/example.ru, а друпал стоит скажем в папке внутри то есть /var/www/example.ru/drupal то RewriteBase /drupal

в твоем примере вообще странно <Directory /var/www/MY.SITE/public_html/> а в реврайте

RewriteBase /var/www/MV.LOC/public_html

Короче чего то ты накуралесил.

luk911 ()
Ответ на: комментарий от luk911

Я на скорую руку протестировал и ушел. Я в конец запутался.. В конфигурации друпала вообще отсутствует пункт clean URl, хотя он там быть должен. Как вообще проверить должным образом работу чистых ссылок?

djemNa ()
Ответ на: комментарий от luk911

А, все. Понятно. In Drupal 8, clean URLS are enabled by default and can't be disabled. Осталось найти способ проверить их работу.

djemNa ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.