LINUX.ORG.RU
ФорумAdmin

Изменить порт apache ubuntu на другой

 ,


0

1

У меня apache стоит на порту 80. Хочу поменять, например, на 8080...

Менял здесь /etc/apache2/ports.conf не помогает. После перезапуска apache порт восстанавливается на 80. В других местах менял - тоже самое...

Подскажите верный вариант?

grep -ri Listen /etc/apache2

anonymous ()

После перезапуска apache порт восстанавливается на 80

Как проверяешь?

# netstat -tulpn | grep :80
# netstat -tulpn | grep :8080

?

Nokman ()

идешь в /etc/apache2/sites-enabled/default и меняешь Listen 80 на «не 80»

SevikL ★★★★ ()
Ответ на: комментарий от SevikL

Ещё я добавил в файл /etc/apache2/apache2.conf строчку «Listen 8080» - только тогда работает...

Однако, теперь работает на двух портах. Как отменить порт 80

sitev_ru ()
Ответ на: комментарий от sitev_ru

В безлунную полночь зарезать на цыганском кладбище черную курицу и написать ее кровью себе на лбу «MᖷTЯ». Дома в зеркале прочтешь ответ.

thesis ★★★★★ ()
Ответ на: комментарий от sitev_ru

сделай в консоли cat /etc/apache2/sites-enabled/000-default

и выхлоп сюда, не забыв

оформить в LORCODE

SevikL ★★★★ ()
Ответ на: комментарий от SevikL

<VirtualHost *:8080>
ServerName sitev.ru
ServerAlias sitev.ru http://www.sitev.ru
DocumentRoot /var/www/sitev.ru
<Directory /var/www/sitev.ru>
AllowOverride All
</Directory>
ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory «/usr/lib/cgi-bin»>
AllowOverride None
Options +ExecCGI -MultiViews
+SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

sitev_ru ()
Ответ на: комментарий от SevikL

# If you just change the port or add more ports here, you will likely also # have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default.conf

Listen 80

<IfModule ssl_module>
Listen 443
</IfModule>

<IfModule mod_gnutls.c>
Listen 443
</IfModule>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

sitev_ru ()
Ответ на: комментарий от sitev_ru

# If you just change the port or add more ports here, you will >likely also # have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default.conf

Listen 80

наводит?

SevikL ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.