LINUX.ORG.RU
ФорумAdmin

apache не вычитывает php_value

 , ,


0

1

Собственно... Не могу понять. Решил попробовать поиграться с ansible.galaxy, поюзать чужие роли, но похоже зря... Все баги до которых дотянулся - поправил. Но вот один не могу одолеть:

Поставил собственно роль:

https://github.com/dj-wasabi/ansible-zabbix-server

Пришёл такой файл конфигурации:

/etc/apache2/sites-enabled/zabbix.conf (я уж молчу про то, что автор кладёт его сюда напрямую а не симлинком...)

Насколько я понимаю конфиг бессмысленнен на половину... Куча повторов Directory ни к чему:


<VirtualHost *:80>
  ServerName zabbix.company.ru

  ## Vhost docroot
  DocumentRoot "/usr/share/zabbix"

  <Directory "/usr/share/zabbix">
    AllowOverride None
    Order Allow,Deny
    Allow from all
  </Directory>

  <Directory "/usr/share/zabbix/conf">
    AllowOverride None
    Order Deny,Allow
    Deny from all
  </Directory>

  <Directory "/usr/share/zabbix/api">
    AllowOverride None
    Order Deny,Allow
    Deny from all
  </Directory>

  <Directory "/usr/share/zabbix/include">
    AllowOverride None
    Order Deny,Allow
    Deny from all
  </Directory>

  <Directory "/usr/share/zabbix/include/classes">
    AllowOverride None
    Order Deny,Allow
    Deny from all
  </Directory>

  ## Logging
  ErrorLog "/var/log/apache2/zabbix.company.ru_error.log"
  ServerSignature Off
  CustomLog "/var/log/apache2/zabbix.company.ru_access.log" combined

  ## Rewrite rules
  RewriteEngine On
  RewriteRule ^$ /index.php [L]

  ## Custom fragment
  php_value max_execution_time 300
  php_value memory_limit 128M
  php_value post_max_size 16M
  php_value upload_max_filesize 2M
  php_value max_input_time 300
  # Set correct timezone.
  php_value date.timezone Europe/Moscow
</VirtualHost>

Суть в том, что переменная: php_value date.timezone, не подхватыватся, на что сильно ругается zabbix.

Если прописать переменную, в: /etc/php5/apache2/php.ini (по умолчанию не определена), то всё хватается. Хочу понять, почему не хватается из виртуального хоста?

P.S. пробовал: AllowOverride Config, как в этом файле ставить, так и в /etc/apache2/apache2.conf в директиве: Directory / , всё игнорируется. В том числе и мои тщетные попытки прописать это в htaccess

Я могу взять топор и поправить роль как надо, но всё же стало интересно понять...

★★★★★

А если php_admin_value попробовать?

d2 ()

Только потом средствами php уже не переопределить, если используется php_admin_value.

Kilte ★★★★★ ()
Ответ на: комментарий от Kilte

Неа, это было то, что я попрбовал с самого начала.


Тут выяснилось то вот чего, короче, похоже тут очень много трешу понаписано, есть же:

/etc/apache2/conf-enabled/zabbix.conf

# Define /zabbix alias, this is the default
<IfModule mod_alias.c>
Alias /zabbix /usr/share/zabbix
</IfModule>

<Directory «/usr/share/zabbix»>
Options FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all

php_value max_execution_time 300
php_value memory_limit 128M
php_value post_max_size 16M
php_value upload_max_filesize 2M
php_value max_input_time 300
#php_value date.timezone Europe/Riga
</Directory>

<Directory «/usr/share/zabbix/conf»>
Order deny,allow
Deny from all
<files *.php>
Order deny,allow
Deny from all
</files>
</Directory>

....

Раскоментировать: #php_value date.timezone Europe/Riga , не спортивно, я читал оф. документацию zabbix. Они там просто раскоментируют. Понять бы как правильно добавить переменную просто.

DALDON ★★★★★ ()
Последнее исправление: DALDON (всего исправлений: 1)
Ответ на: комментарий от DALDON

Прозреваю, что у тебя где-то оверрайдится другой directory, поэтому просто в вихосте не срабатывает.

Это во-первых. Во-вторых, такие вещи все же по правилам хорошего тона надо бы оборачивать в if_module.

Ну и в-третьих, ты должен мне новый парсер.

leave ★★★★★ ()
Ответ на: комментарий от leave

А ты совершенно прав. Я нашёл, вот это: /etc/apache2/conf-enabled/zabbix.conf и там такое:


<Directory «/usr/share/zabbix»>
Options FollowSymLinks
AllowOverride None

Я то изменил, на: AllowOverride Options. Но это не помогло. Стало зато вычитывать мой: /usr/share/zabbix/.htaccess , но это тоже не особо спортивно... Хочу может багфикс послать в роль ansible. Вот как-бы правильнее то сделать в таком случае..? Пока выходит так: всё, что написано, в /etc/apache2/conf-enabled, главнее чем: /etc/apache2/sites-enabled ...

Чем-то же должен был руководствоваться автор, когда создавал эту роль? - Одну из самых популярных, кстати.

DALDON ★★★★★ ()
Последнее исправление: DALDON (всего исправлений: 2)
Ответ на: комментарий от Komintern

Читал это дело. Но там ничего не сказывается, об обработке директив в секции virtualhost. Именно с этим у меня нюанс то...

DALDON ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.