LINUX.ORG.RU
решено ФорумAdmin

Проблема с tproxy squid

 , , , ,


2

1

И так, пытаюсь включить:

в конфиге

root@wifi-master:/usr/src/squid-2.7.STABLE9# cat /usr/local/squid/etc/squid.conf|grep tproxy
#	   tproxy	Support Linux TPROXY for spoofing outgoing
http_port 3128 tproxy
Конфиг сборки:
root@wifi-master:/usr/src/squid-2.7.STABLE9# /usr/local/squid/sbin/squid -vSquid Cache: Version 2.7.STABLE9
configure options:  '--enable-linux-netfilter'

Ошибка при запуске:

root@wifi-master:/usr/src/squid-2.7.STABLE9# /usr/local/squid/sbin/squid
FATAL: Bungled squid.conf line 1122: http_port 3128 tproxy
Squid Cache (Version 2.7.STABLE9): Terminated abnormally.
root@wifi-master:/usr/src/squid-2.7.STABLE9# 

в чём я ошибся?

★★★★★

запусти с squid с дебагом

snaf ★★★★★ ()

В чем смысл использовать squid-2.7S9 ?

У тебя в тегах вроде squid3 написано, а мучаешь 2.7.

На 3.4 tproxy на http_port воспринивается нормально.

Если сам собирал, посмотри в config.log нашел ли он необходимые хидеры. Там какие-то ip_tproxy.h хотят, которых в в актуальных системах уже нет.

vel ★★★★★ ()
Ответ на: комментарий от ne-vlezay

нет.

оно собирается с --enable-linux-netfilter и без этих хидеров.

Убедись, что у тебя есть «#define LINUX_TPROXY» в include/autoconf.h

vel ★★★★★ ()
Ответ на: комментарий от vel

Разобрался. Модуль очень интерестный в плане блокировки запрещённых сайтов.

ne-vlezay ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.