LINUX.ORG.RU
ФорумAdmin

Mageia, сеть, два интерфейса


0

1

Доброго времени суток. Помогите настроить нормально сеть. Имеем:

ethX      Link encap:Ethernet  HWaddr 00:00:21:03:6B:1B 
ethX      Link encap:Ethernet  HWaddr 00:00:E8:A9:02:85 
Пишу именно ethX потому что это все произвольно меняется после перезагрузок.

нужно:

eth0      HWaddr 00:00:21:03:6B:1B  
          inet addr:192.168.10.74  
          Bcast:192.168.10.255  
          Mask:255.255.255.0
eth1      HWaddr 00:00:E8:A9:02:85  
          inet addr:192.168.0.XXX (DHCP)
          Gate:  (DHCP)
          Bcast:192.168.0.255  
          Mask:255.255.255.0
На eth0 висит ltsp и DHCP сервер, который туда должен выдавать адреса в сегменте 192.168.10.0

На eth1 внешняя сеть с интернетом и DHCP серваком «гдето там», тоесть должно конфигурироваться само, ну в крайнем случае можно и статику влепить но не охота, хотя сейчас не работает ни так ни эдак(

И в основном все отваливается из-за произвольного назначения имен интерфейсов, тк настройки, вроди как, привязаны к именам, и получается что после перезагрузки внутренняя сеть то на одной сетевухе, то на другой О_о

Ну так назначь сам имена:

ganymede webmaster # cat /etc/udev/rules.d/70-my-network.rules 
SUBSYSTEM=="net", ACTION=="add", ATTR{address}=="94:de:80:a1:bd:c3", NAME="eth0"
soomrack ★★★ ()
Ответ на: комментарий от soomrack

Последние продвижения:

Снес, к чертям, весь конфиг, т.е.

/network-scripts/ifcfg*; iftab; /etc/udev/rules.d/*

перезагрузил....

в результате появилось два интерфейса

enp2s10 и enp2s11 с конфигом по DHCP

Создал /etc/udev/rules.d/70-network.rules

перезагруз, в итоге оба интерфейса просто исчезли О_о

Опять посносил конфиги, перезагрузил, поправил ifcfg*

 
[root@localhost network-scripts]# cat ifcfg*0
DEVICE=enp2s10
BOOTPROTO=static
ONBOOT=yes
IPADDR=192.168.10.74
NETMASK=255.255.255.0
GATEWAY=192.168.0.1 ## <<- указал так, потому что, с какойто радости, по 
DNS1=192.168.0.1 ## <<- другому нэт не поднимался на втором интерфейсе

[root@localhost network-scripts]# cat ifcfg*1
DEVICE=enp2s11
BOOTPROTO=dhcp
ONBOOT=yes
Сеть вродь начала подниматься нормально.

НО!

теперь имеем следующее:

[root@localhost network-scripts]# dhcpd enp2s10
Internet Systems Consortium DHCP Server 4.2.5-P1
Not searching LDAP since ldap-server, ldap-port and ldap-base-dn were not specified in the config file
Wrote 0 leases to leases file.
Listening on LPF/enp2s10/00:00:21:03:6b:1b/192.168.10.0/24
Sending on   LPF/enp2s10/00:00:21:03:6b:1b/192.168.10.0/24
Can't bind to dhcp address: Address already in use
Please make sure there is no other dhcp server
running and that there's no entry for dhcp or
bootp in /etc/inetd.conf.   Also make sure you
are not running HP JetAdmin software, which
includes a bootp server.

DIABLOPC ()
Ответ на: комментарий от soomrack

Содрано с родного магеевского фаила... вообщето пробовал и без - результат тот-же...

Та фиг с ним, пускай называются как хотят, абы не скакали имена, а сейчас все вродь нормально с этим, но теперь вопрос в том что с DHCP происходит???

DIABLOPC ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.