LINUX.ORG.RU
ФорумAdmin

Товарищи, помогите с побороть sams

 ,


0

1

установил squid+sams при переходе на страницу самса пишет: can't open sams config file /etc/sams.conf в логах хоста: [Tue Apr 08 14:11:13 2014] [warn] [client 192.168.10.11] mod_fcgid: stderr: PHP Warning: fopen(/etc/sams.conf): failed to open stream: Operation not permitted in /var/www/clients/client1/web2/web/mysqltools.php on line 183, referer: http://sams.home.lan/

гуглил эту тему ничего конкретного не нашел...надеюсь вы мне поможете. p.s версия php 5.2.17


1) установи владельцем файла пользователя, из-под которого запускается apache.
2) Проверь в php.ini должно быть Safe_mode=Off
3) Перезапусти apache.

fbiagent ★★★ ()
Ответ на: комментарий от ceroz

там по теме внизу:

chown -R www-data:www-data /usr/local/share/sams 
chown www-data:www-data /etc/sams.conf 
chmod 700 -R /usr/local/share/sams 
chmod 777 /usr/local/share/sams/data -R 
только это для фряхи.

dada ★★★★★ ()
Последнее исправление: dada (всего исправлений: 1)
Ответ на: комментарий от fbiagent

Владелец и группа стоят правильно: -rwxrwxrwx 1 web2 client1 584 Апр 8 03:12 /etc/sams.conf

в php.ini Safe_mode=Off

но ошибка таже...уже и незнаю куда копать...ели чем то поможет то настраивал я по этой статье

http://softnastroy.com/content/ustanavlivaem-proksi-server-squid-c-veb-interf...

ceroz ()
Ответ на: комментарий от ceroz

та же проблема...

у меня та же проблема! can't open sams config file /etc/sams.conf Скажите пожалуйста, в каком именно файле и как прописать путь к конфигу самса??? уже не хватает терпения, все перерыл, ничего не могу найти... если можно приведите пример, как данная позиция прописана у вас! Заранее спасибо!

ivan56 ()
Ответ на: та же проблема... от ivan56

попробуй сделать вот так вот....

<Directory /var/www/site.com/>

Options Indexes FollowSymLinks MultiViews

AllowOverride All

Order allow,deny

allow from all php_admin_value open_basedir ".:/etc/sams.conf"

</Directory>

ceroz ()
Ответ на: комментарий от ceroz

извиняюсь, может глупый вопрос, но я с linux-ом знаком недолго, и знаний не хватает... Так вот, в каком файле это прописать!? И должна ли существовать директория /var/www/site.com/, потому что у меня ее нет!

ivan56 ()
Ответ на: комментарий от ceroz

Вобщем прописал в httpd.conf следующее:

Alias /sams /usr/local/share/sams

<Directory /usr/local/share/sams/>

Order Allow,Deny

Allow from all

Deny from none

</Directory>

перезапустил squid с sams-ом и пошло... Спасибо за помощь!

ivan56 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.