LINUX.ORG.RU
ФорумAdmin

К роутеру на OpenWrt с перебоями подключаются Android устройства

 , ,


0

1

Добрый день.

Есть роутер TP-LINK TL-WR1043ND v1.8. Раньше стояла DD-WRT, но потом пошли какие-то странные разрывы и на него была поставлена OpenWrt Barrier Breaker r39469 (по рекомендации с OpenWrt wiki), на котором был поднят WAN и настроен веб-интерфейс LuCl, потом через него настроен вайфай. Больше вроде нигде не лазил.

Так вот, в сети есть 2 компа и принтер - с ними всё ок, 3 андроид устройства: ТВ-приставка, с которой проблем нет, и 2 телефона (китайцы Jiyau J3 и Hero H7300).

С телефонов сидеть в сети нереально - после подключения интернет на них работает от 30 секунд до 2 минут, а потом всё - приходится выключать/включать вайфай на телефоне или ребутить роутер.

На других вайфай сетях всё хорошо, поэтому проблема в роутере. Пробовал играться с каналами, менять ширину 20/40 мегагерц, менять мощность передатчика, переключать шифрование с WPA2 на WPA/WPA2 mixed и обратно, но корелляции не заметил.

Сбрасывал роутер на заводские настройки - не помогло.

Пробовал также по совету из сети вручную привязать девайсам айпи-адреса из начала диапазона, но особых улучшений не вижу.

Телефоны разрутованы, так что к диагностике готов. Буду рад советам!

Посмотреть/изменить на powersave mode для wifi на этих телефонах.

взять другой андроид-телефон и посмотреть.

Раз стоит openwrt, то посмтореть dmesg на роутере. Возможно там будет какя-нибудь ругань на wifi.

vel ★★★★★ ()

Ведроиды засыпают - просыпается мафия^W точно проблема не в настройках энергосбережения на смартфонах?

dhameoelin ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.