LINUX.ORG.RU

2
Всего сообщений: 75

Java 17 Released

Кто самый умный - сделайте новость. С https://jdk.java.net/17/ уже качаются релизные бинарники, несмотря на то, что релиз завтра.

./jdk-17/bin/java -version
openjdk version "17" 2021-09-14
OpenJDK Runtime Environment (build 17+35-2724)
OpenJDK 64-Bit Server VM (build 17+35-2724, mixed mode, sharing)

 ,

Legioner ()

Gentoo LTS

Привет.

Интересует почему на сайте https://packages.gentoo.org/packages/sys-kernel/gentoo-kernel-bin указано два ядра.

А именно

5.10.61

5.4.143

Как и водится, найти нормальную информацию по этому вопросу, естественно не представляется возможным. Единственно что нашел это вот:

… 13 декабря 2020 года Линус Торвальдс представил первый стабильный релиз ядра Linux 5.10. Выпуск новой версии ядра Linux вышел в соответствии с графиком, спустя два месяца после выхода предыдущей стабильной версии. Исходный код ядра Linux 5.10 уже доступен для загрузки на портале kernel.org. …

… Новое ядро Linux 5.10 получило долгосрочную поддержку (LTS, long-term support). Разработчики будут не менее двух лет (вероятно, что это будет делаться даже до 6 лет) выпускать обновления для ядра Linux 5.10. Предыдущая версия ядра Linux с LTS — 5.4, которая будет поддерживаться до декабря 2025 года. …

Судя там по рисунку, следующее ядро будет 5.12.19, те я нахожусь не на ветке LTS. Ну какбы, наверно надо перейти на ядро 5.4 ? Как?)

 

RuttY ()

Грег Кроа-Хартман ищет помощников в тестировании LTS ядер

Собственно, сабж.

Greg Kroah-Hartman has a suggestion for anybody who would like to help him maintain long-term-stable kernel releases. «All I request is that people test the -rc releases when I announce them, and let me know if they work or not for their systems/workloads/tests/whatever. [...] But, if you want to do more, I always really appreciate when people email me, or stable@vger.kernel.org, git commit ids that are needed to be backported to specific stable kernel trees because they found them in their testing/development efforts.»

Более длинная новость: http://kroah.com/log/blog/2021/02/03/helping-out-with-lts-kernel-releases/ .

 , ,

saahriktu ()

Произведение мультимедиа вырубает ноут.

ArchXfceLts Как только загружается видео или gif в ВК и Телеграмме, ноутбук зависает на несколько минут, легче перезагружать. Замечаю, что это происходит обычно после спящего режима ноутбука.

 , , , ,

MelomanIk ()

Ubuntu 16.04.7?

Сегодня обновлял свою Ubutnu. Поставился новым только один пакет base-files. После чего вся система пометилась седьмым обновлением:

lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 16.04.7 LTS
Release:	16.04
Codename:	xenial

На страничке с расписанием выхода точечных релизов вообще ничего новее 16.04.5 нет.

Это вообще нормально? Может, меня взломали и кто-то таким образом ведёт со мной странную игру?

 ,

Android ()

Поддержка Debian Jessie (LTS) завершена.

 , ,

LINUX-ORG-RU ()

LTS ядро в Fedora 32

Недавно в поисках нормального дистрибутива, от которого не захочется бежать, я перешёл на Федору. В принципе всё устраивает, кроме слишком нового ядра 5.6.16-300.fc32.x86_64. Негласно чувствуешь себя Линусом, которому свежее ядро приходит одному из первых. Есть ли возможность слезть с этих рельс на более стабильные и реже обновляемые 5.4?

В гугле нашёл вот это, но не знаю насколько оно правильно.

UPD: задам ещё вопрос. Как в линуксах вообще работает гибридная графика Intel+AMD. Когда должна вызывается дискретка, и нужны ли для этого дополнительные телодвижения с моей стороны?

 , ,

Artamudo ()

Firefox и компиляция «руками»: три вопроса в одном топике

При установке SLE 11 SP4, там «из коробки» Firefox 38. Работает нормально. Из репозитория SLE_11_SP4:Updates можно установить Firefox 45. Он тоже работает нормально. Потом поддержка SLED кончилась, осталась только поддержка SLES, и в SLES не обновляют Firefox. Версия Firefox так и осталась 45. Поэтому я решил компилировать новые версии сам. Я скомпилировал версию 52. Установил, работает. Но есть три вопроса.

Первый вопрос: скомпилированный мной браузер хорошо работает на системах с 4+ Gb RAM и выше. На системах с 2 Гб памяти он работает нестабильно: при загрузке большой страницы (такой как maps.google.ru) он может «упасть»

Сначала я подумал, что проблема в патче, который я наложил, чтобы Firefox скомпилировался с Glibc 2.11. Была заменена одна строчка - неужели глюки из-за этого? Чтобы понять, так ли это, я обновил системный Glibc до 2.12 и попробовал скомпилировать Firefox без патча. Всё равно падает на 2 гигах ОЗУ...

И что интересно - помимо Firefox 52, я также скомпилировал Tor Browser 52, и он-то как раз не падает! Как так?

В поисках решения проблемы, я попробовал компилировать предыдущие версии браузера. Firefox 45 падает (хотя тот же Firefox 45 из репозитория дистрибутива не падает). Мне бы получить SRPM-ку Firefox 45 из SLED_11_SP4:Updates - наверное, там есть некий патч, который исправлет эти падения. Может быть, у кого-нибудь есть эта SRPM-ка? А Tor Browser либо тоже имеет это исправление, либо там просто что-то отключено в about:config

И наконец, самое интересное. Если компилировать браузер вручную, а потом выполнить ./mach package, то будет создал *.tar.gz архив, подобный тому, который выкладывают в http://ftp.mozilla.org/pub. А если зайти в dist/bin и запустить браузер оттуда, то ничего не падает! Это как?! В итоге я скопировал dist/bin в ~/firefox, и это работает. Но немного напрягает, что там внутри 4000 файлов, а через mach их всего 60.

Второй вопрос касается повышения системных требований. Все уже знают, что в Firefox 52 официальные сборки теперь компилируют с PulseAudio без ALSA. Нам сказали примерно следующее: «наконец-то мы прекратили поддержку Windows XP и RHEL5. Теперь нам не надо поддерживать старые звуковые системы, и поэтому мы можем реализовать звук 5.1 в браузере»

У меня возникла проблема не с этим. В Firefox 52 подняли системные требования до Xorg 7.5, который был в RHEL/CentOS 6, потому что прекратили поддержку RHEL5. В SLE 11 версия Xorg чуть меньше - 7.4. Пришлось обновить libxcb с версии 1.1 до 1.4 (вообще в Xorg 7.5 - libxcb 1.5, но опытным путём выяснилось, что 1.4 достаточно), а также libX11 с 1.1 до 1.3. Firefox скомпилировался и заработал.

Возможно ли скомпилировать libxcb 1.13, libX11 1.6.7, и, во время компиляции Firefox, слинковаться с ними статически? Я так понимаю, если я тупо уберу libxcb.so и libX11.so, оставив только libxcb.a и libxcb.a, то Firefox будет использовать именно их. Вот только все остальные зависимости (например GTK) работать без *.so версий этих либ не захотят. Так как тогда?

Лично мне не сложно обновить системные libxcb и libX11. Но мне написал юзер SLE 11 из Колумбии и сказал «Ты прописал зависимости от пакетов таких-то версий, а где их взять?». Похоже что он просто скачал мои RPM-ки вместо того, чтобы подключить репозиторий, потому что в этом случае всё само бы поставилось. И поэтому я задумался над тем, чтобы подцепить эти либы статически, а системные не обновлять. Возможно ли это?

Третий вопрос это обновление до следующих LTS-версий браузера. Там Rust, я вот пердолюсь с тем, чтобы его скомпилировать. Бинарная сборка Rust уже есть, но в OBS-репозитории mozilla бинарную сборку используют только для того, чтобы скомпилировать из исходников. Блин, а чё так сложно?

Вообще, интересные открытия можно сделать, если посмотреть SRPM-пакеты с Firefox-ом из CentOS 5 и 6. Например в пакете с CentOS 5 нашлись чудесные патчи, понижающие минимально необходимую версию GTK с 2.18 до 2.10. Также я оттуда узнал, что хотя в CentOS 5 нет Python 2.7, питон просто компилируется рядом и используется при компиляции. А потом он не нужен. Ну и наконец я оттуда взял патчи для понижения минимально необходимой версии fontconfig. SRPM-ку из CentOS 6 я пока не смотрел, и наверное решение проблемы с зависимостью от Rust и LLVM там есть.

 , , , ,

ZenitharChampion ()

Куда копать, если xrandr вдруг резко потерял один из портов?

Перезагрузил я, значит, бубунту лтс, а она мне и говорит, что больше у меня нет hdmi порта.

Обычно такое происходит, когда драйвер для xorg кривой, но он не менялся уже больше года.

Попробовал более старые ядра - не помогает. Скорее всего я что-то поставил эдакое, но конкретно что не могу понять.

У кого-нибудь есть опыт как такую шляпу дебажить.

Ну и да, в качетве видюхи затычка от Intel.

 ,

zloelamo ()

достаточно ли стабильна 18.04?

subj. На домашнем компьютере до сих пор 14.04 с xfce, но устаревание некоторых используемых мной приложений/библиотек начинает немного напрягать. Имеет ли смысл устанавливать 18.04, насколько она стабильна, есть ли серьёзные косяки?

 , ,

thunar ()

18.04

xubuntu - ничего особенного, как был так и остался, развития ноль.

mate - тоже самое.

kylin - ваще космос, будто lubuntu на lxqt в первые дни выпуска.

ubuntustudio - какой то венегрет без lts.

kubuntu - плазма сразу упала когда определил основным экраном телевизор, незнаю в чём прикол КДЕ, слишком много кнопок повсюду.

budgie - год назад был торт, особенно в родном Solus'е, но сдох, развития ноль, будущего нет.

lubuntu - торт, но умер.

ubuntu - зря они док слева воткнули и внизу кнопку меню, а так норм.

 , ,

eR ()

стабильный дистрибутив

В общем, всегда и везде пользуюсь арчем, удобно, всегда все самое свежее и так далее. Но сейчас возник вопрос: какие дистрибутивы могут предложить максимально редкие апдейты, но при этом не мертвые. Чтобы было понятнее, объясню: хочу сделать дистрибутив на флешке, установить туда все необходимое и чтобы можно было об этмо забыть на год-другой, сейчас там арч, но из-за того, что редко пользуюсь, заметил сегодня, там обновлений на пару гигабайт скопилось..

Сейчас смотрю в сторону дебиал стейбл, либо убунту-лтс, но оба меня пугают своим апт (пакман удобнее), убунту пугает своими последними действиями (выкидывания всяких юнити, переходы на гномы и вообще непонятные действия).

Слышал, есть всякие centos которые стабильные, шо ппц.

 , , , ,

shikata_ga_nai ()

Вопрос знатокам Debian

хочу скачать dvd debian wheezy

вот эти образы доступны для скачивания

debian-7.11.0-i386-DVD-1.iso.torrent 2016-06-05 19:05 75K
debian-7.11.0-i386-DVD-2.iso.torrent 2016-06-05 19:07 84K
debian-7.11.0-i386-DVD-3.iso.torrent 2016-06-05 19:09 86K
debian-update-7.11.0-i386-DVD-1.iso.torrent 2016-06-06 19:37 84K
debian-update-7.11.0-i386-DVD-2.iso.torrent 2016-06-06 19:37 84K
debian-update-7.11.0-i386-DVD-3.iso.torrent 2016-06-06 19:37 44K

ВНИМАНИЕ ВОПРОС

Чет отличаются debian и debian-update образы ?????????

 , ,

jabocrack ()

Ubuntu 15.04 - Long Term Supprort?

На Packages.ubuntu.com Utopic исчез, как и полагается, а Vivid не убрали. Получается, 15.04 - это LTS?

 , ,

Ceser ()

Ubuntu LTS - что там обновляется?

Люди, у меня, возможно, глупый вопрос... но гугление по нему как-то не дало результатов.

Скажите, где можно почитать (или как можно понять), какие пакеты обновляются в Ubuntu LTS? В том же Debian Stable всё достаточно понятно - не обновляется ничего, кроме пакетов, которым без обновлений ну никак (типа clamav), плюс, естественно, заплатки по безопасности.

Я раньше думал, что в Ubuntu LTS всё также; но, насколько я понял, не совсем - вроде как KDE было обновлено до последней версии 4-й ветки, к примеру, хотя в изначальном выпуске его не было. Так как же получается? Что именно обновляется в Ubuntu LTS?

Аналогичный вопрос по Linux Mint, в первую очередь интересует Mint KDE.

 , ,

stav_artefakt ()

Поговорим про 16.04 ?

Скоро грядёт следующий выпуск убунту для тех, кто не осилил обычные релизы, установил ЛТС. И не флудит стонами, о том, как всё плохо, на форуме.

Давайте поговорим об этом. Что вы ожидаете от него? Уберут юнити, поставят кеды но умолчанию? Снесут вейланд? Пульсаудио будет в ядре убунту?

 ,

darkenshvein ()

Земляная белка надеюсь будет стабильнее педантичного панголина?

Ибо надежный тар не такой уж и надежный, а точнее кривой до сих пор.

 , , , ,

Tems ()

Вопросы по обновлениям в Ubuntu

Пожалуйста, помогите разобраться в некоторых вопросах касательно обновлений пакетов в Убунту:

  • Обновления безопасности. Есть ли в Убунту команда безопасности, как в Дебиан, и для всех ли пакетов поставляются своевременные исправления проблем безопасности?
  • Обновления версий пакетов внутри одного выпуска. Какие обновления получают пакеты в рамках одного выпуска? Попадают ли туда минорные релизы, багфикс-релизы?
  • Обновления пакетов в Дебиан. Попадают ли в Убунту так называемые ревизии дебиановских пакетов (изменения только в рамках каталога Debian)? Попадают ли они в уже выпущенный релиз, или же только сливаются в новый?

Заранее большое спасибо. Ответы на все эти вопросы очень хотелось бы знать и для ЛТС, и для рядовых выпусков. Кстати, чем, кроме срока поддержки, ЛТС принципиально отличается от обычного релиза?

 , ,

Norong ()

Вопросы по Ubuntu LTS на десктопе

Здравия желаю. Рассматриваю переустановку всего на компе с переездом на Ubuntu LTS. Пожалуйста, дайте ответы на следующие вопросы:

  • Стабильность. Правильно ли я понимаю, что Ubuntu LTS полируются гораздо лучше, чем рядовые релизы Ubuntu, так что, можно спокойно обновляться от LTS к LTS без риска того, что система развалится?
  • Новизна софта. Правильно ли я понимаю, что версии там не самые старые, но достаточно стабильные а в случае необходимости нового, можно подтянуть из PPA или собрать самому? Кстати, за жизненный цикл LTS-релиза бывает ли, что приходят не-багфикс обновления, а просто обновления до новых релиз-версий?
  • Что означает «поддержка в течение 5 лет»? Какие именно обновления будут выкатываться для системы?

    В целом, исходя из того, что я прочитал, у меня сложилось впечатление, что Ubuntu LTS - очень хорошая система для десктопа, с достаточным уровнем стабильности, дружелюбности к пользователю, но и не слишком устаревающая. Или, может быть, есть какие-то негативные стороны, которые я проморгал? Кстати, если что, использую я Awesome, так что, недостатки Unity расписывать не имеет смысла.

    P.S. Там в Ubuntu планируют выкатить Mir. Я надеюсь, в репозиториях для желающих останется Xorg, и те, кто не желают юзать Mir+Unity, по-прежнему смогут собирать из mini.iso всё то, что захотят. Моим надеждам суждено оправдаться? Заранее спасибо.

 , ,

Valdor ()

Про поддержку пакетов в дистрибутивах

В каком-нибудь серьёзном дистрибутиве, у которого поддержка заканчивается в 2020, допустим RHEL, есть ruby 1.8, поддержку которого давно дропнули, значит ли это что в дистре всё равно будут закрываться все уязвимости в ruby 1.8?
Также открыл для себя ubuntu-support-status, и выяснилось что в моей 14.04 некоторые пакеты поддерживаются до февраля 2015, в том числе и nginx, значит ли это что если в этом nginx завтра обнаружится критическая дыра - её никто латать и будет, и мой сервер будет не защищён?(хоть поддержка до апреля 2019 года) Так же заметил что много пакетов из стандартных реп не поддерживается, накатил чистую 15.04 и один пакет из стандартной поставки вообще не поддерживается изначально, почему так?

 ,

GanGSISoft ()