LINUX.ORG.RU

125
Всего сообщений: 2180

Выбор дисплея для работы GDM3

Установил федорку с гномами и gdm. И этот самый gdm запускается на правом мониторе (основной левый) при том, что сам гном работает правильно (ручками выставил в настройках). Подскажите какой параметр в конфигах искать. Ну и хорошо бы знать, где искать сам конфиг.

gdm3setup запускатся не хочет ни так, ни от sudo через терминал. Также хочу тему впаять и курсор.

 , ,

ViktorShahter ()

Поломались зависимости в Fedora 30

Последний мой rpm-дистрибутив был OpenSUSE 11.3, где особых проблем с зависимостями не было. А на Fedora я даже не знаю куда копать.

Через терминал получаю вот такое:

# dnf update
определение самого быстрого зеркала (3 узлов).. done.B/s |   0  B     --:-- ETA
Fedora Modular 30 - x86_64 - Updates            9.1 kB/s |  23 kB     00:02    
Fedora 30 - x86_64 - Updates                     27 kB/s |  23 kB     00:00    
Fedora 30 - x86_64 - Updates                    883 kB/s | 1.5 MB     00:01    
Fedora 30 - x86_64                               71 kB/s |  24 kB     00:00    
google-chrome                                    15 kB/s | 1.3 kB     00:00    
RPM Fusion for Fedora 30 - Free - Updates        15 kB/s | 9.6 kB     00:00    
RPM Fusion for Fedora 30 - Nonfree - Updates     34 kB/s | 9.4 kB     00:00    
vivaldi                                         6.4 kB/s | 2.9 kB     00:00    
Ошибка: 
 Проблема 1: package kernel-modules-extra-5.1.5-300.fc30.x86_64 requires kernel-uname-r = 5.1.5-300.fc30.x86_64, but none of the providers can be installed
  - conflicting requests
 Проблема 2: package kernel-5.1.5-300.fc30.x86_64 requires kernel-core-uname-r = 5.1.5-300.fc30.x86_64, but none of the providers can be installed
  - conflicting requests
(try to add '--skip-broken' to skip uninstallable packages)
# dnf update --skip-broken
Последняя проверка окончания срока действия метаданных: 0:00:54 назад, Вс 23 июн 2019 11:12:58.
Ошибка: 
 Проблема 1: package kernel-modules-extra-5.1.5-300.fc30.x86_64 requires kernel-uname-r = 5.1.5-300.fc30.x86_64, but none of the providers can be installed
  - conflicting requests
 Проблема 2: package kernel-5.1.5-300.fc30.x86_64 requires kernel-core-uname-r = 5.1.5-300.fc30.x86_64, but none of the providers can be installed
  - conflicting requests

Если обновлять через гномовский центр приложений, то получаю вот такое:

Не удалось загрузить обновления:
Ошибка при выполнении транзакции: файл /usr/share/doc/glibc/NEWS из устанавливаемого пакета glibc-2.29.fc30.i686 конфликтует с файлом из пакета glibc-2.29.fc30.x86_64

Не обновлялся пару месяцев – не до того было. Сижу на ядре 5.0.17, ибо на ядрах 5.1.X черный экран после загрузки. i686 пакеты основных библиотек были для чего-то нужны, я уже не помню зачем, но хотелось бы оставить, чтоб ничего не отломалось.

 , ,

the_real_kinik ()

Потеря Windows 10 загрузчиком GRUB (UEFI)

Порекомендовали поставить федору. Поставил. Установленный Grub при перезагрузке не отобразился. Анализ os-prober результатов не показал. В саму Windows через Boot Menu (Windows Boot Manager) не заходит совсем. В конфиге на винду ни намёка. Подозреваю на случайный снос EFI раздела. Что можно сделать, будучи в Fedore? Сама винда есть на диске со всеми папками (её не тронуло). ISOшник с виндой в наличии.

Решение: https://remontka.pro/windows-10-bootloader-fix/ После чего при загрузке выбираем в Boot Menu наш linux (у меня федора) и генерируем новый конфиг grub (с примонтированным диском С, или какой там у вас) Если не ясно насчёт конфига - гуглите, всё есть и в понятной форме.

 , , ,

ViktorShahter ()

гаснет дисплей в Fedora 30

Ноутбук Lenovo. После обновления до Fedora 30 через несколько минут простоя гаснет монитор, и приходиться кнопкой питания выключить а затем включить ноутбук. В предыдущих версиях такого не наблюдалось.

 , ,

Gooddy ()

Fedora, openSUSE, PPPoE. ИДИОТЫ

Прочел на ЛОРе, в статье с броским названием - Fedora, PPPoE, идиотизм - что-то о злоключениях очередного гениального линуксмэна под ником pelmeshechka, обнаружившего в популярных rpm-based дистрибутивах чудовищную несуразность, а именно - неспособность работать с PPPoE... ну, что здесь можно сказать, оставаясь в рамках корректной беседы на техническом форуме. Много лет работаю именно с этими двумя дистрибами; затрудняюсь сказать, насколько давно было (и было ли вообще) время, когда в официальные коробки Fedora и OpenSUSE не входил по умолчанию пакет rp-pppoe:

zypper info rp-pppoe
Загрузка данных о репозиториях...
Чтение установленных пакетов...


Сведения — пакет rp-pppoe:
--------------------------
Репозиторий            : openSUSE-Leap-15.1-Oss                 
Имя                    : rp-pppoe                               
Версия                 : 3.12-lp151.5.60                        
Архитектура            : x86_64                                 
Поставщик              : openSUSE                               
Размер после установки : 410,9 KiB                              
Установлено            : Да                                     
Состояние              : актуален                               
Пакет с исходным кодом : rp-pppoe-3.12-lp151.5.60.src           
Заключение             : A PPP Over Ethernet Redirector for PPPD
Описание               :                                        
    rp-pppoe is a user-space redirector which permits the use of PPPoE
    (Point-to-Point Protocol Over Ethernet) with Linux. PPPoE is used by
    many ADSL service providers.

Короткой строкой How to start? как запустить; по ссылке. Подтверждение сказанному несложно найти, погуглив всего несколько секунд, вопросы о работе пакета rp-pppoe на Fedora 27, скажем, вообще лежат на поверхности. Выйду, таким образом, из немалого затруднения, слегка перефразировав терминологию автора вышеназванных двух постов, несколько более объемных, чем этот... получится примерно так:

Откуда Берутся Идиоты?

P.S. Вот эти перлы -

TL;DR: в федоре из коробки невозможно подключиться по PPPoE.
pppoe-setup тоже отстутствует

- не соответствуют действительности. Попросту говоря, это бред.

 , ,

rishard ()

тиринг в новом amdgpu

привет всем. Начиная с 5 версии ядра дрова amdgpu доступны из коробки, т.е. не надо доустанавливать пакет xorg-x11-drv-amdgpu. Но он почему-то игнорирует опции xorga в частности tearfree, без чего нормально работать невозможно. Я пробовал ставить обычный драйвер, через некоторое время иксы просто больше не стартуют без каких-либо сообщений. Для нового драйвера нужны другие опции, если да кто скажет какие? опции xorg

Section "OutputClass"
	Identifier "AMDgpu"
	MatchDriver "amdgpu"
	Driver "amdgpu"
	 Option "VariableRefresh" "on" 
	 Option "ShadowPrimary" "on" 
	 Option "TearFree" "on" 
	Option "SWCursor" "true"
EndSection

что говорит лог об ошибке

.....
  366.682] (II) modeset(0): Initializing kms color map for depth 24, 8 bpc.            │
[   366.682] (==) modeset(0): DPMS enabled                                               │
[   366.682] (WW) modeset(0): Option "VariableRefresh" is not used                       │
[   366.682] (WW) modeset(0): Option "ShadowPrimary" is not used                         │
[   366.682] (WW) modeset(0): Option "TearFree" is not used                              │
[   366.683] (II) modeset(0): [DRI2] Setup complete                  
.....
.

 ,

jtad ()

Удалить новое ядро Fedora

Как правильно удалить? dnf remove kernel-5.1.5 не помогло.Кстати, хоть его и нет(?) в системе, система все равно грузится с ним

 ,

billylee17 ()

Fedora vs openSuse

Всем доброго дня! Нужен совет. Стою перед выбором дистрибутива Fedora или openSuse, предпочтение к оболочке KDE. Что нужно от OS, я начинающий web разработчик хотелось подобрать стабильный дистрибутив для дальнейшей работы а не головнина. Если есть другие предложения с удовольствием выслушаю.

******
Если есть разработчики, напишите, пожалуйста, кто в чем работает. Заранее благодарен!
******

P.S. Ubuntu, Debian и их подобных не предлагать.

 , , ,

serendsoft ()

Как правильно удалить Gnome из Fedora 29

На домашнем ПК Fedora 29, установлена была (кажется) с образа Workstation, в общем, тот который с гномом. Некоторое время назад установил Cinnamon

dnf group install cinnamon-desktop-environment

и логинился в него через шестерёнку в GDM. Теперь хочется удалить гном, так как больше не нужен. Сделал

dnf group remove gnome-desktop

но куча гномопакетов осталась

[root@home ~]# rpm -qa gnome\* | wc -l
32

и они висят в меню Cinnamon (‘‘Настройки Gnome’’ и т.д.). Если пытаться удалять гномопакеты поштучно (gnome-shell, gnome-session, …), то dnf хочет удалить gdm и разные xorg-пакеты, и я подозреваю что больше уже не залогинюсь. Как правильно удалить гном и ничего не разломать?

 , ,

d_a ()

Fedora 29 и 30: не работает помощь в Qt5

Установил из репозитория на Fedora 29 Qt5 SDK. Пакеты qt5, qt5-qtdoc, qt5-devel, qt-creator. Так вот, в Qt Creator и Qt Assistant не работает документация по Qt. В «Contents» есть пункт «Qt 5... Reference Documentation, в нём подпункт Classes. На открывшейся странице выбираю любой класс, а он в ответ:

Error loading: qthelp://org.qt-project.qtdoc.5113/qtwidgets/qabstractgraphicsshapeitem.html

Обновил Fedora до 30. В ней то же самое, но вместо ошибки „Error loading...“ открывается пустая страница.

Проверьте, у всех так? Можно ли профиксить?

 ,

te111011010 ()

fedora server стабильность

Приветствую господа и дамы ЛОРа!
Имею fedora server 30. Установлен софт: varnish, nginx, mariadb-server, php-fpm, composer, phpmyadmin, drupal8.
Софт установлен из репозиториев дистрибутива.
Вопрос: Что будет, когда выйдет федора сервер 31, и я обновлю дистрибутив через пакетный менеджер? Софт поломается, или будет работать?
Спасибо за ваши добрые и щедрые ответы =).

 ,

SergeyF ()

Напоминатор об обновлениях софта для федоры

Нужен сабж, чтобы не писать просто sudo dnf upgrade каждый день в надежде что что-то вышло, а апгрейдить тогда когда действительно вышло. При этом юзаю сугубо DNF в консоли, гуёвина что-то не нравится, поэтому не ставил ни PackageKit ни gnome-software. Есть ли что нибудь отдельное, что может напоминать об апдейтах в трее, но больше ничего не делать? И да, в том числе и о том, что пора апгрейдить версию и самой федоры, у них бывают EOL.

 , , ,

justin_case ()

Лагает kde на федоре

Вообщем сначала я попользовался kde на mageia и он там просто летал, но мне пришлось его снести по некоторым причинам. После я решил попробовать fedora 30 kde. Лагает невероятно сильно, загрузка дольше секунд на 15,даже когда на меню нажимаешь, то оно с задержкой открывается. Постоянно трещит жёсткий диск, но свап не юзается. В системном мониторе потребление озу не большое и нагрузки на проц тоже почти нет. Отключил некоторые эффекты. Кто-то знает в чём может быть проблема и как решить? Уж очень федора понравилась. Проц 4 ядра 1.6,буст до 2.6, 4 гига озу. Жёсткий диск более менее быстрый

 , ,

kronos2411 ()

Проблема с копированием Fedora30

Добрый день, была установлена Fedora 28 LXDE поставил Fedora 30 LXDE и пытаюсь скопировать любые текстовые данные, но почему то выделяемый текст сбрасывается через секунду, что приводит к невозможности его копирование, единственное исключение AbiWord там все выделяется, но произвести вставку куда либо тоже не получается. Такое наблюдалось на Fedora29 LXDE, я думал что они решат проблему в новой версии но увы не решили.

 , ,

Serge29 ()

fedora 28 i686 и 4 гига памяти - чому так?

Есть комп на нем 4 гига памяти и федора 28 (а раньше и много других федор, начиная с 7). Памяти раньше было вообще 2 а потом проапгрейдил, но в любом случае всегда и везде писали что если её больше 4 то надо ставить 64, а если меньше то 32 в самый раз. Но сегодня заметил что ядро видит только 3 гига из 4. Загрузился с ливцд той же федоры но 64 и да - все 4 гига видны стали. И вот чому так ведь 4 гига это не БОЛЬШЕ ЧЕТЫРЕХ, а видится только 3? Почему тогда пишут про больше 4 а не больше 3? Надо ли переустанавливать или я просто что-то делаю не так?

 , ,

justin_case ()

Fedora 30

Fedora 30 x64. Проблема с обновлением.

Вывод сообщения на $sudo dnf update -v

Загружены модули: builddep, changelog, config-manager, copr, debug, debuginfo-install, download, generate_completion_cache, needs-restarting, playground, repoclosure, repodiff, repograph, repomanage, reposync DNF version: 4.2.2 cachedir: /var/cache/dnf Неизвестное значение параметра: failovermethod=priority в /etc/yum.repos.d/fedora-updates-modular.repo; Конфигурация: OptionBinding с идентификатором «failovermethod» не существует Неизвестное значение параметра: failovermethod=priority в /etc/yum.repos.d/fedora-updates-modular.repo; Конфигурация: OptionBinding с идентификатором «failovermethod» не существует Неизвестное значение параметра: failovermethod=priority в /etc/yum.repos.d/fedora-updates-modular.repo; Конфигурация: OptionBinding с идентификатором «failovermethod» не существует репозиторий: используется кэш для: fedora-modular not found other for: Fedora Modular 30 - x86_64 не найдено deltainfo для: Fedora Modular 30 - x86_64 не найден updateinfo для: Fedora Modular 30 - x86_64 fedora-modular: используются метаданные из Пт 26 апр 2019 02:47:30. РЕПО: загрузка с удаленного устройства: updates-modular error: Downloading successful, but checksum doesn't match. Calculated: 19681c5615cb30a94e569f2a3e743e5b74a3ac4c5966026fff54050e55af377addb3809710363328cbe8a4bd7887ce892f0051463eafa597e5a992b2555751f5(sha512) Expected: 512d5b4545c9cc72f803a88e83e62b7c35b8a1b792c2d8106cf08bbf99aec31fec1399865d5be1348da1b05cb43f8645b53187e56b3b10281722f8d9b16ff41e(sha512) (https://mirror.linux-ia64.org/fedora/linux/updates/30/Modular/x86_64/repodata...). error: Downloading successful, but checksum doesn't match. Calculated: 19681c5615cb30a94e569f2a3e743e5b74a3ac4c5966026fff54050e55af377addb3809710363328cbe8a4bd7887ce892f0051463eafa597e5a992b2555751f5(sha512) Expected: 512d5b4545c9cc72f803a88e83e62b7c35b8a1b792c2d8106cf08bbf99aec31fec1399865d5be1348da1b05cb43f8645b53187e56b3b10281722f8d9b16ff41e(sha512) (http://mirror.linux-ia64.org/fedora/linux/updates/30/Modular/x86_64/repodata/...). error: Status code: 404 for https://mirror.linux-ia64.org/fedora/linux/updates/30/Modular/x86_64/repodata... (https://mirror.linux-ia64.org/fedora/linux/updates/30/Modular/x86_64/repodata...). error: Status code: 404 for https://mirror.linux-ia64.org/fedora/linux/updates/30/Modular/x86_64/repodata... (https://mirror.linux-ia64.org/fedora/linux/updates/30/Modular/x86_64/repodata...). error: Status code: 404 for https://mirror.linux-ia64.org/fedora/linux/updates/30/Modular/x86_64/repodata... (https://mirror.linux-ia64.org/fedora/linux/updates/30/Modular/x86_64/repodata...). error: Status code: 404 for http://mirror.linux-ia64.org/fedora/linux/updates/30/Modular/x86_64/repodata/... (http://mirror.linux-ia64.org/fedora/linux/updates/30/Modular/x86_64/repodata/...). error: Status code: 404 for http://mirror.linux-ia64.org/fedora/linux/updates/30/Modular/x86_64/repodata/... (http://mirror.linux-ia64.org/fedora/linux/updates/30/Modular/x86_64/repodata/...). error: Status code: 404 for http://mirror.linux-ia64.org/fedora/linux/updates/30/Modular/x86_64/repodata/... (http://mirror.linux-ia64.org/fedora/linux/updates/30/Modular/x86_64/repodata/...). error: Curl error (52): Server returned nothing (no headers, no data) for https://mirror.yandex.ru/fedora/linux/updates/30/Modular/x86_64/repodata/9bb2... [Empty reply from server] (https://mirror.yandex.ru/fedora/linux/updates/30/Modular/x86_64/repodata/9bb2...). error: Curl error (52): Server returned nothing (no headers, no data) for https://mirror.yandex.ru/fedora/linux/updates/30/Modular/x86_64/repodata/f850... [Empty reply from server] (https://mirror.yandex.ru/fedora/linux/updates/30/Modular/x86_64/repodata/f850...). error: Status code: 404 for http://mirror.linux-ia64.org/fedora/linux/updates/30/Modular/x86_64/repodata/... (http://mirror.linux-ia64.org/fedora/linux/updates/30/Modular/x86_64/repodata/...). error: Status code: 404 for https://mirror.linux-ia64.org/fedora/linux/updates/30/Modular/x86_64/repodata... (https://mirror.linux-ia64.org/fedora/linux/updates/30/Modular/x86_64/repodata...). error: Zchunk header checksum didn't match expected checksum (http://mirror.yandex.ru/fedora/linux/updates/30/Modular/x86_64/repodata/f850e...). error: Zchunk header checksum didn't match expected checksum (http://mirror.yandex.ru/fedora/linux/updates/30/Modular/x86_64/repodata/9bb27...). Fedora Modular 30 - x86_64 - Updates 117 kB/s | 877 kB 00:07 Не удается загрузить «https://mirrors.fedoraproject.org/metalink?repo=updates-released-modular-f30&...»: Checksum error /var/cache/dnf/updates-modular-783da5de2e38c644/repodata/f850ebe08c1f80a08866f62242b0e6a7091e500ef2a205bd3dc1c16640f06f1c-primary.xml.zck: Unable to read zchunk lead.

------

Как понятно из сообщения Downloading successful, but checksum doesn't match. Дистрибутив взят с https://getfedora.org/

не знаю насколько серьезна проблема modular.repo; Конфигурация: OptionBinding с идентификатором «failovermethod» не существует репозиторий: используется кэш для: fedora-modular

вроде пофиксена должна быть https://forum.remirepo.net/viewtopic.php?id=3747

sudo dnf clean all делал до проверки сертифкатов ещё не дошёл нужны советы как чего смотреть и крутить

Всем прочитавшим спасибо.

 , ,

rapacu ()

продукты Red Hat для домохозяев

После прочтения новости о выходе RHEL 8 и комментариев к ним назрел вопрос – какую пользу я получу при переходе со свежеустановленного KDE спина Fedora 30 на RHEL 8 с бесплатной подпиской для разработчиков?

Что запускаю на компе (+ то, что я хочу запускать):

  • Веб-браузер (Vivaldi);
  • VM с Windows XP в VirtualBox, Windows 10 в QEMU/KVM;
  • Пару пиратских программ, которые поддерживают только RHEL;
  • Emacs + ESS + knitr (соотв-но нужен LaTeX и R);
  • Какую-нибудь среду разработки (скорее всего VS Code, потому что мне очень нравится MS Visual Studio для Windows) для обучения C++ и Fortran;
  • Chrome для DRM контента;
  • Очень хотел бы завести MS Outlook (по-моему, это лучший почтовик ever) под Wine’ом;
  • Было бы очень здорово организовать проброс видеокарты и избавиться от dualboot’а.

Железо:

  • Процессор Intel Core i7;
  • Материнка ASRock;
  • Видеокарта GTX 1060.

Смогу ли я реализовать то, что хочу и использую из первого списка на железе из второго под RHEL 8? Ну и плюсом хотелось бы изучить эти новые штуки типа AppStream, podman и SCL о которых писали в комменатриях.

 , ,

the_real_kinik ()

Проброс USB устройства в Wine (Fedora 30)

Обновился на федору 30. Отвалилася USB-девайс, проброшенный в Wine:

lsusb
Bus 003 Device 002: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
ls -l /dev
crw-rw----. 1 root  dialout 188,   0 мая  7 06:50 ttyUSB0
ls -l  ~/.wine/dosdevices/
lrwxrwxrwx. 1 artem artem 10 мая  7 19:15 com1 -> /dev/ttyS0
lrwxrwxrwx. 1 artem artem 12 мая 19  2018 com3 -> /dev/ttyUSB0
lrwxrwxrwx. 1 artem artem 12 мая  3 22:11 com33 -> /dev/ttyUSB0
В 28-29 федоре всё работало. Виндовая прога в Wine (Ambibox) дает ошибку not connected. При выборе порта в Ambibox подсветка пытается включиться (мигает последовательно цветами как и должна), но не включается.

Куда копать? Wine или Fedora?

 , ,

flather ()

Не работает shutdown при заблокированном экране.

Суть в названии темы. Нужно, чтобы компьютер выключался ночью. Я прописываю команду в crontab «shutdown -P now», и толку нет. Если запланировать через несколько минут — сработает, если просто выполнить из консоли — тоже. Но как только экран блокируется, система отказывается выключать комп.

 ,

vasya256 ()

Ошибки отображения шрифта Lucida Grande в Firefox\Chrome

Собственно строчная кириллическая Т отображается как - (выглядит это так https://yadi.sk/i/UOI8UNieItUqRQ), невозможно ввести двоеточие в адресной строке, если lucida используется как системный. Это происходит как в интерфейсе браузеров, так и в содержимом. В остальном окружении изменений не произошло. В хроме это уже с полгода так, в ффоксе сравнительно недавно. Ума не приложу, с чем это связанно, т.к. с ни менее древним Ариалом ничего подобного не произошло. Да и как-то сомнительно, что в новых версиях utf могли произойти столь глобальные изменения. Найти причину у меня не получилось. Версия шрифта 0.24.1, более новой версии так-же найти не вышло.

 , , ,

luiswoo ()