LINUX.ORG.RU

6
Всего сообщений: 83

ath10k + hostapd + 5ghz + linux 5.8 = fail

Привет *,

Собсно есть у меня железяка PCEngines APU2 в которую воткнуто 2 двухдиапазонных адаптера Compex WLE600VX на базе ath10k - один дует на 2.4Ггц, второй - на 5Ггц. Стоит Убунта 20.04 и всё было хорошо.

Тут чёрт меня дёрнул обновиться на новый HWE - ядро 5.8 (было 5.4) - и вайфай пропал.

Оказалось что в EEPROM карт вбит по дефолту регион «мир» (0x63) и в 5.8, похоже, закрутили гайки и отметили все 5Ггц частоты в этом регионе как «no IR» т.е. AP на них делать теперь нельзя:

Frequencies:
                        * 5180 MHz [36] (23.0 dBm) (no IR)
                        * 5200 MHz [40] (23.0 dBm) (no IR)
                        * 5220 MHz [44] (23.0 dBm) (no IR)
                        * 5240 MHz [48] (23.0 dBm) (no IR)
                        * 5260 MHz [52] (23.0 dBm) (no IR, radar detection)
                        * 5280 MHz [56] (23.0 dBm) (no IR, radar detection)
                        * 5300 MHz [60] (23.0 dBm) (no IR, radar detection)
                        * 5320 MHz [64] (23.0 dBm) (no IR, radar detection)
                        * 5500 MHz [100] (disabled)
                        * 5520 MHz [104] (disabled)
                        * 5540 MHz [108] (disabled)
                        * 5560 MHz [112] (disabled)
                        * 5580 MHz [116] (disabled)
                        * 5600 MHz [120] (disabled)
                        * 5620 MHz [124] (disabled)
                        * 5640 MHz [128] (disabled)
                        * 5660 MHz [132] (disabled)
                        * 5680 MHz [136] (disabled)
                        * 5700 MHz [140] (disabled)
                        * 5720 MHz [144] (disabled)
                        * 5745 MHz [149] (30.0 dBm) (no IR)
                        * 5765 MHz [153] (30.0 dBm) (no IR)
                        * 5785 MHz [157] (30.0 dBm) (no IR)
                        * 5805 MHz [161] (30.0 dBm) (no IR)
                        * 5825 MHz [165] (30.0 dBm) (no IR)
                        * 5845 MHz [169] (disabled)
                        * 5865 MHz [173] (disabled)

В 5.4 по крайней мере часть каналов была доступна:

  Frequencies:
                        * 5180 MHz [36] (20.0 dBm)
                        * 5200 MHz [40] (20.0 dBm)
                        * 5220 MHz [44] (20.0 dBm)
                        * 5240 MHz [48] (20.0 dBm)
                        * 5260 MHz [52] (20.0 dBm) (no IR, radar detection)
                        * 5280 MHz [56] (20.0 dBm) (no IR, radar detection)
                        * 5300 MHz [60] (20.0 dBm) (no IR, radar detection)
                        * 5320 MHz [64] (20.0 dBm) (no IR, radar detection)
                        * 5500 MHz [100] (disabled)
                        * 5520 MHz [104] (disabled)
                        * 5540 MHz [108] (disabled)
                        * 5560 MHz [112] (disabled)
                        * 5580 MHz [116] (disabled)
                        * 5600 MHz [120] (disabled)
                        * 5620 MHz [124] (disabled)
                        * 5640 MHz [128] (disabled)
                        * 5660 MHz [132] (20.0 dBm) (no IR, radar detection)
                        * 5680 MHz [136] (20.0 dBm) (no IR, radar detection)
                        * 5700 MHz [140] (20.0 dBm) (no IR, radar detection)
                        * 5720 MHz [144] (20.0 dBm) (radar detection)
                        * 5745 MHz [149] (20.0 dBm)
                        * 5765 MHz [153] (20.0 dBm)
                        * 5785 MHz [157] (20.0 dBm)
                        * 5805 MHz [161] (20.0 dBm)
                        * 5825 MHz [165] (20.0 dBm)
                        * 5845 MHz [169] (disabled)
                        * 5865 MHz [173] (disabled)

Насколько я почитал гугл - из юзерспейса это не решается, загрузка новых regulatory domain (wireless-regdb + crda) только может еще больше гайки закрутить, а не открутить.

Как я понял - в том же OpenWRT патчат ядро чтобы это решить.

Пока я откатился на 5.4, но тренд какой-то хреновый. Может есть способ какой-то чтобы это решить не таща своё ядро? А то собирать лень каждый раз.

 , , , ,

blind_oracle ()

Wi-Fi заставляет систему падать

Собственно, следующая проблема. После долгого аптайма, примерно около суток, сначала перестает работать вайфай, а когда я пробую переподключиться, то система зависает и я ничего не могу сделать, кроме как просто водить мышкой или переключиться на другой tty. После переключения на другой tty, система работает, но не получается залогиниться как root, если запустить sudo из-под пользователя, то команда так и висит не исполняясь и ничего не спрашивая.

Система: calculate linux (она же gentoo), wifi модуль Qualcomm Atheros QCA6174, NetworkManager, OpenRC. Также я использую VPN, он обозначен как frankfurt408 в логах.

Логи: https://pastebin.com/VU0p9mDS

 , , , ,

evioejgg45 ()

Установка драйверов на сетевую карту

Всем привет. Использую Fedora 32 на ноуте. Раньше стояла сетевая карта RT3290 на которой в линуксе не работает блютуз. Купил Qualcomm Atheros qcwb833, поставил. Fedora определяет ее как Qualcomm Atheros QCA9565 / AR9565. В принципе все работает и вифи и блютуз, но когда слушаю музыку на наушниках(по блютуз), начинает сильно тормозить вифи, долго грузит и зависает. Как бы установить правильные дрова на Atheros qcwb833? Я просто совсем не умею в это.

 , , ,

umdacc ()

Atheros и MAC адрес - проблемки на ровном месте

Всем доброго времени суток. Есть один интересный кейс, суть вот в чем: посмотрев на мать своего ноута, обнаружил, что сетевку AR8152 можно заменить на AR8151, при условии добавления мелочевки вокруг. Заменил, добавил, все работет. Но есть нюанс: MAC адрес на ней рандомно меняется, на старой такого не было.

Есть момент: я могу прописать адрес руками в софт, но не хочу, нужно от этого аппарата более устойчивое положение в сети при замене софта

На реалтеке я менял адрес, зашив в сетевку спец утилитой, а на сайте Qualcomm я чуть ноги не сломав так и не нашел куда им писать вопросы подобного характера.

Может кто знает, можно ли чем-нибудь вшить адрес в сетевуху? Не важно каким софтом и под какую платформу.

 , ,

lord_iu ()

Как узнать какой чипсет WI-FI поддерживает режим монитора а какой нет?

Кто знает как определить какой чипсет WI-FI поддерживает режим монитора а какой нет? Если конкретно, то меня интересуют вот эти чипы Atheros AR7240 и Atheros AR9342. В гугле про них ничего не нашел. Смотрел эту таблицу https://en.wikipedia.org/wiki/Comparison_of_open-source_wireless_drivers но похоже в ней не все чипы есть. Если кто знаком с чипами Atheros AR7240 и Atheros AR9342 отпишитесь.

 , , ,

MRX256 ()

Не работает wifi atheros на ноутбуке с Debian

Добрый день! Помогите решить проблему с неработающим wifi!

Ноутбук dell 3584-7386. Недавно установил Debian 10 + openbox. Сразу же поставил firmware-atheros. Через wicd подключился к wifi, нормально работало весь вечер. На следующее же утро не могу подключиться.

Сначала подумал что имя интерфейса изменилось, в wicd ведь его надо руками указать. Однако ifconfig -a выдает только проводное соединение, через которое я сейчас и подключен.

enp1s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500

sudo rfkill list и sudo rfkill —output-all не выдают ничего sudo rfkill unblock all не помогает

через lspci адаптер виден:

02:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)

fn+PrintScreen, на котором комбинация включения wifi, тоже не помогает)

Пару недель назад ставил Ubuntu Server 18.04 + openbox + wicd/network-manager и происходила такая же ерунда. Т.е. от версии ядра, видимо, не зависит проблема.

Также пробовал десктопные ubuntu, kubuntu — там такого косяка не наблюдал, но по некоторым причинам, я не хочу использовать тяжелые de, да и убунту вообще.

P.S. На линукс перешел чуть более полугода назад, многих вещей не понимаю, обьясняйте подробнее, пожалуйста, хочу все знать)

 ,

user464 ()

WLE900VX (QCA9880) + hostapd?

Интерес ваш опыт по такой связке. В плане работы с hostapd и 802.11ac. Стоит ли покупать и вообще связываться с QCA9880. Другие варианты? Есть ли подводные камни?

 , ,

deuser ()

Как установить опенсорсные драйвера для Atheros 9271 на Debian?

В общем есть USB WI-FI адаптер TP Link TL-722n первой ревизии на Atheros AR9271 и есть комп на котором установлен Debian. Вставляю в комп этот адаптер, смотрю командами ifconfig или iwconfig и комп этого адаптера не видит. Гугл привел меня к вот этой инструкции https://wiki.debian.org/ath9k_htc но меня смущает то что в командах есть «non-free». Как установить именно полностью опенсорсные драйвера для этого адаптера в Debian?

 , , ,

MRX256 ()

Какие модели Wi-Fi сейчас на чипе Atheros?

Давно брал, сейчас тоже хотелось бы такой за абсолютно беспроблемную работу в Linux. Но с удивлением обнаружил, что например, модель TP-Link TL-WN881ND раньше были на Atheros, сейчас на Realtek, с совершенно тем же названием. Тоже и с моделью 722

Есть что-то проверенное в торговле сейчас, а не старые запасы?

 ,

praseodim ()

ath10k btcoex_enable

Добрый день.

Гуглил проблему, о ней есть информация, но не нашел решения. В кратце: есть ноутбук Lenovo V330-14ikb с сетевым адаптером Qualcomm Atheros QCA9377 802.11ac. Стоит драйвер ath10k. Приобрёл я значит блютуз-наушники. Подключаются нормально, есть проблема с работой микрофона на линуксе, но эт отдельная тема.

О проблеме: при подключении наушников по блютуз и проигрывании чего-то онлайн, случается вот такое:

doctor@tardis:~$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=120 time=214 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=120 time=4010 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=120 time=3537 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=120 time=2541 ms
64 bytes from 8.8.8.8: icmp_seq=6 ttl=120 time=1517 ms

Гугл говорит, что такое случается, так как блютуз и вай-фай используют 2,4Ghz и на линуксах проблема решается ключом parm: btcoex_enable. НО, этот параметр доступен только на ath9k, а ath10k идёт без данного параметра, из-за проприетарщины, как я понял. Я попробовал использовать ath9k в качестве драйвера - добавил ath10k в блэклисты, добавил ath9k в modules, при включении загружается именно ath9k, блютуз работает. Только теперь не грузится wifi. Почему-то сетевой адаптер всё равно хочет видеть ath10k_pci, хотя он и не загружен:

lspci -knn | grep Net -A3 
02:00.0 Network controller [0280]: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter [168c:0042] (rev 31)
	Subsystem: Lenovo QCA9377 802.11ac Wireless Network Adapter [17aa:0901]
	Kernel modules: ath10k_pci

И вот я хз. Можно ли как-то поменять настройки адаптера, чтоб он обращался к ath9k? Либо, если ath9k не работает с моим адаптером, то возможно ли использовать ath10k для вай-фая и ath9k для блютуза одновременно? Или есть ли другие способы решения проблемы?

 

Datt_ ()

usb 1-4: string descriptor 0 read error: -22

Здравствуйте.

ОС Debian 9, 4.9.0-8-amd64.

При загрузке

usb 1-4: string descriptor 0 read error: -22

На usb 1-4 висит Bluetouth:

ID 13d3:3393 IMC Networks

Firmware под него установлено:

apt-get install firmware-linux firmware-atheros
Blietouth работает, устройства видит, но ошибка в dmesg все-равно пристутствует.

Жить не мешает, но хотелось бы понять причину.

 ,

Neuro75 ()

Подскажите на счет wi-fi модуля для ноутбука

Сейчас стоит такая карточка:

https://wikidevi.com/wiki/Dell_Wireless_1810_(DW1810)

lspci | grep -i network
3a:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)

В спецификации указано abgn+ac, 1x1:1.

В принципе, карточка работает без проблем. Но есть возможность выбрать и обменять ее на другую.

1. Правильно ли я понимаю, что для установки модуля с MIMO 2x2 или 3x3 в ноутбуке должно быть физически большее количество антенн?

2. В зависимости от ответа на первый вопрос, посоветуйте максимально беспроблемный, быстрый и энергоеффективный модуль под Linux.

 , , ,

aquadon ()

ath10k_pci: Direct firmware load failed

Debian Stretch, Сеть работает, но есть такие ошибки.

sudo dmesg | grep ath10k
[   19.989036] ath10k_pci 0000:3a:00.0: enabling device (0000 -> 0002)
[   19.990336] ath10k_pci 0000:3a:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[   20.274640] ath10k_pci 0000:3a:00.0: firmware: failed to load ath10k/pre-cal-pci-0000:3a:00.0.bin (-2)
[   20.274642] ath10k_pci 0000:3a:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:3a:00.0.bin failed with error -2
[   20.274651] ath10k_pci 0000:3a:00.0: firmware: failed to load ath10k/cal-pci-0000:3a:00.0.bin (-2)
[   20.274652] ath10k_pci 0000:3a:00.0: Direct firmware load for ath10k/cal-pci-0000:3a:00.0.bin failed with error -2
[   20.276179] ath10k_pci 0000:3a:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/firmware-5.bin
[   20.276183] ath10k_pci 0000:3a:00.0: qca9377 hw1.1 target 0x05020001 chip_id 0x003821ff sub 1028:1810
[   20.276185] ath10k_pci 0000:3a:00.0: kconfig debug 0 debugfs 0 tracing 0 dfs 0 testmode 0
[   20.276637] ath10k_pci 0000:3a:00.0: firmware ver WLAN.TF.1.0-00267-1 api 5 features ignore-otp crc32 79cea2c7
[   20.338321] ath10k_pci 0000:3a:00.0: board id is not exist in otp, ignore it
[   20.339366] ath10k_pci 0000:3a:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/board-2.bin
[   20.339376] ath10k_pci 0000:3a:00.0: failed to fetch board data for bus=pci,vendor=168c,device=0042,subsystem-vendor=1028,subsystem-device=1810 from ath10k/QCA9377/hw1.0/board-2.bin
[   20.339584] ath10k_pci 0000:3a:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/board.bin
[   20.339596] ath10k_pci 0000:3a:00.0: board_file api 1 bmi_id N/A crc32 544289f7
[   22.113597] ath10k_pci 0000:3a:00.0: htt-ver 3.1 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[   22.121537] ath10k_pci 0000:3a:00.0 wlp58s0: renamed from wlan0

Файлов pre-cal-pci-0000:3a:00.0.bin и cal-pci-0000:3a:00.0.bin в /lib/firmware/ath10k не существует. Может нужно добавть символьную ссылку?

 , ,

aquadon ()

WiFi AP 5GHz ath10k "(no IR)"

Имеется сетевая карта:

Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
Хочу попробовать у себя WiFi AP в 5GHz. Проблема в том что в карте зашит регион «global» (он же world) я прописал «RU» но разрешения «складываются»(нельзя + можно = нельзя) iw reg get:
global
country RU: DFS-ETSI
        (2402 - 2482 @ 40), (N/A, 20), (N/A)
        (5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW
        (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW
        (5650 - 5730 @ 80), (N/A, 30), (0 ms), DFS
        (5735 - 5835 @ 80), (N/A, 30), (N/A)
        (57000 - 66000 @ 2160), (N/A, 40), (N/A)
и соответственно hostapd не запускается.

Я нагуглил следующие решения openwrt_pathes в часности 402 патч позволяет системе «забить» на redomain который прошит в eeprom. Но проблема в том что патчи видимо староваты и в моих исходниках ядра(linux-headers-4.15.0-42) нет файла «drivers/net/wireless/ath/regd.c». Система ubuntu 18.04.

Выхлоп iw list с проблемой:

                Frequencies:
                        * 5180 MHz [36] (20.0 dBm) (no IR)
                        * 5200 MHz [40] (20.0 dBm) (no IR)
                        * 5220 MHz [44] (20.0 dBm) (no IR)
                        * 5240 MHz [48] (20.0 dBm) (no IR)
                        * 5260 MHz [52] (20.0 dBm) (no IR, radar detection)
                        * 5280 MHz [56] (20.0 dBm) (no IR, radar detection)
                        * 5300 MHz [60] (20.0 dBm) (no IR, radar detection)
                        * 5320 MHz [64] (20.0 dBm) (no IR, radar detection)
                        * 5500 MHz [100] (disabled)
                        * 5520 MHz [104] (disabled)
                        * 5540 MHz [108] (disabled)
                        * 5560 MHz [112] (disabled)
                        * 5580 MHz [116] (disabled)
                        * 5600 MHz [120] (disabled)
                        * 5620 MHz [124] (disabled)
                        * 5640 MHz [128] (disabled)
                        * 5660 MHz [132] (30.0 dBm) (no IR, radar detection)
                        * 5680 MHz [136] (30.0 dBm) (no IR, radar detection)
                        * 5700 MHz [140] (30.0 dBm) (no IR, radar detection)
                        * 5720 MHz [144] (30.0 dBm) (no IR, radar detection)
                        * 5745 MHz [149] (30.0 dBm) (no IR)
                        * 5765 MHz [153] (30.0 dBm) (no IR)
                        * 5785 MHz [157] (30.0 dBm) (no IR)
                        * 5805 MHz [161] (30.0 dBm) (no IR)
                        * 5825 MHz [165] (30.0 dBm) (no IR)
                        * 5845 MHz [169] (disabled)
Может кто сталкивался с решением данной проблемы? Есть ли иные способы обхода, или наименьшее из зол только ядро патчить?

Просто перед тем как продолжить копать далее данную тему, хотелось бы узнать чужой опыт.

 , ,

Miss_Burpl ()

QCA6174, Debian 9, Подключается но не работает.

Здравствуйте, товарищи.

Ситуация:
Ноутбук Acer aspire A717-71G.
ОС: Debian 9.5 Stretch
И всё то на нём хорошо, кроме Wi-fi карты Qualcomm Atheros QCA6174

А именно:

Драйвер установлен, прошивка установлена, Wi-fi карта определяется, Network manager успешно подключает её к сети, и даже получает IP-адрес, но после этого данные не передаёт совершенно.

Другие ПК (в том числе на Debian Linux 8 и 9) и телефоны прекрасно подключаются к той же самой сети.

Оборудование: https://pastebin.com/cRe7YkE7

Ядро: 4.9.0-8-amd64 #1 SMP Debian 4.9.110-3+deb9u6 (2018-10-08) x86_64 GNU/Linux

apt search firmware-atheros:
firmware-atheros/now 20180825+dfsg-1~bpo9+1 all [установлен, локальный] Binary firmware for Atheros wireless cards

apt search firmware-linux:
firmware-linux/stable,stable,now 20161130-3 all [установлен] Binary firmware for various drivers in the Linux kernel (meta-package)

firmware-linux-free/stable,stable,now 3.4 all [установлен] бинарные микропрограммы различных устройств для ядра Linux

firmware-linux-nonfree/stable,stable,now 20161130-3 all [установлен] Binary firmware for various drivers in the Linux kernel (meta-package)

Сообщения «dmesg | grep ath10k»:
https://pastebin.com/H1j1bJK5

Сообщения dmesg при подключении к WiFi-сети:
https://pastebin.com/EW23ynfU

Собственно последние строчки из dmesg (IPv6: wlp2s0: IPv6 duplicate address fd01::525b:c2ff:fe7e:aa5 detected! ) меня и наводят на странные мысли.

Я пробовал отключить для карты IPv6 с помощью настроек NetworkManager'а и путём танцев с бубном, выразившихся в подключении/отключении соединения, выполнения dhclient, и подобных вещей, мне 1 раз удалось заставить её работать, но воспроизвести свою последовательность действий я уже не смог, и после очередного пробуждения из спящего режима всё опять вернулось в нерабочее состояние.

Что ещё можно предпринять для решения проблемы?

 , ,

MihanEntalpo ()

помогите создать правило для UDEV

Linux Mint 19

При каждом включении мне приходиться постоянно делать ручную установку драйвера ath9k Wi-Fi usb модуля (AR9374).

При этом я выполняю указанные команды

modprobe ath6kl_usb

echo 27d5 0080 > /sys/bus/usb/drivers/ath6kl_usb/new_id

Чтобы не требовалось это делать при каждой загрузке я пробовал создать правило nano /etc/udev/rules.d/10-own.rules

SUBSYSTEM==«net», ATTR{address}==«c0:3e:0f:12:d9:8c», RUN+=«СКРИПТ???»,

Помогите составить именно СКРИПТ..не имею еще опыта

спасибо

 

IURII ()

Помогите установить драйвер ath9k Wi-Fi usb модуля (AR9374)

Не знаю где найти драйвер и как его установить по тем данным что в этих двух ссылках - не получается. http://ubuntuforums.org/showthread.php?t=2103062 http://askubuntu.com/questions/215498/upcoming-support-for-qualcomm-atheros-a...

 

IURII ()

Медленная скорость загрузки E2400

Всем привет. Являюсь обладателем материнки с такой сетевой картой:

Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller [1969:e0a1]
Драйвер, который автоматом подхватился - alx. Проблема в том, что при тарифе 100Мбит/с я имею фактическую скорость загрузки 8-15 Мбит/с в зависимости от ресурса. Замерял на нескольких сервера speedtest, пробовал несколько торрентов с большим количеством сидов, пробовал скачивать большие файлы через браузер. Максимум что увидел - 2,2 МБайт/с. Пишу сюда не сразу, сначала я попробовал найти решение сам. Нашел похожие случаи но не с такой картой. Рекомандовали проверить режим - должен быть полный дуплекс. У меня он полный:
Settings for enp7s0:
	Supported ports: [ TP ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Supported pause frame use: Symmetric Receive-only
	Supports auto-negotiation: Yes
	Supported FEC modes: Not reported
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Advertised pause frame use: Symmetric
	Advertised auto-negotiation: Yes
	Advertised FEC modes: Not reported
	Speed: 100Mb/s
	Duplex: Full
	Port: Twisted Pair
	PHYAD: 0
	Transceiver: internal
	Auto-negotiation: on
	MDI-X: Unknown
Cannot get wake-on-lan settings: Operation not permitted
	Current message level: 0x000060e4 (24804)
			       link ifup rx_err tx_err hw wol
	Link detected: yes
Так же рекомендовали поиграться с mtu в пределах 1490-1500. Я попробовал все значения с перезагрузкой network-manager. Результат +- не изменился. Еще рекомендовали попробовать другие способы подключения, кроме n-m. Попробовал подключаться через connman. Так же ничего не изменилось. Подскажите, пожалуйста, какие еще проверки можно провести, чтобы определить причину. С такой скоростью после 100 Мбит/с совершенно некомфортно.
P.S. Скорость отдачи в порядке.
P.P.S. В дуалбуте windows 7 - там все ок.

 , ,

Linux_Newbie ()

MiniPCIe Wifi адаптер для ноутбука

Задумал обновить wifi карточку в ноуте, смотрю на чипы от Atheros, т.к. хочу без адаптер без блоба и хорошей поддержкой в ядре + bluetooth. Офигенные скорости, ac режим, 5GHz не обязательны, но почему бы и нет. Что мудрые люди посоветуют?

 , ,

ia666 ()

Не могу заставить aircrack-ng работать.

Мне нужно перевести сетевуху в режим мониторинга, вот эту:

0c:00.0 Network controller: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) (rev 01)
	Subsystem: Lite-On Communications Inc AR9287 Wireless Network Adapter (PCI-Express)
	Flags: bus master, fast devsel, latency 0, IRQ 17
	Memory at f69f0000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: <access denied>
	Kernel driver in use: ath9k
	Kernel modules: ath9k

Я убиваю все мешающиеся проги, а именно NetworkManager и avahi-daemon, после чего пишу:

airmon-ng start /dev/wlan0
И получаю в ответ:
[root@dell2 romashev]# airmon-ng start /dev/wlan0


PHY	Interface	Driver		Chipset

phy0	wlan0		ath9k		Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) (rev 01)

Устройства по адресу /dev/mon0 не появляется. Но во-первых у меня на самом деле нет и /dev/wlan0, ровно как и /dev/phy0, во-вторых совершенно неясно, почему в таком случае iwconfig отвечает так:

[root@dell2 romashev]# iwconfig 
wlan0     IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=16 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
lo        no wireless extensions.

eth0      no wireless extensions.

Помогите разобраться, пожалуйста.

 , ,

Deleted ()