LINUX.ORG.RU

13
Всего сообщений: 388

Поиск/удаление файлов в /usr, не входящих ни в один пакет (debian)

Есть ли готовые инструменты?

 , ,

Harliff ()

Помогите, у меня сломался debian/linux mint debian edition

При попытке установить цинамон, так как он у меня удалился выдаётся ошибка:

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 mint-meta-cinnamon : Зависит: mint-meta-core но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

Я всё перепробовал, но ничего не получается, как быть? И зависимсоти пробовал ставить, но там ещё миллион зависимостей вручную просят ставить, все инструкции из интернета делал, помогите.

 ,

enot_obrmot ()

Debian: какой приоритет выставить репозиториям?

Немного запутался. Установил Деб Bullseye, но некоторые пакеты очень хочется из Bookworm. Допустим, я добавил источник в sources.list и теперь хочу, чтобы нужные мне пакеты и необходимые версии зависимостей подтягивались из тестинга, например, через apt -t bookwarm install somepackage, но всё остальное не обновлялось. Какой приоритет надо выставить в /etc/apt/preferences? Пока сделал примерно так:

Package: *
Pin: release a=testing
Pin-Priority: 400

Я так ничего не сломаю? Все зависимости подтянутся нужных версий?

 , , ,

potustoronnim_v ()

Ansible установка всех пакетов (deb) из директории, не с помощью dpkg -i *.deb

Не могу найти решение может кто подскажет?

 , ,

Ramzes_116 ()

Кто собирал пакеты для Debian? Прошу помощи

Доброго дня, ЛОР!

У кого есть опыт, прошу поделиться: есть ли какая-нибудь деректива в пакете, которая может исполнить bash-сценарий ДО начала установки зависимостей, указанных у этого пакета. Конкретно нужно несколько вызовов debconf-set-selections, чтобы пакеты в зависимостях установились с заранее выбранными ответами без интерактивного окна.

Большое спасибо! Буду очень рад, если такой инструмент имеется :)

 , ,

rmu ()

Как в apt посмотреть список обновлений из backports?

Я всю жизнь пользовался aptitude и там можно было сделать так:

$ aptitude -t bullseye-backports search ~U
i A libldap-2.4-2                                                                 - OpenLDAP libraries                                                                     
i A libldap-common                                                                - OpenLDAP common files for libraries                                                    
i   mdadm                                                                         - Tool to administer Linux MD arrays (software RAID)                                     
i   zabbix-agent                                                                  - network monitoring solution - agent

В apt наконец тоже завезли шаблоны и я на него уже почти полностью перелез, но держит одна фигня:

$ apt -t bullseye-backports list --upgradable 
E: Command line option 't' [from -t] is not understood in combination with the other options.
$ apt -t bullseye-backports list ~U
E: Command line option 't' [from -t] is not understood in combination with the other options.
$ apt -t bullseye-backports search ~U
Sorting... Done
Full Text Search... Done
$ 
$ 
$ sudo apt -t bullseye-backports full-upgrade 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  libldap-2.4-2 libldap-common mdadm zabbix-agent
4 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 1 382 kB of archives.
After this operation, 37,9 kB of additional disk space will be used.
Do you want to continue? [Y/n]

Что за фигня, почему ключ -t работает только с install/upgrade?!

 , , ,

Turbid ()

builddeps:kodi : Зависит: libmodplug-dev но он не будет установлен

В Kodi нет звука около секунды после паузы. Проблема уже обсуждалась и лучше объяснена здесь. Я воспользовался тем решением.

Пункт 3.a инструкции

# apt build-dep kodi
Чтение списков пакетов… Готово
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 builddeps:kodi : Зависит: libmodplug-dev но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

Ubuntu 18.04

$ dpkg -l | grep 'kodi'
ii  kodi                                                        2:17.6+dfsg1-1ubuntu1                                       amd64        Open Source Home Theatre (executable binaries)
ii  kodi-bin:amd64                                              2:17.6+dfsg1-1ubuntu1                                       amd64        Open Source Home Theatre (architecture-dependent files)
ii  kodi-data                                                   2:17.6+dfsg1-1ubuntu1                                       all          Open Source Home Theatre (arch-independent data package)
ii  kodi-repository-kodi                                        2:17.6+dfsg1-1ubuntu1                                       all          Open Source Home Theatre (official addons repository feed)
ii  kodi-visualization-spectrum:amd64
$ apt search libmodplug-dev
Сортировка… Готово
Полнотекстовый поиск… Готово
libmodplug-dev/bionic 1:0.8.9.0-1 amd64
  development files for mod music based on ModPlug

libopenmpt-modplug-dev/bionic,now 0.3.6-1 amd64 [установлен]
  module music library based on OpenMPT -- modplug compat development files

 ,

damix9 ()

Система удаляет все компоненты

Здравствуйте,сегодня я решил установить питон,там возникли ошибки и я удалил python3-pip(apt remove python3-pip),а затем хотел удалить и питон сам,для переустановки,но… https://i.imgur.com/OgVdzy7.jpg Система всё пытается удалить всё и это уже не первый раз,я не понимаю почему так происходит.Я скачиваю всё из официальных источников и вируса быть не должно быть. Условия глюка: OS: Deepin 20.2.2 x86_64 Kernel: 5.10.36-amd64-desktop Terminal: xfce4-terminal (такое происходит и в deepin терминале)

Попытка удаления python2: https://i.imgur.com/kCp95nT.jpg

Система вроде нормальная,исправно работает,не даёт ошибок почти никогда.Графическую оболочку не менял.В ядро не лез,системные приложения не менял. На других системах такого не было,пожалуйста,подскажите как с этим бороться.

Перемещено shell-script из linux-hardware

 , ,

Kirilus3000 ()

Как решить ошибка dpkg: список файлов пакета $имя пакета отсутствует?

При установке пакета gstreamer1.0-tools получил такую ошибку.Теперь при удалении и установки пакетов она вылезает.

dpkg: предупреждение: список файлов пакета «libboost-system1.67.0:armhf» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: unrecoverable fatal error, aborting:
 список файлов пакета «libboost-chrono1.67.0:armhf» содержит пустое имя файла

Версия linux:

Linux raspberrypi 4.19.75+ #1270 Tue Sep 24 18:38:54 BST 2019 armv6l GNU/Linux

Версия apt:

apt 1.8.2 (armhf)

 ,

Un_ka ()

Проблема с пакетами

Здравствуйте, решал проблему с mysql и судя по всему после этой команды rm /var/lib/dpkg/info/$nomdupaquet* -f у меня при установке или удалии пакета появляется много варнингов, один из них:

dpkg: предупреждение: список файлов пакета «libwayland-client0:i386» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов

Пробовал переустановить все пакеты через Synaptic, под конец появилась какая-то ошибка и ничего не изменилось.

 , ,

pthon ()

Как вернуться с Debian unstable на stable

Доброго дня, система Debian 10. Случайно оставил unstable запись в apt/sources.list и перешел в usntable версию. Подскажите пожалуйста способы возвращения назад безе переустановки всей системы.

 , ,

ettaluni ()

apt upgrade — работает на одном процессоре

Новый комп с amd ryzen 9 3900x, пакеты обновления устанавливаются также как на старом буке. почему когда устанавливается/обновляется новое ядро Linux (самый большой пакет) используется только один процессор из 12. Можно как-то в настройках установить, чтобы использовалось больше ядер.

 , ,

sap78 ()

Среда. DNF медленный. В КДЕ много настроек.

Добрый день.

Всем известно, что dnf – самый медленный пакетный менеджер в линуксе. Если не считать портажа, конечно. И действительно, любая операция в dnf начинается с некоторой задумчивости. Поиск, установка, удаление – разумеется с опцией -C в т.ч. У меня в виртуалке установлено несколько систем, чтобы смотреть новинки, такие как Fedora Rawhide, KDE Neon, Ubuntu LTS (смотреть новинки). Периодически в каждой накапливаются обновления на 300-400Mb, которые надо бы установить. И вот что я заметил: dnf хоть и медленно стартует, но при этом сами обновления устанавливает довольно быстро. Т.е. чисто установка, не считая обновлений базы данных, скачивания и т.д.

Когда же дело доходит до apt – это просто какое-то мучение. Поиск, скачивание – все это проходит быстро. Но вот именно установка прямо ООООЧЕНЬ медленная. Это особенно заметно при ограниченных ресурсах типа виртуалки, когда надо установить 300-400Мб обновлений.

Так что не все так однозначно.


Еще один вопрос, который меня взволновал в среду. В виртуалках конечно нет никакой необходимость локать экран через 5-10 минут, чтобы не вводить каждый раз пароль. Поэтому хорошо бы эту фичу отключить. Но почему я – опытный пользователь, который использовал почти все существующие ДЕ и ВМ во всех системах не могу найти такой опции в КДЕ? Очевидно, она должна быть где-то в Power Management, вижу там Screen Energy Saving – отключаю его, ничего не происходит. Это нормально? Половина вообще каких-то левых опций, другая половина работает криво. КДЕ как есть.


Вспомнил, что нужно бы добавить в алиас apt_upgrade команду sudo apt autoremove. Так, где тут кнопка Открыть новый таб в терминале? Господь, ее тут нет?! Ладно, через меню:

File -> New Tab -> С каким профилем желаете открыть новый таб?

ПРОСТО ОТКРОЙ УЖЕ ГРЕБАНЫЙ ТАБ!

Эргономика в КДЕ выше всяких похвал. Сразу видно, специально обученные люди думали над каждым пунктом меню, над каждой опцией, над каждым чекбоксом. И думали они буквально следующее ВЫСРЕМ В КУЧУ, МОЖЕТ КОМУ ПОНАДОБИТСЯ ЛОЛ, ЛИШНИМ НЕ БУДЕТ!.

И все это под клоунский курсорный спиннер с кривыми краями. Не хватает только КДЕшной музыки.

 , ,

Im_not_a_robot ()

Такие странные зависимости

ставлю на debian netinstall plasma desktop
предлагает в т.ч. x11-common x11-utils x11-xserver-utils xdg-utils xml-core
но не сам xserver-xorg
хотя и ежу понятно, что кеды без иксов не запустятся. а вот без vlc-data vlc-plugin-base легко

зачем указывать такие неполные зависимости?

 ,

darkenshvein ()

Проблема с sources.list

Дал ноутбук с Kali Linux другу на день, для чегото ему нужна была эта операционка, по возвращению я обнаружил проблему что при вводе apt update выводит это: E: Некорректная строка 1 в списке источников /etc/apt/sources.list (тип) E: Не удалось прочитать перечень источников. Помогите пожалуйста

 , ,

Kit_Montag ()

Порядок пакетов apt

Здравствуйте! Есть ли такая штука, чтобы можно было указать порядок, в котором apt будет приоритезировать репозитории? Мол: «Ты сначала в локальной репе посмотри, если есть – бери, и не смотри, что эта версия на 0.0.1 старее интернетовской – ничего толком нового там нет, только время и трафик потеряем»?

 

ShkiperDesna ()

Проблема с репозиторием apache ambari

Всем привет, ставлю apache ambari из репозиториев Cloudera Ловлю access denied… Еще пару дней назад все работало. Мб кто то знает в чем дело? Или только у меня так. МБ Cloudera совсем гайки закрутила и не дает даже старые версии качать?.

 , , ,

Flover ()

ошибка при конфигурации

Установил pure os и захотел запустить ssh ,а тут нет демона я попытался установить openssh-client openssh-server ,что-то сломалось и теперь вообще не могу установить пакеты . Помогите пожалуйста,спасибо)

You might want to run ‘apt –fix-broken install’ to correct these. The following packages have unmet dependencies: mysql-cluster-community-client : Depends: mysql-cluster-community-client-core (= 8.0.23-1debian10) but it is not going to be installed ssh : Depends: openssh-client (>= 1:7.9p1-10+deb10u2) but it is not going to be installed Depends: openssh-server (>= 1:7.9p1-10+deb10u2) but it is not going to be installed E: Unmet dependencies. Try ‘apt –fix-broken install’ with no packages (or specify a solution).

dpkg: error processing archive /var/cache/apt/archives/mysql-cluster-community-client-plugins_8.0.23-1debian10_amd64.deb (–unpack): trying to overwrite ‘/usr/lib/mysql/plugin/authentication_ldap_sasl_client.so’, which is also in package mysql-community-client-plugins 8.0.23-1debian10 dpkg-deb: error: paste subprocess was killed by signal (Broken pipe) Preparing to unpack …/mysql-cluster-community-client-core_8.0.23-1debian10_amd64.deb … Unpacking mysql-cluster-community-client-core (8.0.23-1debian10) … dpkg: error processing archive /var/cache/apt/archives/mysql-cluster-community-client-core_8.0.23-1debian10_amd64.deb (–unpack): trying to overwrite ‘/usr/bin/mysql’, which is also in package mysql-community-client-core 8.0.23-1debian10 dpkg-deb: error: paste subprocess was killed by signal (Broken pipe) Errors were encountered while processing: /var/cache/apt/archives/mysql-cluster-community-client-plugins_8.0.23-1debian10_amd64.deb /var/cache/apt/archives/mysql-cluster-community-client-core_8.0.23-1debian10_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

 ,

zero_one_two ()

apt: auto --install-recommends

Здравствуйте! Я активно использую apt и практически каждый раз я пишу: sudo apt install --install-recommends --install-suggests -y .... Можно ли сделать эти настройки (автоматическая установка рекомендованных пакетов) автоматическими?

 

ShkiperDesna ()

(Xubuntu 18.04.5) dpkg не может обработать пакеты

Здравствуйте.

sudo apt install -f, sudo apt update, sudo apt upgrade не работают.

Помогите пожалуйста.

Лог apt:

usr@945GCM:~$ sudo apt install -f Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено. Установлено или удалено не до конца 3 пакетов. После данной операции объём занятого дискового пространства возрастёт на 0 B. Настраивается пакет cups-daemon (2.3.1-9ubuntu1.1) … invoke-rc.d: syntax error: unknown option "--skip-systemd-native" dpkg: ошибка при обработке пакета cups-daemon (--configure): installed cups-daemon package post-installation script subprocess returned error exit status 1 dpkg: зависимости пакетов не позволяют настроить пакет cups-core-drivers: cups-core-drivers зависит от cups-daemon (>= 2.3.1-9ubuntu1.1), однако: Пакет cups-daemon пока не настроен.

dpkg: ошибка при обработке пакета cups-core-drivers (--configure): проблемы зависимостей — оставляем не настроенным dpkg: зависимости пакетов не позволяют настроить пакет cups: cups зависит от cups-core-drivers (>= 2.3.1-9ubuntu1.1), однако: Пакет cups-core-drivers пока не настроен. cups зависит от cups-daemon (>= 2.3.1-9ubuntu1.1), однако: Пакет cups-daemon пока не настроен.

dpkg: ошибка при обработке пакета cups (--configure): проблемы зависимостей — оставляем не �Отчёт apport не записан, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа. Отчёт apport не записан, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа. �астроенным При обработке следующих пакетов произошли ошибки: cups-daemon cups-core-drivers cups E: Sub-process /usr/bin/dpkg returned an error code (1)

usr@945GCM:~$_

 , , ,

KATAR7 ()