LINUX.ORG.RU

Сообщения kolobchanin

 

Падают иксы

Доброго времени суток! Столкнулся с проблемой: если в настройках SMplayer или VLC выставить вывод видео через xv, то при воспроизведении видео у меня падают иксы. Если сменить вывод на gl или gl2 - не падают. После очередного «падения» я заглянул в логи иксов обнаружил там следующее:

[ 5652.272] Backtrace:

[ 5652.289] 0: /usr/bin/Xorg (xorg_backtrace+0x26) [0x7fb35f76d9b6]

[ 5652.289] 1: /usr/bin/Xorg (0x7fb35f5e9000+0x188619) [0x7fb35f771619]

[ 5652.289] 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7fb35e911000+0xf030) [0x7fb35e920030]

[ 5652.290] 3: /usr/lib/xorg/modules/drivers/fglrx_drv.so (xs111LookupPrivate+0x22) [0x7fb35b20cfb2]

[ 5652.290] 4: /usr/lib/xorg/modules/drivers/fglrx_drv.so (xclLookupPrivate+0xd) [0x7fb35abdb01d]

[ 5652.290] 5: /usr/lib/xorg/modules/amdxmm.so (X740XvPutImage+0x12e) [0x7fb357f7e8de]

[ 5652.290] 6: /usr/bin/Xorg (0x7fb35f5e9000+0xa69ee) [0x7fb35f68f9ee]

[ 5652.290] 7: /usr/lib/xorg/modules/extensions/libextmod.so (0x7fb35c713000+0x12e02) [0x7fb35c725e02]

[ 5652.290] 8: /usr/bin/Xorg (0x7fb35f5e9000+0x51fc9) [0x7fb35f63afc9]

[ 5652.290] 9: /usr/bin/Xorg (0x7fb35f5e9000+0x4122a) [0x7fb35f62a22a]

[ 5652.290] 10: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xfd) [0x7fb35d63cead]

[ 5652.290] 11: /usr/bin/Xorg (0x7fb35f5e9000+0x4151d) [0x7fb35f62a51d]

[ 5652.290] Segmentation fault at address 0x20

[ 5652.290]

Fatal server error:

[ 5652.290] Caught signal 11 (Segmentation fault). Server aborting

[ 5652.290]

[ 5652.290] Please consult the The X.Org Foundation support at http://wiki.x.org for help.

[ 5652.290] Please also check the log file at «/var/log/Xorg.0.log» for additional information.

Система - Debian Sid.

Как думаете, в чём может быть проблема?

kolobchanin ()

Проблема с иксами на Debian sid

Здравствуйте, уважаемые лоровцы. Сегодня обновился со Squeeze на Sid и в итоге после перезагрузки получил чёрный экран. На ctrl+alt+F1(F2) и ctrl+alt+backspace не реагирует. Перезагрузился в recovery mode и менял дрова - c ati на radeon и radeonhd - не помогло. Потом поменял на vesa - заработало, но расширение 1024х768. Видюха - ati radeon hd4570. Никто с таким безобразием не сталкивался?

kolobchanin ()

Установка Debian Lenny

Доброго времени суток. Сегодня попытался поставить Debian Lenny на комп соседу. Как только дело доходит до стадии копирования файлов, установщик говорит, что не может прочитать файлы с диска. Дома на Virtual Box'e всё нормально встало. Никто с таким не сталкивался?

kolobchanin ()

Проблема с играми

Доброго времени суток, уважаемые линуксоиды!

Суть проблемы вот в чём: При попытке запустить любую игру под wine экран гаснет и на нём появляется надпись "input not supported".

Теперь подробнее, на примере Half-life2. Пытался запустить из консоли, вот вывод (wine hl2.exe -opengl -steam): ------ Engine initialized.. :) SteamStartup() SteamIsLoggedIn() SteamMountAppFilesystem() fixme:win:EnumDisplayDevicesW ((null),0,0x33e1ac,0x00000000), stub! err:d3d:getColorBits Unsupported format: WINED3DFMT_A16B16G16R16F SteamGetLocalFileCopy z:\mnt\windows\games\hl2ep1\bin\stdshader_dbg.dll SteamGetLocalFileCopy result 0x0 SteamGetLocalFileCopy z:\mnt\windows\games\hl2ep1\bin\stdshader_dx6.dll SteamGetLocalFileCopy result 0x0 SteamGetLocalFileCopy z:\mnt\windows\games\hl2ep1\bin\stdshader_dx7.dll SteamGetLocalFileCopy result 0x0 SteamGetLocalFileCopy z:\mnt\windows\games\hl2ep1\bin\stdshader_dx8.dll SteamGetLocalFileCopy result 0x0 SteamGetLocalFileCopy z:\mnt\windows\games\hl2ep1\bin\stdshader_dx9.dll SteamGetLocalFileCopy result 0x0 fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),0,3,(nil),0,(nil)) - stub! err:ole:CoGetClassObject class {4590f811-1d3a-11d0-891f-00aa004b2e24} not registered err:ole:CoGetClassObject no class object {4590f811-1d3a-11d0-891f-00aa004b2e24} could be created for context 0x1 fixme:keyboard:X11DRV_LoadKeyboardLayout L"00000409", 0000: stub! SteamFindFirst(): z:\mnt\windows\games\hl2ep1\hl2\bin\game_shader_generic* SteamGetLocalFileCopy z:\mnt\windows\games\hl2ep1\hl2\resource\game.ico SteamGetLocalFileCopy result 0x0 err:x11settings:X11DRV_ChangeDisplaySettingsEx No matching mode found 800x600x32 @60! (XRandR) SteamGetLocalFileCopy z:\mnt\windows\games\hl2ep1\hl2\media\Valve.avi SteamGetLocalFileCopy result 0x0 err:alsa:ALSA_copyFormat calculated 50 bytes, capping to 40 bytes fixme:wave:wodOpen unimplemented format: WAVE_FORMAT_ADPCM ------ После этого появляется заставка в окошке 800x600 в центре экрана. Шевелится она оооочень медленно. После того, как она всё-таки закончилась, экран гаснет и появляется надпись "input not supported". Помогает перезапуск иксов по ctrl+alt+backspace.

Система: Debian Lenny. Весь софт из пакетов, кроме дровов на видюху. Они скачаны с сайта производителя. Железо: -проц: celeron, тактовая 2800 -оператива: 1.5 гига -видюха: nvidia GForce 6600 -монитор: 17"

kolobchanin ()

Трабла с приводом

Доброго времени сток, уважаемые форумчане! Проблема такая: купил себе новый привод optiarc ad-7203a. Када я засовываю в него диск, система говорит, что я засунул чистый диск. Если монтировать через консоль (mount /dev/hda), он монтируется в папку /media/cdrom0, но гном продолжает утверждать, что диск пустой. Подскажите, пожалуйста, в чём проблема?

>>>

kolobchanin ()

RSS подписка на новые темы