LINUX.ORG.RU

Сообщения S7a1k3r

 

RTL8168b/8111b - Работает, но как-то странно

Форум — Linux-hardware

Доброго времени суток!

Есть сетевушка RTL8168b/8111b (Встроенная) и RealTek RTL8139 (PCI)

Проблема в том, что интерфейсы eth0 и eth1 вроде бы поднимаются, в лонах есть сообщения типа "eth0: link up".

Но происходит это как-то странно - по этим интерфейсам никакого трафика не идет :(. После нескольких перезагрузок все становится в порядке, а после следующей перезагрузки снова ничего не работает :(.

Драйвера для RTL8168b/8111b есть - r1000

В логах никаких ошибок нет, dmesg тоже никаких ошибок не выдает.

Выводы lsmod при работающих/не работающих сетевых картах ничем не отличаются.

Операционная система - arch linux 0.8 Ядро - 2.6.20 IP - статические на обоих сетевых картах.

Причем подобное происходит не впервые, на предыдущих ядрах было тоже самое.

Может быть кто-нибудь сталкивался?

S7a1k3r ()

Как заставить Radeon выдавать 85Гц в консоли

Форум — Linux-hardware

Доброго времени суток, уважаемые форумчане. Помогите кто нибудь. Давеча приобрел новый комп, установил на него арч, все в порядке - все работает. Но душа большего захотела :). А именно: 1024х768-32@85 В консоли + скины для консоли.

Было скачано ядро 2.6.19.1 c kernel.org И патчи vesafb-tng-1.0-rc2-2.6.19-rc2.patch fbsplash-0.9.2-r5-2.6.19-rc2.patch с http://dev.gentoo.org/~spock/

Соответственно пропатчил ядро

>patch -p1 < vesafb-tng-1.0-rc2-2.6.19-rc2.patch >patch -p1 < fbsplash-0.9.2-r5-2.6.19-rc2.patch

Ошибок не было. далее использовал конфиг от арчевского ядра

>make oldconfig

Скомпилил и установил

>make bzImage && make modules && make modules_install >cp arch/i386/boot/bzImage /boot/kernel-2.6.19.1 >mkinitcpio -k 2.6.19.1 -v -g /boot/init-2.6.19.1

Сделал запись в конфиге GRUB

>... >title new >root (hd0,1) >kernel /boot/kernel-2.6.19.1 root=/dev/sda2 ro >video=vesafb:ywrap,mtrr:2,1024x768-32@85 >initrd /boot/init-2.6.19.1

Система после это грузится, но консоль приобретает черный цвет и... все

>dmesg пишет >vesafb: error switching in mode eax=xxxx или что-то подобное.

>cat /proc/fb0/modes | grep 1024x768 >1024x768-8 >1024x768-16 >1024x768-24 >1024x768-32

Проблема в том что это все работает на nvidia 6200 и 6600 (pcie) а так же на radeon 9200 и 9600 (agp) (на других картах не пробовал)

А на x1300 отказывается Искал в гугле, получается, что vesafb-tng прекрасно уживается с radeon'ами А вмоем случае - нет. Может кто сталкивался?

Попробовал еще vesafb-rrc - таже история :(

Конфигурация: материнка: asus p5ld2 se Проц: pentium d 2.66 Видео: Asus EAX1300Pro (Radeon x1300)

Заренее спасибо за помощь.

S7a1k3r ()

RSS подписка на новые темы