LINUX.ORG.RU

Сообщения Practolog

 

Не работает многопоточность на с++11

Доброе время! Столкнулся с такой проблемой: написал helloWorld #include <iostream> #include <thread>

class background_task { public: void operator()() const { std::cout << «Hello, Multithreaded World!\n»; } };

int main() { background_task bgtask; std::thread mythread(bgtask); mythread.join(); return 0; }. При компиляции g++ -Wall -pthread -std=c++11 вылетает ошибка «terminate called after throwing an instance of 'std::system_error' what(): Enable multithreading to use std::thread: Operation not permitted Aborted (core dumped) »

 

Practolog
()

Не работает многопоточность на с++11

Доброе время! Столкнулся с такой проблемой: написал helloWorld #include <iostream> #include <thread>

class background_task { public: void operator()() const { std::cout << «Hello, Multithreaded World!\n»; } };

int main() { background_task bgtask; // Передаем в конструктор функтор std::thread mythread(bgtask); // Продолжаем вычисления в главном потоке mythread.join(); return 0; } При компиляции g++ -Wall -pthread -std=c++11 вылетает ошибка «terminate called after throwing an instance of 'std::system_error' what(): Enable multithreading to use std::thread: Operation not permitted Aborted (core dumped) »

Practolog
()

/bin/csh: плохой интерпретатор

Доброе время! Собираю glut из сырцов, при команде ./mkmkfiles.imake в корневой папке glut вылетает такая вот ошибка(«/bin/csh: плохой интерпретатор»). В интернете написано что косяк в кодировке. Установил dos2unix, перекодировал dos2unix ./mkmkfiles.imake. Запускаю, снова такая ошибка. Собственно нужен совет как установить библиотеку glut любым способом. Стоит xubuntu. Пробовал apt-get freeglut, glutlib, но в usr/lib так и не появилось глутовских либов. Заранее благодарен

Practolog
()

Добавление русской документации в Qt

Всем привет ! Стоит Qt SDK 4.8.2, приспичило поставить русскую документацию. Подскажите

Practolog
()

Проблема с зависимостями

Здравствуйте ! Поставил Debian и столкнулся с проблемой. При установке deb пакета (google-chrome-stable amd64) выскакивает сообщение «Ошибка: неразрешенная зависимость libcurl3). Что делать ?)

Practolog
()

RSS подписка на новые темы