LINUX.ORG.RU

Сообщения Opik

 

Flare 0.12

Flare v0.12 «Vendors» Released

It's only been a couple weeks but v0.12 is ready! Here's a quick list of changes since v0.12

Vendors have been added. Buy and sell items! There is one vendor at the spawn point and another vendor in the cave.
Voice-acting for the vendor by Brandon Morris (Augmentality)
Male vendor 3D model by TiZiana
Potions can be placed on the Action Bar. The number of remaining potions is shown. When you run out of that potion, the icon goes dark. Thanks to help from LongerDev.
Support for other powers on items has been added. This opens up the possibility for interesting items in the future (e.g. teleport boots).
Action is no longer paused when menus are open. This behavior can be changed in Settings.h. Contributed by LongerDev
Basic support for Mouse Movement added. Edit your save file and you'll see a mouse_move option. Contributed by Cheshire.
Mouse-over on creatures shows a menu with the monster's name, level, and health. Contributed by Cheshire.
Added a basic cmake file to the source distributable. Also rearranged the folder structure to make things easier for novice users. Thanks to gnurobert and ceninan for help on this!
Dying now has a penalty: 50% gold loss
Crits are more powerful and always do more damage than a regular attack.

http://clintbellanger.net/rpg/

Opik ()

vkontakte music player

Написал плеер для контакта, ибо в стандарте не хватало случайного проигрывания и прочих мелочей.
Использует Vkontakte API для получения плейлиста пользователя (программа спрашивает логин и пароль).
Написана на Qt4

Интересна ли программа кому?

Opik ()

[Qt4] Network & encoding

Есть некий QNetworkAccessManager, с его помощью получаю данные по HTTP, в UTF-8 кодировке (страница, к которой обращаюсь в юникоде), однако данные приходят в хрен его знает в каком виде, и отображаются, соответственно, какими-то кракозябрами. Гугл обиделся и не помогает :(

Opik ()

Горячие клавиши на не английской раскладке.

Тема измучена, поиском пользовался (и тут и гугла). Но максимум что нахожу по теме, так это проблему с Firefox. Но данная проблема в основном напрягает при работе с Eclipse.

И проблема номер 2. Как временный (не хотелось, что бы стал постоянным) костыль - забиндил смену раскладки на Shift + Alt (вместо привычного Ctrl + Shift). Ибо горячие клавиши не работали и в английской раскладке.

Есть ли спасение? :)

Opik ()

UDP: bad checksum и UDP: short packet

Администрирую сервер Counter-Strike 1.6 последнее время сервер стал часто валиться:
[1005315.100642] hlds_i686[28889]: segfault at 43c8d33b ip b7e03fb3 sp bff37e14 error 4 in libc-2.9.so[b7d93000+158000]
или
[935804.518743] hlds_i686[28290]: segfault at 0 ip b55dce91 sp bffbe770 error 4 in cs_i386.so[b5565000+136000]
также в dmesg много ошибок:
[851693.876911] UDP: bad checksum. From 201.13.151.129:57713 to 195.250.182.5:27015 ulen 33
[854540.658583] UDP: bad checksum. From 122.252.245.228:2245 to 195.250.182.5:27015 ulen 33
[855687.604988] UDP: bad checksum. From 189.18.4.119:1565 to 195.250.182.5:27015 ulen 33
[860052.204694] UDP: bad checksum. From 122.252.245.228:1821 to 195.250.182.5:27015 ulen 33
[860524.159011] UDP: bad checksum. From 122.252.245.228:1085 to 195.250.182.5:27015 ulen 33
[860599.250222] UDP: bad checksum. From 189.18.65.182:60143 to 195.250.182.5:27015 ulen 33
[861940.065217] UDP: bad checksum. From 201.95.129.1:3285 to 195.250.182.5:27015 ulen 33
[862792.157285] UDP: bad checksum. From 201.13.208.217:62979 to 195.250.182.5:27015 ulen 33
[879265.386130] UDP: short packet: From 93.209.226.163:0 0/105 to 195.250.182.5:0
[879325.685503] UDP: short packet: From 93.209.226.163:0 0/105 to 195.250.182.5:0
[879755.064074] UDP: short packet: From 93.209.226.163:0 65535/105 to 195.250.182.5:0
[926526.936357] UDP: short packet: From 79.129.8.98:28223 58561/33 to 195.250.182.5:27015
[933483.280670] UDP: short packet: From 89.76.206.131:55984 0/105 to 195.250.182.5:0

Может ли сервер валиться из-за "кривых" пакетов? Может лучше попытаться отфильтровывать лишнее, к примеру через iptables?

debian stable

Opik ()

realtime image & nvidia

Пытаюсь установить драивера нвидиа на реалтаим ядро, получаю ошибку:

sudo modprobe nvidia FATAL: Could not read '/lib/modules/2.6.31-4-rt/kernel/drivers/video/nvidia.ko': Invalid module format

4to ja delaju ne tak? modul sobiraju s binarnika s nvidia.com, driver version: 185.18.31

sorry, net russkoi raskladki.

Opik ()

nvidia, debian squezee/sid

Пытаюсь установить проприетарные драйвера на свою видеокарточку - NVIDIA 7300 GS. Устанавливал разными способами - из репозитория, путем module-assistant, бинарной установкой с сайта nvidia, установить то получается, но в абсолютно любой момент может повиснуть комп (предположительно виснут иксы), т.к какое время продолжает играть звук, но потом и тот умолкает.

kernel version: 2.6.29-2-686
xorg version: 1:7.4+1
nvidia version: 180.44

xorg.conf:

Section "ServerFlags"
AllowMouseOpenFail # allows the server to start up even if the mouse does not work
EndSection

Section "Module"
Disable "dri"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "glx" # 3D layer
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce 7300gs"
Driver "nvidia"
Option "DPMS"
Option "DynamicTwinView" "false"
Option "AddARGBGLXVisuals"
EndSection


ЧЯДН?

Opik ()

файловая система переводиться в режим read only

Ребят, я уже с рук/ног сбился =( проблема в следующем - при загрузке системы монтируются харды и все нормально. через некоторое время (последнее время достаточно часто) файловая корневая переводится в режим read-only.

Пробовал менять файловую систему - та же фигня. Пробовал: ext3, xfs, raiserfs, jfs...
Пробовал разные ядра - все ванильные из Ubuntu, Debian. - 2.6.18, 2.6.22,2.6.24 - без разницы.

диск SATA 80GB western digital. раньше такой проблемы не наблюдалось, куда копать?

>>>

Opik ()

locale - bash: locale: command not found

Debian testing.
Каким то образом затерялись locale, localedef и все что с ними связанное...
В каком пакете они идут? Что бы попробовать поставить заного.

ПС: пож-та без фанатизма

>>>

Opik ()

xine 1.1.9

Где его взять? Хотел собрать КДЕ4 из свн, а там в требованиях стоит не ниже 1.1.9, а тут тока: http://sourceforge.net/project/showfiles.php?group_id=9655 1.1.8

>>>

Opik ()

Firefox 3 beta 2

http://www.mozilla.com/en-US/firefox/3.0b2/releasenotes/
Говорят много утечек памяти зафиксили.
Из замеченых проблем - какие то непонятные глюки с CSS:overflow

>>>

Opik ()

Аналог daemon-tools

пересаживаю друга на линукс, поставил ему на ноут убунту 7.10 - все встало идеально.
Но ему нужно монтировать mdf файлы, какую прогу ему посоветовать?
acetoneiso2 не предлагать, mount =)) тоже. Нужна гуевая софтина
есть варианты?

Opik ()

«Сломанный пакет» с ним ничего не сделать

dpkg -r nvidia-kernel-2.6.18-4-486
dpkg: не удалось обработать параметр nvidia-kernel-2.6.18-4-486 (--remove):
Пакет абсолютно неработоспособен -- перед удалением его
следует переустановить.
При обработке следующих пакетов произошли ошибки:
nvidia-kernel-2.6.18-4-486

попытка 2:
aptitude reinstall nvidia-kernel-2.6.18-4-486
Чтение списков пакетов... Готово
Построение дерева зависимостей... Готово
Чтение информации о расширенных состояниях
Инициализация состояний пакетов... Готово
Построение базы данных тегов... Готово
Следующие пакеты оставлены не обновлёнными:
ffmpeg libgpod-common
Следующие пакеты будут ПЕРЕУСТАНОВЛЕНЫ:
nvidia-kernel-2.6.18-4-486
0 пакетов обновлено, 0 установлено новых, 1 переустановлено, 0 пакетов отмечено для удаления, и 2 пакетов не обновлено.
Необходимо получить 0B архивов. После распаковки 0B будет занято.
Запись информации расширенных состояний... Ошибка!
E: Я не в состоянии обнаружить файл пакета nvidia-kernel-2.6.18-4-486. Это может означать, что Вам придётся вручную исправить этот пакет.
E: Не удалось заблокировать каталог lists. Вы суперпользователь?

Зайди под рутом?
$whoami
root

Что я делаю не так?

Opik ()

wine

Стоял вайн 0.9.37, работал инет норм, вышел 0.9.38 скачал, установил - интернет не пашет, и такое же было ранее при обновлении? как лечить?

Opik ()

Linux как музыкальный проигрыватель.

Есть старенький комп. Хочется сделать из него что то вроде медиа проигрывателя. Т.е все что от него будет требоваться - играть музыку (возможно видео) с CD. В автоматическом режиме... Есть ли в природе такие вещи как "медиа-дистрибьютив"? Или же просто ставить мини дистр (аля damnsmalllinux) и настраивать его подобным образом..

Насколько я знаю этот дистр помещается на дискету. Но не факт что влезут и проигрыватель...я про флоппи заговорил потому, что нет жесткого диска. Если ли тут какие то варианты? или все таки нужно будет купить?

Opik ()

Установка нового ядра из репозитория.

Debian Etch.
Установил новое ядро из репозитория, включая заголовки и прочее.
ls -Fla /boot говорит:
initrd.img -> initrd.img-2.6.20-1-amd64
vmlinuz -> vmlinuz-2.6.20-1-amd64
В то же время uname -r говрит:
2.6.18-4-amd64

Что с моими руками?)

Opik ()

wine и права доступа

Установил сабж, все ок, игры пашут. Но вот одна проблема с играми - они не могут сохранять конфиги, делать сейвы и прочее. Не знал что делать, потом допер, что юзеру, из под которого запускается вайн, не хватает прав на запись, дал эти права - и чудо, все заработало как надо :)))

И собсвенно вопрос, как сделать так, что бы при новых инсталяциях на файлы уже были даны права на запись? Или же после каждого инсталла, придется ручками все допиливать???

Opik ()

Нужен легкий медиа плайер, дружащий с русской кодировкой

Перепробовал xmms,bmpx,audacious,mplayer больше всего понравились xmms,audacious но вот беда - с кодировкой проблемы, с первым как то на процентов 25 файлов решилось, а на остальные - кукишь, а с последним что то свою кодировку не выставить вообще и беда полная. Может посоветуете чего?

локаль: ru_RU.KOI8-R

Opik ()

RSS подписка на новые темы