LINUX.ORG.RU

Охота на ошибки LibreOffice 6.2 alpha 1

 , , ,


2

3

The Document Foundation объявил «Охоту на ошибки» в LibreOffice 6.2 alpha 1.

Для удачной охоты вам необходимо 22 октября 2018 года скачать дистрибутив под вашу архитектуру и операционную систему с сайта http://dev-builds.libreoffice.org/pre-releases/, установить LibreOffice и заняться поиском ошибок (или подтверждением корректной работы).

Особое внимание при тестировании первой альфа версии LibreOffice 6.2 необходимо уделить новому модулю интеграции LibreOffice в KDE 5.

Нужно проверить:

  • корректное определение наличия среды KDE 5 и установку соответствующего модуля vcl
  • корректный внешний вид приложения в KDE 5
  • наличие/отсутствие значков в меню LibreOffice в среде KDE 5
  • выравнивание элементов меню LibreOffice при включенном/отключенном отображении значков в меню
  • какой диалог открытия/сохранения файлов используется в LibreOffice в KDE 5
  • что угодно ещё, что вам придет в голову проверить для LibreOffice в KDE 5

Обо всех найденных ошибках нужно сообщать разработчикам в багзиллу проекта, желательно на английском языке.

>>> Подробности

Ответ на: комментарий от spec_po_kiskam

Сколько платят?

мне за публикацию или кому-то за поиск ошибок?

Kompilainenn ★★★★★ ()

У меня бывает отрисовка шрифтов при выделении начинает «прыгать» по высоте. Т.е. выделяю текст, а он на несколько пикселей перемещается вверх.

BceM_IIpuBeT ★★ ()

корректный внешний вид приложения в KDE 5

что подразумевается под корректностью?

anonymous ()
Ответ на: комментарий от BceM_IIpuBeT

в тексте новости написано, куда писать об обнаруженных ошибках. к отчету об ошибке желательно приложить образец документа, информацию о версии из диалога Справка->О программе LibreOffice и скриншот.

проблема с рендером шрифтов в документе крайне обширная и может зависеть от кучи различных вещей внутри либры=(

Kompilainenn ★★★★★ ()
Ответ на: комментарий от anonymous

что у тебя весь интерфейс либры выглядит однородно. Что панели инструментов или меню или диалоги или любой другой элемент ГУИ не выделяется на фоне всех остальных (цветом, шрифтом, тенями, чем угодно)

Kompilainenn ★★★★★ ()

модулю интеграции LibreOffice в KDE 5

Ну всё. Итак тот ещё глюкодром, а они ещё зоопарк увеличивают

fornlr ★★★★★ ()
Ответ на: комментарий от fornlr

Вы же тут ныли, что в кедах либра выглядит плохо, вам запилили фронт энд на qt5, что опять не так?

Kompilainenn ★★★★★ ()
Ответ на: комментарий от Elmer_

как только купишь - так сразу заплатят

anonymous ()

Linux x86 (32-bit) as a build target is deprecated. In a future version (to be announced) there will be no guarantees of being able to build LibreOffice on Linux x86.

Всё, готовьтесь.

mandala ★★★★ ()
Ответ на: комментарий от mandala

погоди ты их пугать, это случится еще через год и то не факт

Kompilainenn ★★★★★ ()
Ответ на: комментарий от Kompilainenn

Ну как в «не факт» я не сомневаюсь, уж очень многие дропнули x86, это тенденция — кто сам не хочет, будет вынужден.

их пугать

И тут напугаешь... Они сами кого хошь напугают )

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 1)

И я уже нашёл ошибку: это дизайн и всё остальное.

gtk3 ()
Ответ на: комментарий от gtk3

И я уже нашёл ошибку: это дизайн и всё остальное.

gtk3

Это прекрасно

Deleted ()

Вот для Haiku хрен знает сколько времени тому назад уже собрали давно Libreoffice 6.2, и он там нормально работает с Qt5. Прямо машина времени у них какая-то...

kknight ★★★ ()
Ответ на: комментарий от Kompilainenn

так он всегда выглядел однородно - как обычное gtk-приложение

а вот то, что он будет мимикрировать под тему qtcurve, я сильно сомневаюсь

anonymous ()
Ответ на: комментарий от mandala

Это замечательно. Поддерживать популярную архитектуру они не могут, а интеграцию в ненужно DE, для большей фрагментации линуксового дескопа - это они могут, и ещё просят потестить. Благо фанбоев кед предостаточно.

anonymous ()
Ответ на: комментарий от kknight

Вот для Haiku хрен знает сколько времени тому назад уже собрали давно Libreoffice 6.2, и он там нормально работает с Qt5

Вам что-то показалось. Несколько дней назад я заглядывал на сайт Haiku. LibreOffice там было только одной версии - 6.11 (альфа), которая появилась в июне. Была жалоба на то, что нельзя выбирать шрифты. То есть, этот LibreOffice был вообще непригоден для использования. Сейчас опять заглянул - версия 6.20 (альфа), появилась в октябре. Какие в ней глюки в Haiku - не узнавал, потому что неинтересно. Эта Haiku никому не нужна, поэтому тестировать неинтересно.

В KDE протестировать можно. Скоро выйдет окончательная версия Kununtu 18.10. Можно испытать в ней.

Partisan ()
Ответ на: комментарий от Partisan

В кубунту 18.10 уже либру 6.1 собрали с патчами под кеды из 6.2

Kompilainenn ★★★★★ ()
Ответ на: комментарий от mandala

Да уж... Останется, конечно, апачский опенок, но, во-первых, там уже некоторых фич заметно недостает (ну да, либра избаловала), а во-вторых, кто знает, что им в голову стукнет.

А по основной новости: лучше бы на совместимость импресса с пауэпойнтом силы бросили, а не на внешний вид. Нам, как говорится, с лица не воду пить.

PVOzerski ★★★ ()
Ответ на: комментарий от anonymous

так он всегда выглядел однородно - как обычное gtk-приложение

LibreOffice - не GTK-приложение и выглядел всяко-разно.

yuran ★★ ()
Ответ на: комментарий от PVOzerski

Это между прочим тоде в 6.2 было. Был запрос от какой то фирмы на устранение некоторых багов в совместимости форматов ppt и pptx с либрой

Kompilainenn ★★★★★ ()
Ответ на: комментарий от anonymous

Поддерживать популярную архитектуру (Linux x86-32) они не могут

Смешно...

Пользователей вендов до Windows 7 всяко больше, но они уже средний палец заслуженно получили.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 2)
Ответ на: комментарий от Kompilainenn

А вот это уже хорошая новость - потому что там не «некоторые баги», а полный глюкодром.

PVOzerski ★★★ ()
Ответ на: комментарий от fornlr

Это не смешно - с учетом большого парка старой техники, которая до сих пор востребована.

PVOzerski ★★★ ()
Ответ на: комментарий от fornlr

Помню время, когда доверчивых новичков заманивали на линуксы отсутствием планового устаревания.

anonymous ()
Ответ на: комментарий от PVOzerski

Это не смешно - с учетом большого парка старой техники, которая до сих пор востребована.

Мне тяжело представить старую 32 битную онли машину, на которой можно было работать с современным Libre Office без стальных нервов (из-за тормозов).

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)
Ответ на: комментарий от anonymous

Это замечательно. Поддерживать популярную архитектуру они не могут, а интеграцию в ненужно DE, для большей фрагментации линуксового дескопа - это они могут, и ещё просят потестить. Благо фанбоев кед предостаточно.

Вообще это не они сами, это центось на которую они завязаны.

mandala ★★★★ ()
Ответ на: комментарий от anonymous

Поддерживать популярную архитектуру они не могут

32bit популярен в 2018 году? Не смешите мои тапочки.

интеграцию в ненужно DE, для большей фрагментации линуксового дескопа

KDE - ведущий DE для Linux и по функционалу, и по количеству пользователей (даже тут на ЛОРе был опрос). Так что фрагментации скорее способствуют ненужные альтернативы типа гнума.

duott ★★★★★ ()
Ответ на: комментарий от fornlr

Мне тяжело представить старую 32 битную онли машину, на которой можно было работать с современным Libre Office без стальных нервов

Я тоже это говорил, но нытикам не объяснишь. Да и тех фич (фичеплакерам) которые есть сейчас хватит еще на много лет, так что не смертельно, что следующая либра не будет поддерживать i386.

mandala ★★★★ ()
Ответ на: комментарий от duott

32bit популярен в 2018 году? Не смешите мои тапочки.

Говорят на 64-х разрядных машинах с 2-3 гигами 32-х разрядные ОС шустрее. Я не заметил такого и если проц 64 то и ось 64 уже много лет, даже если рамы 2 гига.

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 1)
Ответ на: комментарий от PVOzerski

а вот тут ты можешь потестить свои презенташки и сказать разработчикам, что что-то не так (хотя открытых багов по МСО форматам презенташек и так вагон)

Kompilainenn ★★★★★ ()
Ответ на: комментарий от mandala

Говорят(да что говорят, я подтверждаю), что для комфортной работы на десктопе нынче надо 4 гига оперативы минимум. Да, даже в этом нашем линуксе. 32-битные ОС заруливают до 4 гигов, базару нет. Но на 64 битах вот пускаешь ты браузер, админку биллинга(здравствуй UTM5, здравствуй java), почтовик и начинается анал карнавал^W^W своппинг(а виноваты все примерно поровну из вышеперечисленных - это топ по жору оперативы). Это кстати одна из причин почему я свалил с KDE - на рабочей машине с 4 гигами был выбор - или валить с KDE4 на KDE5(и х его з как там с потреблением памяти будет) или срулить на WM и сэкономить чуть-чуть. Я свалил на fluxbox и продержался еще пару лет в таком подвешенном состоянии. Потом выбил себе еще плашку на 4 гига - но валить обратно на убогие KDE5(скрины не возбуждают, как и тыкание в виртуалке) с дизайном аля дисяточка не тянет.

Pinkbyte ★★★★★ ()

Одна большая ошибка — это LibreOffice.

anonymous ()
Ответ на: комментарий от Pinkbyte

Да, 2-3 гига это печать и боль, боль и печаль если пускаешь хотя бы браузер и только его из тяжелого (эмуляторы я не считаю, где висит ssh, ирка и т.п.). Так что тут пофигу — 32 или 64. Или без нормального браузера, офисного пакета и тд — но быстро, или все перманентно стоит раком.

mandala ★★★★ ()

Цена вопроса? И почему не в Job?

xDShot ★★★★★ ()
Ответ на: комментарий от xDShot

Цена вопроса ноль в любой валюте. Это ваша плата за пользование бесплатным продуктом, если так тебе больше понятно и близко

Kompilainenn ★★★★★ ()
Ответ на: комментарий от spec_po_kiskam

Что за шкурные интересы. А как же open source и помощь сообществу?

B00 ()
Ответ на: комментарий от xDShot

Какие вы все меркантильный сволочи...

/me в LO переводик сайтега ru пилить тихонько и даже спасибо не просит.

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 1)

Особое внимание при тестировании первой альфа версии LibreOffice 6.2 необходимо уделить новому модулю интеграции LibreOffice в KDE 5.

Это просто замечательно. Первый крупный проект на моей памяти, который попытался пробить тулкитовскую сегрегацию. Фаерфокс, емнип, с 2009 года говорит что не нужно.

ZhAN ★★ ()

интеграции LibreOffice

ненужно

интеграции LibreOffice в KDE 5

ненужно x2

cuelebra ()
Ответ на: комментарий от fornlr

Как раз с либрой можно - даже на нетбуке с Атомом. Как показывает опыт.

PVOzerski ★★★ ()
Ответ на: комментарий от duott

Так что фрагментации скорее способствуют ненужные альтернативы типа гнума.

Напомни, что там сейчас по дефолту во всех мажорных дистрибутивах.

meliafaro ★★★★ ()
Ответ на: комментарий от fornlr

я вообще считаю KDE плохо выглядящим,

Обои менять пробовал?

Kroz ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.