LINUX.ORG.RU

Изучаю Django - не показывается админка

 ,


0

3

Начал изучать Django. Установил, настроил, увидел «It works».

Операционка Debian. Python 2.7.5, Django 1.5.4.

Проект лежит в подкаталоге /app каталога виртуального хоста /var/www/libretag. Стартовая страница открывается по URL http://local-libretag.ru.

Пытаюсь открыть админку. Для этого сделал следующие настройки:

В файле settings.py:

DATABASES = {
    'default': {
        'ENGINE': 'django.db.backends.sqlite3',
        'NAME': '/var/www/libretag/data/db/blog.db',
        # The following settings are not used with sqlite3:
        'USER': '',
        'PASSWORD': '',
        'HOST': '',
        'PORT': '',
    }
}

...

INSTALLED_APPS = (
    'django.contrib.auth',
    'django.contrib.contenttypes',
    'django.contrib.sessions',
    'django.contrib.sites',
    'django.contrib.messages',
    'django.contrib.staticfiles',
    'blog',
    # Uncomment the next line to enable the admin:
    'django.contrib.admin',
    # Uncomment the next line to enable admin documentation:
    'django.contrib.admindocs',
)

В файле urls.py:

from django.conf.urls import patterns, include, url

# Uncomment the next two lines to enable the admin:
from django.contrib import admin
admin.autodiscover()

urlpatterns = patterns('',
    # Examples:
    # url(r'^$', 'app.views.home', name='home'),
    # url(r'^app/', include('app.foo.urls')),

    # Uncomment the admin/doc line below to enable admin documentation:
    # url(r'^admin/doc/', include('django.contrib.admindocs.urls')),

    # Uncomment the next line to enable the admin:
    url(r'^admin/', include(admin.site.urls)),
)

В каталоге /app дал команду:

./manage.py startapp blog

В файле /blog/models.py прописал:

from django.db import models
from django.contrib import admin

class BlogPost(models.Model):
  title = models.CharField(max_length=150)
  body = models.TextField()
  timestamp = models.DateTimeField()

admin.site.register(BlogPost)

В завершение дал команду:

./manage.py syncdb

Пытаюсь войти в админку по URL:

http://local-libretag.ru/admin

Но в ответ вижу все ту же страницу «It works».

Вопрос. Что где еще надо крутануть чтобы войти в админку?

★★★★★

«It works» ? А кто вообще это пишет? По дефолту при переходе на '/' должна выдаваться ошибка. btw debug = True? Может ты запускаешь на порту 8080 или что-нибудь в этом духе, а стучишься на 80, который слушает nginx/apache etc?

matrixd ()

Запусти сервер разработки python manage.py runserver

liathit ★★ ()
Ответ на: комментарий от matrixd

Django подключен через WSGI. Окно приветсвия пишет апач, вестимо.

Да, debug = True.

Xintrea ★★★★★ ()
Ответ на: комментарий от Xintrea

Вот еще не разобрался, а уже себе лишнее проблемы создаешь. Ну и как ты его запускаешь через wsgi?

matrixd ()
Ответ на: комментарий от matrixd

Что-то какой-то бред получается.

Установил для интереса в settings.py DEBUG=False

А мне всеравно показывает «It works!» и надпись внизу:

You're seeing this message because you have DEBUG = True in your Django settings file and you haven't configured any URLs. Get to work!



С чего это настройку не видит? Причем перед этим настройку БД в том же файле прожевал и файл базы создал.

Xintrea ★★★★★ ()
Ответ на: комментарий от matrixd

Так как в книжке написано.

«Django. Разработка веб-приложений на Python».

Xintrea ★★★★★ ()
Ответ на: комментарий от Xintrea

У тебя джанго через wsgi не запускается вообще, суде по всему. Или запускается, но ты не настроил апач. В любом случаи. На время отладки, а темболее изучения, советую забыть про все это и юзать встроенный сервер, все будет работать из коробки. Запустить его можно командой написанной выше

python manage.py runserver

Незабывай читать официальные доки. Там в частности есть годный туториал.

matrixd ()
Ответ на: комментарий от matrixd

У тебя джанго через wsgi не запускается вообще, суде по всему.

Интересно, кто же мне пишет:

It worked!
Congratulations on your first Django-powered page.

Of course, you haven't actually done any work yet. Here's what to do next:
If you plan to use a database, edit the DATABASES setting in app/settings.py.
Start your first app by running python manage.py startapp [appname].

You're seeing this message because you have DEBUG = True in your Django settings file and you haven't configured any URLs. Get to work!

Или запускается, но ты не настроил апач.

Для работы WSGI в апаче достаточно прописать wsgi-шный бэкэнд. Все остальное должна делать Django, ибо ей все карты в руки сразу передются.

Xintrea ★★★★★ ()
Ответ на: комментарий от Xintrea

Апач перезапускал после изменений в проекте?

gruy ★★★★ ()

Если хочешь при разработке использовать связку uwsgi + фронтэнд (нафиг апач тут — отдельный вопрос, nginx достаточно), добавь touch-reload в конфиг uwsgi, иначе тебе придётся перезапускать uwsgi каждый раз при внесении изменений.

anonymous ()

вспоминая твой предыдущий тред... а может надо "-" в названии сайта убрать?)))

der_looser ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.