LINUX.ORG.RU

PHP 5.2.6. Phpinfo(). Как узнать, есть ли поддержка SQLite3 или нет?


0

0

Здравствуйте!


Вот стоит у меня php5-cgi 5.2.6 из репозитария. Когда смотрю phpinfo(), то в нем ни слова о sqlite/sqlite3. А так же ни слова о pdo.

Вроде как в PHP5 обещяли, что sqlite будет включаться по-умолчанию.

Вопрос. Если в phpinfo() ни слова о sqlite и pdo, то есть ли их поддержка в языке, или нет?

нет
все что поддерживается - наследит в выводе phpinfo()

если php дистрибутивная, то пожно просто раскомментировать нужные расширения в php.ini (доустановить пакеты если нужно)

Sylvia ★★★★★ ()

значит нету. Может там поддержка и из коробки, но собрать можно и без него.

anonymous ()

> Вот стоит у меня php5-cgi 5.2.6 из репозитария. Когда смотрю phpinfo(), то в нем ни слова о sqlite/sqlite3. А так же ни слова о pdo.

видимо дистрибутив у тебя не Slackware...

а собиралбы ты если через
./configure prefix=... && make && make install

то былобы и Sqlite и Sqlite3


просто мода щаз такая пошла у дистрибутиво-строителей (даже Debian) — дробить офицальные сборки на много-много-много-много частей!

сидишь вот ты, читаешь документацию в которой ЧОТКО сказанно что <такойто> компонент должен быть поумолчанию, а на самом деле нет — «мэйнтейнеру-то-видимо-лучше-знать» что должнобыть поумолчанию а что нет :DDD , чем команде разработчиков интерпретатора....

mkfifo ()
Ответ на: комментарий от Sylvia

> если php дистрибутивная, то пожно просто раскомментировать нужные расширения в php.ini (доустановить пакеты если нужно)

если Debian lenny, то:

aptitude install php5-sqlite

(ну а уж там заодно и aptitude install php5-mysql php5-gd ...)

:-)

mkfifo ()

$ wget 'http://localhost/info.php' -qO - | grep sqlite | wc -l
7

KRoN73 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.