LINUX.ORG.RU

не работает Zend Optimizer


0

0

скачал Zend Optimizer v3.3.3 (Linux x86 32bit), установил, указал ему путь к php.ini, перезагрузил апач, а зенд, зараза, не определяется.

sysinfo():
>This program makes use of the Zend Scripting Language Engine:
>Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies

php -v:
>PHP 5.2.9 with Suhosin-Patch 0.9.7 (cli) (built: Mar 12 2009 21:16:18)
Copyright (c) 1997-2009 The PHP Group
>Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies

пробовал в php.ini указывать прямой путь, не
> zend_extension = /usr/local/Zend/lib/ZendExtensionManager.so
> zend_extension_ts = /usr/local/Zend/lib/ZendExtensionManager_TS.so
а
> zend_extensions = /usr/local/Zend/lib/Optimizer-3.3.3/php-5.2.x/ZendOptimizer.so
> zend_extension_ts = /usr/local/Zend/lib/Optimizer_TS-3.3.3/php-5.2.x/ZendOptimizer.so
все равно не пашет.

гугл подсказал прописать в php.ini строку
> zend_optimizer.enable_loader = 1
-опять не помогло. тогда гугл порекомендовал удалить mod_security2 апача - удалил, ничего не изменилось.

если что, php.ini везде одинаковые - мой в /srv/www/php.ini, в /etc/php.ini, и в /usr/local/Zend/etc/php.ini. система: SLED 11,
> # /usr/sbin/httpd2 -v
> Server version: Apache/2.2.11 (Linux/SUSE)
> Server built: Jun 18 2009 18:44:45

кто сталкивался с подобным? чем лечить?

Re: не работает Zend Optimizer

/usr/local/Zend/etc/php.ini после установки оптимайзера должен быть другим. Видимо, что-то недоделалось. Попробуйте повторить процесс.

Кстати, вот в дебиане php.ini разные для cli, cgi, apache,apache2. Может посмотреть в /etc/php5 ? Чисто по-аналогии...

OldFornit ()
Ответ на: Re: не работает Zend Optimizer от OldFornit

Re: не работает Zend Optimizer

спасибо, помогло! дописал в /etc/php5/php.ini

>[Zend]

>zend_extension_manager.optimizer = /usr/local/Zend/lib/Optimizer-3.3.3

>zend_extension_manager.optimizer_ts = /usr/local/Zend/lib/Optimizer_TS-3.3.3

>zend_optimizer.version = 3.3.3

>zend_extension = /usr/local/Zend/lib/ZendExtensionManager.so

>zend_extension_ts = /usr/local/Zend/lib/ZendExtensionManager_TS.so

>zend_optimizer.enable_loader = 1


и зенд наконец определился. phpinfo():

>This program makes use of the Zend Scripting Language Engine:

>Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies

> with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies

> with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies


только в php -v почему-то осталось

> PHP 5.2.9 with Suhosin-Patch 0.9.7 (cli) (built: Mar 12 2009 21:16:18)

> Copyright (c) 1997-2009 The PHP Group

> Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies

opensuse ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.