LINUX.ORG.RU

Ошибки при включении сервака ruby script/server


0

0

sasha@sasha-laptop:~/rails/blog$ ruby script/server => Booting WEBrick... /home/sasha/.gem/ruby/1.8/gems/rails-2.2.2/lib/initializer.rb:259:in `require_frameworks': no such file to load -- jopenssl (RuntimeError) from /home/sasha/.gem/ruby/1.8/gems/rails-2.2.2/lib/initializer.rb:133:in `process' from /home/sasha/.gem/ruby/1.8/gems/rails-2.2.2/lib/initializer.rb:112:in `send' from /home/sasha/.gem/ruby/1.8/gems/rails-2.2.2/lib/initializer.rb:112:in `run' from /home/sasha/rails/blog/config/environment.rb:13 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `require' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies .rb:153:in `require' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies .rb:521:in `new_constants_in' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies .rb:153:in `require' from /home/sasha/.gem/ruby/1.8/gems/rails-2.2.2/lib/commands/servers/webrick.rb:59 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `require' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies .rb:153:in `require' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies .rb:521:in `new_constants_in' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies .rb:153:in `require' from /home/sasha/.gem/ruby/1.8/gems/rails-2.2.2/lib/commands/server.rb:49 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `require' from script/server:3

Включаю сервак и появлются такие ошибки .

Re: Ошибки при включении сервака ruby script/server

jopenssl это пять)

<телепат мод>

у тебя убунта. я вижу это в своем волшебном шаре. нет пакетов ruby1.8-dev или libopenssl-ruby. а может сам руби слишком старый. если выхлоп script/server без ошибок и вебрик действительно пытается загрузить '_j_openssl' , видимо, тебя кто-то проклял.

</телепат мод>

P.S. и таки да, gem install mongrel

volh ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.