LINUX.ORG.RU

Ответ на: комментарий от Anoxemian

спасибо но это вариант с авторизацией, мне надо без

Regacar ()

Если на сервере стоит Python, а он скорее всего стоит, т.к. нужен многим системным утилитам и скриптам, то одна строка:

python -m http.server

В каталоге, который требуется расшарить.

emorozov ()
Ответ на: комментарий от Regacar

заходу на site.com/_h5ai/ пишет
Access Denied

Right, because /_h5ai directory doesn't have an index.php but there is .htaccess with DirectoryIndex disabled. You're supposed to open the «public» directory which as you've noticed is:

_h5ai/public/index.php тут все ок пишет

or just /_h5ai/public/.

anonymous ()
Ответ на: комментарий от anonymous

The 3rd step says you're supposed to create .htaccess in the root directory of your site, e.g. at /path/to/site.com, that would include the following line:

DirectoryIndex  index.html  index.php  /_h5ai/public/index.php
. That way every time anyone opens site.com they'll see the script at site.com/_h5ai/public/index.php.

anonymous ()

В приведенном посте отсутствует ясность что делали.

anonymous ()
Ответ на: комментарий от Regacar

Там же написано, что надо в конфиге web-сервера путь до индексных файлов поменять

В Installation 3-й пункт.

Если ты не можешь менять настройки сервера, то этот вариант тебе не подойдёт.

Radjah ★★★★★ ()
Ответ на: комментарий от Regacar

пробовал все htacces apache conf

у меня vesta

You've created `.htaccess` file with the above mentioned content at the root of your project (i.e., at `/path/to/site.com` not `/path/to/site.com/_h5ai` or something) and it still didn't work (when you opened site.com)?

Do you use Apache? Are `.htaccess` files enabled? If so, your control panel is irrelevant, it's supposed to work.

anonymous ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.