LINUX.ORG.RU

Что за предупреждения в NPM?

 ,


0

1

Я долго пользовался старым NPM (2.14) и он работал, для моих узких задач, нормально.

Сегодня поставил новый, свежий. И там при установке пакетов постоянно предупреждения:

npm WARN saveError ENOENT: no such file or directory, open '...package.json'
npm WARN enoent ENOENT: no such file or directory, open '...package.json'

Че за фигня? Че ему не нравится?

Deleted

А вы случайно

npm install

делали не в каталоге, где нет package.json? Может там нужно было проинициализировать конфиг вначале с помощью npm init?

Если не поможет, сделайте

npm install debug.

и покажите выхлоп.

lucentcode ★★★★★ ()
Последнее исправление: lucentcode (всего исправлений: 1)
Ответ на: комментарий от lucentcode

делали не в каталоге, где нет package.json

Да, именно так. Package.json в том каталоге не было. А должен был быть?

То есть, скажем так, я понимаю, что _должен_, но ведь старая версия NPM не выводила этого предупреждения. А теперь оно есть. Не очень понятно, с чем именно это связано. То ли этот файл все-таки нужен, то ли по желанию.

Я не девелопер, если что.

Deleted ()
Последнее исправление: myLogin (всего исправлений: 1)
Ответ на: комментарий от Deleted

Я не девелопер, если что.

Ну так позови билд инженера, или того кто это в репу накомитил, пусть он тебе на пальцах объяснит что должно быть и как этого добится.

_должен_

Именно должен. Если до этого не требовало, то он уже был. Подругому работаь не будет. Если тебе его нужно создать, то npm init тебе в помощь.

Deleted ()
Ответ на: комментарий от Deleted

Я вообще не работаю в IT, это для домашнего использования, в рамках хобби.

Именно должен. Если до этого не требовало, то он уже был.

Старая версия NPM (2.14) не выводила такого предупреждения. Package.json в каталоге точно так же не было.

Но вообще спасибо, я понял.

Deleted ()
Ответ на: комментарий от Deleted

2.14

а ты вообще где это откопал. Ему минимут 3 года.

npm install PackageName --save

--save намекает на то, что информацию об этой зависимости нужно сохранить. Единственное место где можно сохранить эту информацию - package.json. Собственно если ты не собираешься выкладывать сорцы\сохранять информацию о зависимостях - можешь просто игнорировать, ну или попробуй убрать --save. Но лучше запусти npm init, введи хотя бы имя, а все остальное оставь по дефолту, а после этого уже устанавливай пакеты из npm.

Deleted ()
Ответ на: комментарий от Deleted

а ты вообще где это откопал. Ему минимут 3 года.

Как поставил когда-то, так и работало. Я редко пользуюсь NPM, поэтому не заморачивался с его обновлением.

В остальном понял, спасибо.

Deleted ()