LINUX.ORG.RU

angular2 создание приложения с помощью ng из под пользвателя

 ,


0

1

При создание приложение angular2 от пользователя такие ошибки:

$ ng new my-project
installing ng2
  create .editorconfig
  create README.md
  create src/app/app.component.css
  create src/app/app.component.html
  create src/app/app.component.spec.ts
  create src/app/app.component.ts
  create src/app/app.module.ts
  create src/app/index.ts
  create src/assets/.gitkeep
  create src/environments/environment.prod.ts
  create src/environments/environment.ts
  create src/favicon.ico
  create src/index.html
  create src/main.ts
  create src/polyfills.ts
  create src/styles.css
  create src/test.ts
  create src/tsconfig.json
  create src/typings.d.ts
  create angular-cli.json
  create e2e/app.e2e-spec.ts
  create e2e/app.po.ts
  create e2e/tsconfig.json
  create .gitignore
  create karma.conf.js
  create package.json
  create protractor.conf.js
  create tslint.json
Successfully initialized git.
Installing packages for tooling via npm.
npm WARN deprecated node-uuid@1.4.7: use uuid module instead
npm WARN deprecated graceful-fs@1.2.3: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use 'npm ls graceful-fs' to find it in the tree.
npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated tough-cookie@2.2.2: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm ERR! tar.unpack untar error /opt/.npm/@angular/core/2.2.1/package.tgz
npm ERR! tar.unpack untar error /opt/.npm/abbrev/1.0.9/package.tgz
npm ERR! tar.unpack untar error /opt/.npm/@angular-cli/base-href-webpack/1.0.7/package.tgz
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.15: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @angular-cli/base-href-webpack@1.0.7 (node_modules/@angular-cli/base-href-webpack):
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: EBADF: bad file descriptor, close
npm ERR! Linux 4.7.0-0.bpo.1-amd64
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "install"
npm ERR! node v6.9.1
npm ERR! npm  v3.10.8
npm ERR! code EBADF
npm ERR! errno -9
npm ERR! syscall close

npm ERR! EBADF: bad file descriptor, close
npm ERR! 
npm ERR! If you need help, you may report this error at:
npm ERR!     <https://github.com/npm/npm/issues>

npm ERR! Please include the following file with any support request:
npm ERR!     /home/user/programming/angular2/my-project/npm-debug.log

Package install failed, see above.

Проверил права дериктории /opt/.npm -все ок. Из под root все создается нормально. Может я не правильно angular-cli установил (делал это из под root, т.к. инсталлятор не мог создать линк для /usr/bin/ng)

Кто сталкивался может помочь?

Спасибо

★★★

Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.