LINUX.ORG.RU

PhpMyAdmin не создаёт куки и не входит

 ,


0

1

я настроил phpmyadmin на своей впс, чтобы он открывался по адресу: 55.55.55.55/phpmyadmin

в этом мне помог кусок статьи в конце http://www.lonelycoder.be/nginx-php-fpm-mysql-phpmyadmin-on-ubuntu-12-04/

конкретно, чтобы пхпмайамин открывался в браузере я сделал так:

cd /usr/share/nginx/html
sudo ln -s /usr/share/phpmyadmin

эффект есть, но при вводе любого имени и пароля я попадаю на эту же страницу логина, то есть не получается войти.

вот мой конфиг

# cat nginx.conf

user  www-data www-data;
worker_processes  1;
worker_priority	-20;

error_log  /var/log/nginx/error.log warn;
pid        /var/run/nginx.pid;


events {
    worker_connections  1024;
}


http {
    include       /etc/nginx/mime.types;
    default_type  application/octet-stream;

    log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';

    client_max_body_size 12m;
    access_log  off; #/var/log/nginx/access.log  main;

    sendfile        on;
    #tcp_nopush     on;

    keepalive_timeout  65;

    server_names_hash_max_size	1024;
    server_names_hash_bucket_size	128;

    #gzip  on;

    fastcgi_temp_path	/var/cache/nginx/temp/fastcgi;
    proxy_temp_path	/var/cache/nginx/temp/proxy;

    charset	utf-8;
    index	index.php index.html index.htm;

    #include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;
}

я подозреваю, что в дефолтном хосте ошибки:

# cat /etc/nginx/sites-enabled/default
server {
    listen 80 default; ## listen for ipv4; this line is default and implied
 
    # Make site accessible from http://localhost/ or server IP-address
    server_name localhost;
    server_name_in_redirect off;
 
    charset utf-8;
 
    access_log /usr/share/nginx/log/access.log;
    error_log /usr/share/nginx/log/error.log;
 
    root /usr/share/nginx/html;
    index index.php index.html index.htm;
 
    location / {
        # First attempt to serve request as file, then
        # as directory, then trigger 404
        try_files $uri $uri/ =404;
    }

    location ~ \.php$ {
        include             /etc/nginx/conf.d/fastcgi_params.conf;
 
        fastcgi_param       SCRIPT_FILENAME  	/usr/share/nginx/html$fastcgi_script_name;
        fastcgi_param       DOCUMENT_ROOT       /usr/share/nginx/html;
    }
 
}

что делать, чтобы работать в phpmyadmin в браузере?


Ответ на: комментарий от sin_a

да есть такой файл. я когда устанавливал пхпмайадмин, я не выбирал сервер, так как у ммен nginx а там было только апаче и lighttpd. и я указывал рут-пароль майскюэля и задал для пхпмайадмина пароль. может что-то не так?

про config.inc.php я почитал тут http://php-myadmin.ru/doc/install.html и посмотрел в своем файле - та вроде нет ничего странного.

tlito ()
Ответ на: комментарий от tlito

простейшая конфигурация может выглядеть так:

<?php
$cfg['blowfish_secret'] = 'ba17c1ec07d65003'; // use here a value of your choice
$i=0;
$i++;
$cfg['Servers'][$i]['auth_type'] = 'cookie';
?>
sin_a ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.