LINUX.ORG.RU

ssh-agent + gpg-agent + XFCE

 , ,


0

1

Я делаю вход по ключам SSH так, чтобы они брались из GnuPG.

Делал по https://opensource.com/article/19/4/gpg-subkeys-ssh .

В Bash все работает. Для этого, в ~/.bashrc у меня

export SSH_AUTH_SOCK=$(gpgconf --list-dirs agent-ssh-socket)
gpgconf --launch gpg-agent

а в ~/.gnupg/gpg-agent.conf

enable-ssh-support

Как заставить Thunar делать так же? XFCE

bashrc "исполняется" только в интерактивной сессии Bash. Чтобы вся сессия использовала настроенное окружение, нужно использовать механизм, который используется в том числе в графической сессии — ~/.xinitrc, ~/.profile(FIXME). Возможно, существуют и другие. Что используется в качестве логин-менеджера и что использует этот логин-менеджер я не знаю.

mord0d ★★★ ()

Кстати, а кто запускает gpg-agent? Он у меня запущен. И версию выводит в ${HOME}/.xsession-errors. Но кто его запускает? В настройках «Сеансы и запуск» от XFCE упоминания о нем не нашел.

kuraga ()
Ответ на: комментарий от kuraga

Выяснено, что это делает https://git.xfce.org/xfce/xfce4-session/tree/xfce4-session/xfsm-startup.c?h=xfce-4.14#n195.

Если gpg-agent стартовал, то ssh использует GnuPG ключи (видимо, важна опция enable-ssh-support).

Thunar GnuPG ключи никогда не использует.

kuraga ()
Последнее исправление: kuraga (всего исправлений: 3)