LINUX.ORG.RU

версии ПО


0

0

посмотрел вот это:

nmap -A malpaso.ru | grep open
22/tcp    open     ssh          OpenSSH 3.8.1p1 (protocol 2.0)
25/tcp    open     smtp?
53/tcp    open     domain       ISC Bind 9.2.4
80/tcp    open     http         Apache httpd 2.0.54 ((Debian GNU/Linux) mod_ssl/2.0.54 OpenSSL/0.9.7e)
143/tcp   open     imap         Dovecot imapd
443/tcp   open     ssl/http     Apache httpd 2.0.54 ((Debian GNU/Linux) mod_ssl/2.0.54 OpenSSL/0.9.7e)
587/tcp   open     submission?
993/tcp   open     ssl/imap     Dovecot imapd
995/tcp   open     ssl/pop3     Dovecot pop3d

(на malpaso.ru лежит security faq)

и, соответственно, вопрос: имеет ли смысл скрывать версии или даже тип ПО, или это всё детские игры и реально безопасности не увеличивает?

PS
кстати, curl -I yandex.ru | grep Apache
Server: Apache/1.3.29 (Unix) mod_perl/1.29 mod_deflate/1.0.21 rus/PL30.19
★★★

Re: версии ПО

Вообщем-то если вы вовремя патчите все уязвимости, то вопрос о сокрытии версий не так уж и важен - как кому нравится.. В любом случае - надо вовремя апдейтить систему.

К вопросу о яндексе - либо патчат старый апач (например в ОпенБСД используется тот-же апач-1.3.29, только он пропатчен), либо в ус не дуют - например не используют те модули/функции в которых есть уязвимости.

anonymous ()

Re: версии ПО

> и, соответственно, вопрос: имеет ли смысл скрывать версии или даже тип ПО, или это всё детские игры и реально безопасности не увеличивает?

Я смысла не вижу и, соответственно, не делаю. Впрочем, периодически делаю apt-get upgrade

ivlad ★★★★★ ()
Ответ на: Re: версии ПО от ivlad

Re: версии ПО

т.е. играешь с кулхацкерами в игру "кто первый": он успеет ломануть сервак или ты сделать apt-get upgrade?

theserg ★★★ ()

Re: версии ПО

Заморачиваться с версиями возможно не стоит (разве что Debian и Linux выкинуть из строки apache), а вот обновляться стоит, особенно это касается SSH.

saper ★★★★★ ()

Re: версии ПО

большого смысла скрывать версию нет, например на apache ты можешь исправить servertokens, для bind, строку version в options разделе, версию openssh через конфигурационный файл не исправишь, только правя исходники. все-равно, несмотря на версию, если кто-то серьезно ломать будет, то будет пробовать все доступные ему средства.

mator ★★★★★ ()
Ответ на: Re: версии ПО от theserg

Re: версии ПО

> т.е. играешь с кулхацкерами в игру "кто первый": он успеет ломануть сервак или ты сделать apt-get upgrade?

мой опыт говорит, что червяки и скрипт-киды не смотрят на версию, а сразу запускают k3w1 spl0itz, так что изменение версии не дает ничего.

А "кто первый" происходит вне зависимости от того, показывается версия, или нет.

ivlad ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.