LINUX.ORG.RU

Отваливается звук на новом ядре в Debian

 , ,


0

1

Debian 11 stable, после обновления на ядро 5.10.0-20-amd64 (и плюс обновления кучи разных пакетов).. Стал отваливаться звук в процессе работы. Чуть нажал на музыке где-то паузу, а обратно уже играет беззвучно, например. Чтобы отрубалось само, не замечал, обычно только когда где-нибудь паузу нажму. Выходное устройство выбрано, звук как будто есть, но в реальной жизни - тишина. Потом прописываю pulseaudio --kill, лезу выбираю выходное устройство и все опять работает. Пока где-то не отвалится в очередной раз. Не думаю, что это что-то новое на форуме, может надо указать каких-то логов для уточнения? (P.S. дрова у меня из пакета firmware-sof-signed)

Перемещено hobbit из general

и плюс обновления кучи разных пакетов

и все опять работает.

Дело не в новом ядре. С ядром всё хорошо. Удоли настроки из ~/.config связанные с pulse, dbus (папки), Удоли полностью ~/.cache/

перезагрузись.
Посмотри на выхлоп dmesg |grep error или dmesg |grep fail Но это так, если был звук, то конфигами старыми перебивается.

Roy-Batty
()

Нет пульсы - нет проблем.

дрова у меня из пакета firmware-sof-signed

Это не дрова, это прошивки.

firkax ★★★★★
()

останови pulseaudio
systemctl --user stop pulseaudio.socket
systemctl --user stop pulseaudio.socket

открой отдельный граф терминал и дай команду pulseaudio -v --log-time=1
воспроизводи проблему и смотри, какие предупреждения/ошибки падают в этот терминал
по коду ошибок гугли и там уже смотри, что нужно делать

d00fy ★★
()

Новое ядро, системд и пульсаудио и отваливается звук? Тут прекрасно всё.

burato ★★★★★
()

Учитывая тебя — что угодно. Судя по твоим прошлым темам, ты регулярно ставишь стороннее ПО в систему крайне кривыми и извращенными способами.

Настолько кривыми, что я даже не сразу понимаю, зачем ты так и что ты накосячил: Рай перфекциониста, или запуск приложения в той же иконке (комментарий)

Нет, серьезно, нафига лишнее действие? У тебя бинарник по известному тебе пути. Вместо того, чтобы тупо его указать, ты сперва сделал на него симлинк, потом уже его велел запускать. Зачем?

Сперва создай нового пользователя и проверь под ним, на уровне системы косяк или у тебя в конфигах твоего пользователя.

Vsevolod-linuxoid ★★★★★
()
Ответ на: комментарий от Vsevolod-linuxoid

Симлинк делал для красоты, чтобы мог из из терминала запускать одной командой. А пользователя второго создал, и в первые же 5мин увидел ровно то же самое. Значит, проблема в системный конфигах?.. Какой конфиг показывать?

Yarosvet
()
Ответ на: комментарий от Yarosvet

Хрен его знает, какой конфиг. Сперва покажи, что у тебя за пакеты в принципе стоят: for i in $(LANG=C apt list --installed 2>/dev/null | grep -v "^Listing..." | cut -f 2 -d / | cut -f 1 -d " " | cut -f 1 -d "," | sort | uniq); do echo $i; LANG=C apt list --installed 2>/dev/null | grep "/$i" | wc -l; done

Vsevolod-linuxoid ★★★★★
()
Ответ на: комментарий от Vsevolod-linuxoid
anydesk/now 6.2.1 amd64 [installed,local]
dbeaver-ce/now 22.3.0 amd64 [installed,upgradable to: 22.3.1]
discord/now 0.0.22 amd64 [installed,local]
exodus/now 22.10.22-1 amd64 [installed,local]
insomnia/now 2022.6.0-beta.4 amd64 [installed,local]
kata-shim/now 1.13.0~alpha0-48 amd64 [installed,local]
libpython3.6-minimal/now 3.6.3-1~deb9u1 amd64 [installed,local]
maltego/now 4.3.1 all [installed,local]
metasploit-framework/now 6.2.33+20221223112627~1rapid7-1 amd64 [installed,upgradable to: 6.2.34+20230103112628~1rapid7-1]
noaa-apt/now 1.3.1-1 amd64 [installed,local]
obsidian/now 0.15.9 amd64 [installed,local]
python3.6-minimal/now 3.6.3-1~deb9u1 amd64 [installed,local]
segger-jlink-udev-rules/now 7.66 all [installed,local]
st-stlink-server/now 2.1.0-1 amd64 [installed,local]
st-stlink-udev-rules/now 1.0.3-2 all [installed,local]
st-stm32cubeide-1.10.1/now 1.10.1-12716-20220707-0928-1 amd64 [installed,local]
virtualbox-6.1/unknown,now 6.1.40-154048~Debian~bullseye amd64 [installed]
Yarosvet
()
Ответ на: комментарий от Yarosvet
  • Есть вопросы:

metasploit-framework/now 6.2.33+20221223112627~1rapid7-1 amd64 [installed,upgradable to: 6.2.34+20230103112628~1rapid7-1] — он у тебя тут обновиться хочет, то есть есть репозиторий, как я понимаю… интересно, что не дает? Покажи выводы:

apt install -sf
apt upgrade -s

obsidian/now 0.15.9 amd64 [installed,local] — а этот DEB откуда взял? На официальном сайте варианта нет, только Flatpak, Snap, AppImage.

libpython3.6-minimal/now 3.6.3-1~deb9u1 amd64 [installed,local]
python3.6-minimal/now 3.6.3-1~deb9u1 amd64 [installed,local]

— А вот это такая себе идея — хотя если это не перезаписывает оригинальный 3.9, то может и норм. Покажи выводы

apt remove --purge -s libpython3.6-minimal python3.6-minimal
apt install -s libpython3.9-minimal python3.9-minimal
  • Есть комментарии:

anydesk/now 6.2.1 amd64 [installed,local] — использовать ПО не из репозиториев Debian нормально, но я бы на твоем месте подключил его официальный репозиторий, благо он есть: http://deb.anydesk.com/howto.html (это не ошибка, что не сделал, просто так удобнее, чтобы не обновлять руками).

dbeaver-ce/now 22.3.0 amd64 [installed,upgradable to: 22.3.1] — есть репозиторий, я бы его включил: https://dbeaver.io/download/ , плюс есть Flatpak или Snap, но я не вижу смысла их использовать, пока зависимости не создадут проблем.

insomnia/now 2022.6.0-beta.4 amd64 [installed,local] — есть репозиторий, я бы его включил: https://docs.insomnia.rest/insomnia/install , плюс есть Snap, но я не вижу смысла его использовать, пока зависимости не создадут проблем.

kata-shim/now 1.13.0~alpha0-48 amd64 [installed,local] — есть репозиторий, я бы его включил: https://github.com/kata-containers/documentation/blob/master/install/debian-installation-guide.md

segger-jlink-udev-rules/now 7.66 all [installed,local]
st-stlink-server/now 2.1.0-1 amd64 [installed,local]
st-stlink-udev-rules/now 1.0.3-2 all [installed,local]
st-stm32cubeide-1.10.1/now 1.10.1-12716-20220707-0928-1 amd64 [installed,local]

— не знаю, возможно и норм… хотя не уверен. Но не думаю, что ты тут ошибся, просто ПО возможно кривое, хотя не факт.

virtualbox-6.1/unknown,now 6.1.40-154048~Debian~bullseye amd64 [installed] — уже вышел 7.0, использовать 6.1 нормально, он поддерживается, но если хочешь, можешь обновиться.

  • Всё остальное вроде правильно поставил.
Vsevolod-linuxoid ★★★★★
()
Ответ на: комментарий от Vsevolod-linuxoid

Метасплоиту не даю обновляться я, тк он каждый день новую версию пихает, и не хочется каждый раз по полгига обновлять, хотя я им не пользуюсь каждый день. Все же, вывод команд..

ЗАМЕЧАНИЕ: Производится только имитация работы!
           Для реальной работы apt требуются права суперпользователя.
           Учтите, что блокировка не используется, поэтому нет полного
           соответствия с текущей реальной ситуацией!
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово         
Следующие пакеты устанавливались автоматически и больше не требуются:
  linux-headers-5.10.0-16-amd64 linux-headers-5.10.0-16-common
  linux-image-5.10.0-16-amd64 sse3-support
Для их удаления используйте «apt autoremove».
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено.
ЗАМЕЧАНИЕ: Производится только имитация работы!
           Для реальной работы apt требуются права суперпользователя.
           Учтите, что блокировка не используется, поэтому нет полного
           соответствия с текущей реальной ситуацией!
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово         
Расчёт обновлений… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  linux-headers-5.10.0-16-amd64 linux-headers-5.10.0-16-common
  linux-image-5.10.0-16-amd64 sse3-support
Для их удаления используйте «apt autoremove».
Следующие пакеты будут обновлены:
  dbeaver-ce metasploit-framework
Обновлено 2 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Inst dbeaver-ce [22.3.0] (22.3.1 dbeaver.io [amd64])
Inst metasploit-framework [6.2.33+20221223112627~1rapid7-1] (6.2.34+20230103112628~1rapid7-1 Metasploit Framework:downloads.metasploit.com [amd64])
Conf dbeaver-ce (22.3.1 dbeaver.io [amd64])
Conf metasploit-framework (6.2.34+20230103112628~1rapid7-1 Metasploit Framework:downloads.metasploit.com [amd64])

Обсидиан взят из https://github.com/obsidianmd/obsidian-releases/releases и отлично работает. Для питона все ок работает 3.9, хотя я и крутил что-то с pyenv но в результате его послал. выводы:

ЗАМЕЧАНИЕ: Производится только имитация работы!
           Для реальной работы apt требуются права суперпользователя.
           Учтите, что блокировка не используется, поэтому нет полного
           соответствия с текущей реальной ситуацией!
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово         
Следующие пакеты устанавливались автоматически и больше не требуются:
  linux-headers-5.10.0-16-amd64 linux-headers-5.10.0-16-common
  linux-image-5.10.0-16-amd64 sse3-support
Для их удаления используйте «apt autoremove».
Следующие пакеты будут УДАЛЕНЫ:
  libpython3.6-minimal* python3.6-minimal*
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 2 пакетов, и 2 пакетов не обновлено.
Purg python3.6-minimal [3.6.3-1~deb9u1]
Purg libpython3.6-minimal [3.6.3-1~deb9u1]
ЗАМЕЧАНИЕ: Производится только имитация работы!
           Для реальной работы apt требуются права суперпользователя.
           Учтите, что блокировка не используется, поэтому нет полного
           соответствия с текущей реальной ситуацией!
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово         
Уже установлен пакет libpython3.9-minimal самой новой версии (3.9.2-1).
libpython3.9-minimal помечен как установленный вручную.
Уже установлен пакет python3.9-minimal самой новой версии (3.9.2-1).
python3.9-minimal помечен как установленный вручную.
Следующие пакеты устанавливались автоматически и больше не требуются:
  linux-headers-5.10.0-16-amd64 linux-headers-5.10.0-16-common
  linux-image-5.10.0-16-amd64 sse3-support
Для их удаления используйте «apt autoremove».
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено.

(Порядок?)

Yarosvet
()
Ответ на: комментарий от Vsevolod-linuxoid

За Anydesk репоз спасибо, dbeaver уже и так стоит репоз, но то ли он меня доканал со своими «обнови меня» что я его обновил напрямую, то ли все нормально. Инсомния взята откуда-то но спс за репозиторий, а в ката я разочаровался т.к. там неудобно прикручивать GUI из-за самой специфики работы виртуальной машины, а это для меня было важно - повышенная безопасность и изоляция, при относительно комфортной работе с интерфейсом.

Yarosvet
()
Ответ на: комментарий от Yarosvet

в ката я разочаровался т.к. там неудобно прикручивать GUI из-за самой специфики работы виртуальной машины

Эм… как я понял, это вообще-то GUI к контейнерам, а не к виртуалкам.

Vsevolod-linuxoid ★★★★★
()
Ответ на: комментарий от Yarosvet

Хм… честно говоря, выглядит всё вполне нормально, особо подозрительного не вижу. А для чего тебе понадобился именно Python 3.6, а не 3.9?

Но вообще выглядит так, как будто придется отлаживать по-взрослому. Создай нового пользователя и запусти там PulseAudio в режиме отладки, как тут описано: https://fedoraproject.org/wiki/How_to_debug_PulseAudio_problems

Vsevolod-linuxoid ★★★★★
()
Ответ на: комментарий от Vsevolod-linuxoid

Питон 3.6 нужен был когда-то для каких-то пакетов, уже и не вспомню.

Вот лог пульсы: https://pastebin.com/Ub3kg2LB

И похоже, я заметил что эту ошибку вызвать труднее (или ее нет?) если я использую совмещенно два монитора. У меня ноутбук и к нему подключен монитор, и у меня всегда стоит в режиме «один дисплей» и это монитор.

Yarosvet
()
Ответ на: комментарий от Vsevolod-linuxoid

https://pastebin.com/UANfZkNb Это прямо с момента, как я нажал в музыке паузу, пошел загрузил на другой странице ютуб, и вернулся на страницу музыки и, по окончанию лога видно что оно «processing to rewind» - это я попытался включить музыку, но звук уже не пошел. Кстати, в гноме в параметрах звука, дорожка «бегает», мол звук идет, но только по факту его нет.

Yarosvet
()
Последнее исправление: Yarosvet (всего исправлений: 1)
Ответ на: комментарий от Yarosvet

Честно говоря, понятия не имею, что за ерунда. Предлагаю заменить PulseAudio на PipeWire и посмотреть, что выйдет. Сейчас на виртуалке проверю, как будет работать.

Vsevolod-linuxoid ★★★★★
()
Ответ на: комментарий от Yarosvet

Короче, я поставил в виртуалку Debian 11 с GNOME, как у тебя, и успешно заменил PulseAudio на PipeWire, звук после работает.

В общем, для начала нужно прописать в /etc/apt/sources.list бекпорты, если они ещё не прописаны, конечно, строчка выглядит так:

deb http://deb.debian.org/debian/ bullseye-backports main contrib non-free

После чего нужно от root поставить из них необходимые пакеты:

apt install -t bullseye-backports pipewire pipewire-pulse pipewire-audio-client-libraries wireplumber libspa-0.2-bluetooth

После чего от обычного пользователя, не от root нужно переключить звук на PW:

systemctl --user --now disable pulseaudio.service pulseaudio.socket
systemctl --user mask pulseaudio
systemctl --user --now enable wireplumber.service

Потом перезагрузка и на следующем логине должен звук идти через PW:

seva@debian:~$ LANG=C pactl info | grep '^Server Name'
Server Name: PulseAudio (on PipeWire 0.3.63)

По идее PipeWire эмулирует API PulseAudio для всех программ, так что звук должен нормально работать.

Можешь попробовать, авось сработает. И это не имеет отношения ко звуку, но я бы удалил Python 3.6, раз он не нужен более:

apt remove --purge libpython3.6-minimal python3.6-minimal
Vsevolod-linuxoid ★★★★★
()
Ответ на: комментарий от Vsevolod-linuxoid

При установке PipeWire:

Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово         
Уже установлен пакет pipewire самой новой версии (0.3.19-4).
pipewire помечен как установленный вручную.
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 pipewire-pulse : Зависит: pipewire (= 0.3.63-1~bpo11+1) но 0.3.19-4 должен быть установлен
                  Ломает: pipewire-bin (< 0.3.27-2)
                  Ломает: pipewire-bin:i386 (< 0.3.27-2)
 wireplumber : Зависит: libpipewire-0.3-0 (>= 0.3.52) но 0.3.19-4 должен быть установлен
               Зависит: libwireplumber-0.4-0 (= 0.4.13-1~bpo11+1) но он не будет установлен
               Зависит: pipewire (>= 0.3.52) но 0.3.19-4 должен быть установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

Это ли не значит, что какая-то версия PipeWire установлена?

Yarosvet
()
Ответ на: комментарий от Yarosvet

Ну да, похоже на то, что стоит. Правда у тебя версия не из бекпортов, и она известна проблемами, молодая технология.

Покажи вывод apt list --installed 2>/dev/null | grep pipewire

Vsevolod-linuxoid ★★★★★
()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 2)
Ответ на: комментарий от Yarosvet
                 Ломает: pipewire-bin (< 0.3.27-2)
                  Ломает: pipewire-bin:i386 (< 0.3.27-2)

Блин, откуда это вообще взялось?

Vsevolod-linuxoid ★★★★★
()
Ответ на: комментарий от Vsevolod-linuxoid

первый вывод:

gstreamer1.0-pipewire/stable,now 0.3.19-4 amd64 [установлен, автоматически]
libpipewire-0.3-0/stable,now 0.3.19-4 amd64 [установлен, автоматически]
libpipewire-0.3-modules/stable,now 0.3.19-4 amd64 [установлен, автоматически]
pipewire-bin/stable,now 0.3.19-4 amd64 [установлен, автоматически]
pipewire/stable,now 0.3.19-4 amd64 [установлен, автоматически]

Второй:

deb http://mirror.truenetwork.ru/debian/ bullseye main non-free contrib
deb-src http://mirror.truenetwork.ru/debian/ bullseye main non-free contrib
deb http://security.debian.org/debian-security bullseye-security main contrib non-free
deb-src http://security.debian.org/debian-security bullseye-security main contrib non-free
deb http://mirror.truenetwork.ru/debian/ bullseye-updates main contrib non-free
deb-src http://mirror.truenetwork.ru/debian/ bullseye-updates main contrib non-free
deb http://deb.debian.org/debian bullseye-backports main contrib non-free
deb-src http://deb.debian.org/debian bullseye-backports main contrib non-free
deb [arch=amd64 signed-by=/usr/share/keyrings/oracle-virtualbox-2016.gpg] https://download.virtualbox.org/virtualbox/debian bullseye contrib non-free

Откуда взялось - не знаю, честное слово, руками не трогал!) да и написано вроде «установлено автоматически». Значит, при каком-то обновлении дебиана?.. Но почему тогда его не было у тебя на ВМ?

Yarosvet
()
Ответ на: комментарий от Yarosvet

Просто придется немного хитрее команду указать:

apt install -t bullseye-backports pipewire pipewire-pulse pipewire-audio-client-libraries wireplumber libspa-0.2-bluetooth gstreamer1.0-pipewire libpipewire-0.3-0 libpipewire-0.3-modules pipewire-bin

Всё нормально. Просто по зависимостям от какого-то ПО прилетели библиотеки, что зависят от определенной версии PipeWire, потому при установке его из бекпортов их тоже нужно обновлять. А у меня на виртуалке ОС с минимум ПО, вот их и не было.

Vsevolod-linuxoid ★★★★★
()
Ответ на: комментарий от Vsevolod-linuxoid

так все то же

Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово         
Уже установлен пакет gstreamer1.0-pipewire самой новой версии (0.3.19-4).
gstreamer1.0-pipewire помечен как установленный вручную.
Уже установлен пакет libpipewire-0.3-0 самой новой версии (0.3.19-4).
libpipewire-0.3-0 помечен как установленный вручную.
Уже установлен пакет libpipewire-0.3-modules самой новой версии (0.3.19-4).
libpipewire-0.3-modules помечен как установленный вручную.
Уже установлен пакет pipewire самой новой версии (0.3.19-4).
pipewire помечен как установленный вручную.
Уже установлен пакет pipewire-bin самой новой версии (0.3.19-4).
pipewire-bin помечен как установленный вручную.
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 pipewire-pulse : Зависит: pipewire (= 0.3.63-1~bpo11+1) но 0.3.19-4 должен быть установлен
                  Ломает: pipewire-bin (< 0.3.27-2)
                  Ломает: pipewire-bin:i386 (< 0.3.27-2)
 wireplumber : Зависит: libpipewire-0.3-0 (>= 0.3.52) но 0.3.19-4 должен быть установлен
               Зависит: libwireplumber-0.4-0 (= 0.4.13-1~bpo11+1) но он не будет установлен
               Зависит: pipewire (>= 0.3.52) но 0.3.19-4 должен быть установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.
Yarosvet
()
Ответ на: комментарий от Yarosvet

Долбаные циклические зависимости. APT не силен в их решении. Попробуй:

apt install aptitude
aptitude install -t bullseye-backports pipewire pipewire-pulse pipewire-audio-client-libraries wireplumber libspa-0.2-bluetooth gstreamer1.0-pipewire libpipewire-0.3-0 libpipewire-0.3-modules pipewire-bin
Vsevolod-linuxoid ★★★★★
()
Ответ на: комментарий от Vsevolod-linuxoid
gstreamer1.0-pipewire уже установлен в запрошенной версии (0.3.19-4)
libpipewire-0.3-0 уже установлен в запрошенной версии (0.3.19-4)
libpipewire-0.3-modules уже установлен в запрошенной версии (0.3.19-4)
pipewire-bin уже установлен в запрошенной версии (0.3.19-4)
pipewire уже установлен в запрошенной версии (0.3.19-4)
gstreamer1.0-pipewire уже установлен в запрошенной версии (0.3.19-4)
libpipewire-0.3-0 уже установлен в запрошенной версии (0.3.19-4)
libpipewire-0.3-modules уже установлен в запрошенной версии (0.3.19-4)
pipewire-bin уже установлен в запрошенной версии (0.3.19-4)
Следующие НОВЫЕ пакеты будут установлены:
  libldacbt-abr2{a} libldacbt-enc2{a} libopenaptx0{a} libspa-0.2-bluetooth 
  pipewire-audio-client-libraries pipewire-pulse{b} wireplumber{b} 
Следующие пакеты будут УДАЛЕНЫ:
  linux-headers-5.10.0-16-amd64{u} linux-headers-5.10.0-16-common{u} 
  sse3-support{u} 
0 пакетов обновлено, 7 установлено новых, 3 пакетов отмечено для удаления, и 2 пакетов не обновлено.
Необходимо получить 324 kБ архивов. После распаковки освободится 57,3 MБ.
Следующие пакеты имеют неудовлетворённые зависимости:
 pipewire-pulse : Зависит: pipewire (= 0.3.63-1~bpo11+1) но установлен 0.3.19-4
                  Ломает: pipewire-bin (< 0.3.27-2) но установлен 0.3.19-4
                  Ломает: pipewire-bin:i386 (< 0.3.27-2) но его установка не запланирована
 wireplumber : Зависит: libpipewire-0.3-0 (>= 0.3.52) но установлен 0.3.19-4
               Зависит: libwireplumber-0.4-0 (= 0.4.13-1~bpo11+1) но его невозможно установить
               Зависит: pipewire (>= 0.3.52) но установлен 0.3.19-4
Следующие действия разрешат зависимости:

     Оставить для следующих пакетов их текущие версии:
1)     pipewire-pulse [Не установлен]                 
2)     wireplumber [Не установлен]                    

     Оставить следующие зависимости неразрешёнными:   
3)     wireplumber рекомендует pipewire-pulse         



Принять данное решение? [Y/n/q/?] Y
Следующие НОВЫЕ пакеты будут установлены:
  libldacbt-abr2{a} libldacbt-enc2{a} libopenaptx0{a} libspa-0.2-bluetooth 
  pipewire-audio-client-libraries 
Следующие пакеты будут УДАЛЕНЫ:
  linux-headers-5.10.0-16-amd64{u} linux-headers-5.10.0-16-common{u} 
  sse3-support{u} 
0 пакетов обновлено, 5 установлено новых, 3 пакетов отмечено для удаления, и 2 пакетов не обновлено.
Необходимо получить 224 kБ архивов. После распаковки освободится 57,9 MБ.
Хотите продолжить? [Y/n/?] y
Получить: 1 http://mirror.truenetwork.ru/debian bullseye/main amd64 libldacbt-enc2 amd64 2.0.2.3+git20200429+ed310a0-4 [24,6 kB]
Получить: 2 http://mirror.truenetwork.ru/debian bullseye/main amd64 libldacbt-abr2 amd64 2.0.2.3+git20200429+ed310a0-4 [5 152 B]
Получить: 3 http://mirror.truenetwork.ru/debian bullseye/main amd64 libopenaptx0 amd64 0.2.0-5 [14,1 kB]
Получить: 4 http://mirror.truenetwork.ru/debian bullseye/main amd64 libspa-0.2-bluetooth amd64 0.3.19-4 [93,1 kB]
Получить: 5 http://mirror.truenetwork.ru/debian bullseye/main amd64 pipewire-audio-client-libraries amd64 0.3.19-4 [86,8 kB]
Получено 224 kБ в 1с (259 kБ/с)                            
(Чтение базы данных … на данный момент установлено 454154 файла и каталога.)
Удаляется linux-headers-5.10.0-16-amd64 (5.10.127-2) …
Удаляется linux-headers-5.10.0-16-common (5.10.127-2) …
Удаляется sse3-support (6) …
Выбор ранее не выбранного пакета libldacbt-enc2:amd64.
(Чтение базы данных … на данный момент установлено 435642 файла и каталога.)
Подготовка к распаковке …/libldacbt-enc2_2.0.2.3+git20200429+ed310a0-4_amd64.deb …
Распаковывается libldacbt-enc2:amd64 (2.0.2.3+git20200429+ed310a0-4) …
Выбор ранее не выбранного пакета libldacbt-abr2:amd64.
Подготовка к распаковке …/libldacbt-abr2_2.0.2.3+git20200429+ed310a0-4_amd64.deb …
Распаковывается libldacbt-abr2:amd64 (2.0.2.3+git20200429+ed310a0-4) …
Выбор ранее не выбранного пакета libopenaptx0:amd64.
Подготовка к распаковке …/libopenaptx0_0.2.0-5_amd64.deb …
Распаковывается libopenaptx0:amd64 (0.2.0-5) …
Выбор ранее не выбранного пакета libspa-0.2-bluetooth:amd64.
Подготовка к распаковке …/libspa-0.2-bluetooth_0.3.19-4_amd64.deb …
Распаковывается libspa-0.2-bluetooth:amd64 (0.3.19-4) …
Выбор ранее не выбранного пакета pipewire-audio-client-libraries:amd64.
Подготовка к распаковке …/pipewire-audio-client-libraries_0.3.19-4_amd64.deb …
Распаковывается pipewire-audio-client-libraries:amd64 (0.3.19-4) …
Настраивается пакет libldacbt-enc2:amd64 (2.0.2.3+git20200429+ed310a0-4) …
Настраивается пакет libldacbt-abr2:amd64 (2.0.2.3+git20200429+ed310a0-4) …
Настраивается пакет libopenaptx0:amd64 (0.2.0-5) …
Настраивается пакет pipewire-audio-client-libraries:amd64 (0.3.19-4) …
Настраивается пакет libspa-0.2-bluetooth:amd64 (0.3.19-4) …
Обрабатываются триггеры для man-db (2.9.4-2) …
Обрабатываются триггеры для libc-bin (2.31-13+deb11u5) …

Но не похоже что оно все-таки установилось

Yarosvet
()
Ответ на: комментарий от Vsevolod-linuxoid
gstreamer1.0-pipewire/stable,now 0.3.19-4 amd64 [установлен, автоматически]
libpipewire-0.3-0/stable,now 0.3.19-4 amd64 [установлен, автоматически]
libpipewire-0.3-modules/stable,now 0.3.19-4 amd64 [установлен, автоматически]
pipewire-audio-client-libraries/stable,now 0.3.19-4 amd64 [установлен]
pipewire-bin/stable,now 0.3.19-4 amd64 [установлен, автоматически]
pipewire/stable,now 0.3.19-4 amd64 [установлен, автоматически]
Yarosvet
()
Ответ на: комментарий от Vsevolod-linuxoid
ЗАМЕЧАНИЕ: Производится только имитация работы!
           Для реальной работы apt требуются права суперпользователя.
           Учтите, что блокировка не используется, поэтому нет полного
           соответствия с текущей реальной ситуацией!
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово         
Заметьте, выбирается «pipewire-media-session» для шаблона «pipewire*»
Заметьте, выбирается «pipewire-pulse» для шаблона «pipewire*»
Заметьте, выбирается «pipewire-audio-client-libraries» для шаблона «pipewire*»
Заметьте, выбирается «pipewire» для шаблона «pipewire*»
Заметьте, выбирается «pipewire-tests» для шаблона «pipewire*»
Заметьте, выбирается «pipewire-v4l2» для шаблона «pipewire*»
Заметьте, выбирается «pipewire-jack» для шаблона «pipewire*»
Заметьте, выбирается «pipewire-bin» для шаблона «pipewire*»
Заметьте, выбирается «pipewire-doc» для шаблона «pipewire*»
Заметьте, выбирается «pipewire-alsa» для шаблона «pipewire*»
Пакет «pipewire-media-session» не установлен, поэтому не может быть удалён
Пакет «pipewire-alsa» не установлен, поэтому не может быть удалён
Пакет «pipewire-doc» не установлен, поэтому не может быть удалён
Пакет «pipewire-jack» не установлен, поэтому не может быть удалён
Пакет «pipewire-pulse» не установлен, поэтому не может быть удалён
Пакет «pipewire-tests» не установлен, поэтому не может быть удалён
Пакет «pipewire-v4l2» не установлен, поэтому не может быть удалён
Следующие пакеты устанавливались автоматически и больше не требуются:
  gir1.2-accountsservice-1.0 gir1.2-gck-1 gir1.2-gcr-3 gir1.2-gdm-1.0 gir1.2-gmenu-3.0 gir1.2-gnomebluetooth-1.0
  gir1.2-graphene-1.0 gir1.2-gtop-2.0 gir1.2-handy-0.0 gir1.2-ibus-1.0 gir1.2-mutter-7 gir1.2-nm-1.0 gir1.2-nma-1.0
  gir1.2-rsvg-2.0 gir1.2-upowerglib-1.0 gnome-session-bin gnome-session-common gnome-shell-common hyphen-en-us ibus
  ibus-data ibus-gtk ibus-gtk3 im-config libgdm1 libgnome-menu-3-0 libmutter-7-0 libpipewire-0.3-modules
  libreoffice-help-en-us libvncserver1 linux-image-5.10.0-16-amd64 mutter-common mythes-en-us python3-ibus-1.0
  switcheroo-control xwayland
Для их удаления используйте «apt autoremove».
Следующие пакеты будут УДАЛЕНЫ:
  chrome-gnome-shell* gdm3* gnome* gnome-core* gnome-remote-desktop* gnome-session* gnome-shell*
  gnome-shell-extension-appindicator* gnome-shell-extension-dashtodock* gnome-shell-extension-desktop-icons*
  gnome-shell-extension-prefs* gnome-shell-extension-system-monitor* gnome-shell-extensions* gnome-tweaks*
  gstreamer1.0-pipewire* pipewire* pipewire-audio-client-libraries* pipewire-bin* task-gnome-desktop*
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 19 пакетов, и 2 пакетов не обновлено.
Purg chrome-gnome-shell [10.1-5]
Purg gnome [1:3.38+3]
Purg task-gnome-desktop [3.68+deb11u1]
Purg gnome-core [1:3.38+3]
Purg gdm3 [3.38.2.1-1]
Purg gnome-remote-desktop [0.1.9-5]
Purg gnome-session [3.38.0-4]
Purg gnome-shell-extensions [3.38.2-1]
Purg gnome-shell-extension-system-monitor [38+git20200414-32cc79e-1]
Purg gnome-shell [3.38.6-1~deb11u1] [gnome-shell-extension-dashtodock:amd64 gnome-shell-extension-appindicator:amd64 gnome-shell-extension-desktop-icons:amd64 gnome-shell-extension-prefs:amd64 ]
Purg gnome-shell-extension-appindicator [34-1] [gnome-shell-extension-dashtodock:amd64 gnome-shell-extension-desktop-icons:amd64 gnome-shell-extension-prefs:amd64 ]
Purg gnome-shell-extension-dashtodock [69-1] [gnome-shell-extension-desktop-icons:amd64 gnome-shell-extension-prefs:amd64 ]
Purg gnome-shell-extension-desktop-icons [20.04.0+git20200908-5] [gnome-shell-extension-prefs:amd64 ]
Purg gnome-tweaks [3.34.0-4] [gnome-shell-extension-prefs:amd64 ]
Purg gnome-shell-extension-prefs [3.38.6-1~deb11u1]
Purg gstreamer1.0-pipewire [0.3.19-4]
Purg pipewire-audio-client-libraries [0.3.19-4]
Purg pipewire [0.3.19-4]
Purg pipewire-bin [0.3.19-4]
Yarosvet
()
Ответ на: комментарий от Yarosvet

У тебя на новом пользователе, ты писал, те же проблемы. Если ты не менял системные конфиги пульсы, то не поможет.

И ей-богу, обычный мелкий dep-hell. Немного возни и всё.

Vsevolod-linuxoid ★★★★★
()
Ответ на: комментарий от Yarosvet

Не соглашайся, просто скажи, что выдается на такую команду?

aptitude install -t bullseye-backports gstreamer1.0-pipewire libpipewire-0.3-0 libpipewire-0.3-modules pipewire-audio-client-libraries pipewire-bin pipewire

Попробуем обновить только установленные без установки новых сверх того.

Vsevolod-linuxoid ★★★★★
()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от Vsevolod-linuxoid
gstreamer1.0-pipewire уже установлен в запрошенной версии (0.3.19-4)
libpipewire-0.3-0 уже установлен в запрошенной версии (0.3.19-4)
libpipewire-0.3-modules уже установлен в запрошенной версии (0.3.19-4)
pipewire-audio-client-libraries уже установлен в запрошенной версии (0.3.19-4)
pipewire-bin уже установлен в запрошенной версии (0.3.19-4)
pipewire уже установлен в запрошенной версии (0.3.19-4)
gstreamer1.0-pipewire уже установлен в запрошенной версии (0.3.19-4)
libpipewire-0.3-0 уже установлен в запрошенной версии (0.3.19-4)
libpipewire-0.3-modules уже установлен в запрошенной версии (0.3.19-4)
pipewire-audio-client-libraries уже установлен в запрошенной версии (0.3.19-4)
pipewire-bin уже установлен в запрошенной версии (0.3.19-4)
pipewire уже установлен в запрошенной версии (0.3.19-4)
Ни одного пакета не будет установлено, обновлено или удалено.
0 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 2 пакетов не обновлено.
Необходимо получить 0 Б архивов. После распаковки 0 Б будет занято.
Yarosvet
()
Ответ на: комментарий от Vsevolod-linuxoid
gstreamer1.0-pipewire:
  Установлен: 0.3.19-4
  Кандидат:   0.3.19-4
  Таблица версий:
     0.3.63-1~bpo11+1 100
        100 http://deb.debian.org/debian bullseye-backports/main amd64 Packages
 *** 0.3.19-4 1000
       1000 http://mirror.truenetwork.ru/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
Yarosvet
()
Ответ на: комментарий от Yarosvet

Сдаюсь. Понятия не имею, как тебе помочь и в чём дело.

Только что откатил виртуалку на снимок после первой установки:

gstreamer1.0-pipewire/stable,now 0.3.19-4 amd64 [установлен, автоматически]
libpipewire-0.3-0/stable,now 0.3.19-4 amd64 [установлен, автоматически]
libpipewire-0.3-modules/stable,now 0.3.19-4 amd64 [установлен, автоматически]
pipewire-bin/stable,now 0.3.19-4 amd64 [установлен, автоматически]
pipewire/stable,now 0.3.19-4 amd64 [установлен, автоматически]

То же, что у тебя. При этом инструкцию я писал с реальной ОС по установке PW. И всё работало, версия обновилась. Понятия не имею, что именно у тебя так держит пакеты.

Сейчас на виртуалке где всё сработало так:

gstreamer1.0-pipewire/bullseye-backports,now 0.3.63-1~bpo11+1 amd64 [установлен, автоматически]
libpipewire-0.3-0/bullseye-backports,now 0.3.63-1~bpo11+1 amd64 [установлен, автоматически]
libpipewire-0.3-common/bullseye-backports,now 0.3.63-1~bpo11+1 all [установлен, автоматически]
libpipewire-0.3-modules/bullseye-backports,now 0.3.63-1~bpo11+1 amd64 [установлен, автоматически]
pipewire-alsa/bullseye-backports,now 0.3.63-1~bpo11+1 amd64 [установлен, автоматически]
pipewire-audio-client-libraries/bullseye-backports,now 0.3.63-1~bpo11+1 all [установлен]
pipewire-bin/bullseye-backports,now 0.3.63-1~bpo11+1 amd64 [установлен, автоматически]
pipewire-jack/bullseye-backports,now 0.3.63-1~bpo11+1 amd64 [установлен, автоматически]
pipewire-pulse/bullseye-backports,now 0.3.63-1~bpo11+1 amd64 [установлен]
pipewire/bullseye-backports,now 0.3.63-1~bpo11+1 amd64 [установлен, автоматически]
Vsevolod-linuxoid ★★★★★
()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 3)
Ответ на: комментарий от Vsevolod-linuxoid

К сожалению не могу найти строчек обновления в apt history, не откатить. Но а вдруг о чем-то говорит инфа, что звук возрождается командой pulseaudio --kill на некоторое время, и я постоянно прописываю это чтобы звук работал. Звук вылетает, когда я ставлю что-то на паузу (то есть звуковое устройство переходит в режим ожидания?). И главное, проблемы АБСОЛЮТНО и точно нет, когда я использую «расширить дисплеи», а не как обычно «один дисплей» в gnome. Вдруг это все что-то говорит?

Yarosvet
()
Ответ на: комментарий от Vsevolod-linuxoid

Решилось. А решилось отключением режима ожидания у устройств. Некрасиво, но снаружи это незаметно. Закомментировал в /etc/pulse/default.pa строчку:

load-module module-suspend-on-idle

Интересно, а это как-то скажется, допустим, на энергопотреблении? Ноут же, иногда сижу с аккумулятора

Yarosvet
()
Последнее исправление: Yarosvet (всего исправлений: 1)
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.