LINUX.ORG.RU
решено ФорумMobile

«Заморозка» обновления пакетов в Maemo

 , , , ,


0

1

Есть проблема: поставил себе поддержку HD в камере, для этого нужно было поставить специальную версию камеры и библиотек(системой опознается как более старая версия). Все работает, но при установке и удалении пакета через терминал ругается и блокирует действие - просит обновление. Обновлю - лишусь HD. Вопрос: можно ли как то «заморозить» обновление конкретных пакетов? Вывод терминала ниже:

установка программы:

BusyBox v1.10.2 (Debian 3:1.10.2.legal-1osso31+0cssu0) built-in shell (ash) 
Enter 'help' for a list of built-in commands. 

/home/user # apt-get remove necroplayer 
Reading package lists... Done 
Building dependency tree 
Reading state information... Done 
You might want to run `apt-get -f install' to correct these: 
The following packages have unmet dependencies: 
mp-fremantle-community-pr: Depends: camera-ui (>= 1.1.29.2+0cssu15+thumb0) but 1.1.29.2+0cssu7 is to be installed 
Depends: libgdigicam-gst-camerabin0 (>= 0.3.29.2+0cssu1+thumb0) but 0.3.29.1+0m5 is to be installed 
Depends: libgdigicam0 (>= 0.3.29.2+0cssu1+thumb0) but 0.3.29.1+0m5 is to be installed 
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). 
/home/user # 
Вот попытка исправить как советует терминал:
BusyBox v1.10.2 (Debian 3:1.10.2.legal-1osso31+0cssu0) built-in shell (ash) 
Enter 'help' for a list of built-in commands. 

/home/user # apt-get -f intall 
E: Invalid operation intall 
/home/user # apt-get -f install 
Reading package lists... Done 
Building dependency tree 
Reading state information... Done 
Correcting dependencies... Done 
The following packages were automatically installed and are no longer required: 
python2.5-qt4-svg python2.5-qt4-xml python2.5-qt4-test 
python2.5-qt4-phonon python2.5-qt4 python2.5-qt4-script 
python2.5-qt4-gl python2.5-qt4-multimedia 
python2.5-qt4-xmlpatterns 
Use 'apt-get autoremove' to remove them. 
The following extra packages will be installed: 
camera-ui libgdigicam-gst-camerabin0 libgdigicam0 
The following packages will be upgraded: 
camera-ui libgdigicam-gst-camerabin0 libgdigicam0 
3 upgraded, 0 newly installed, 0 to remove and 5 not upgraded. 
Need to get 102kB of archives. 
After this operation, 49,2kB disk space will be freed. 
Do you want to continue [Y/n]?
На форуме предлагали сделать так, но не помогло:
dpkg --set-selections << end
camera-ui hold
libgdigicam-gst-camerabin0 hold
libgdigicam0 hold
end
Может что-то не так делаю? есть ли варианты остаться со модифицированными пакетами и работать с пакетами через терминал? Тема на форуме Meegos.ru - http://meegos.ru/forum/viewtopic.php?pid=125908 Наперед благодарю за ответы!

Ответ на: комментарий от invokercd

тогда выходит:

apt-mark hold
camera-ui
libgdigicam-gst-camerabin0
libgdigicam0
правильно понял? извините - слабо шарю в командах терминала

badazimer ()
Ответ на: комментарий от invokercd

Почему-то не вышло

BusyBox v1.10.2 (Debian 3:1.10.2.legal-1osso31+0cssu0) built-in shell (ash) 
Enter 'help' for a list of built-in commands. 

~ $ sudo gainroot 
Root shell enabled 


BusyBox v1.10.2 (Debian 3:1.10.2.legal-1osso31+0cssu0) built-in shell (ash) 
Enter 'help' for a list of built-in commands. 

/home/user # apt-mark hold camera-ui libgdigicam-gst-camerabin0 libgdigicam0 
Error importing apt_pkg, is python-apt installed? 
Traceback (most recent call last): 
File "/usr/bin/apt-mark", line 18, in <module> 
apt_pkg.init() 
NameError: name 'apt_pkg' is not defined 
/home/user # 
что я сделал не так?

badazimer ()
Ответ на: комментарий от invokercd

это невозможно так как все проблема и состоит в том что не могу ничего поставить.

/home/user # apt-get install python-apt 
Reading package lists... Done 
Building dependency tree 
Reading state information... Done 
You might want to run `apt-get -f install' to correct these: 
The following packages have unmet dependencies: 
mp-fremantle-community-pr: Depends: camera-ui (>= 1.1.29.2+0cssu15+thumb0) but 1.1.29.2+0cssu7 is to be installed 
Depends: libgdigicam-gst-camerabin0 (>= 0.3.29.2+0cssu1+thumb0) but 0.3.29.1+0m5 is to be installed 
Depends: libgdigicam0 (>= 0.3.29.2+0cssu1+thumb0) but 0.3.29.1+0m5 is to be installed 
python-apt: Depends: libapt-inst-libc6.5-6-1.1 
Depends: lsb-release but it is not going to be installed 
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). 
/home/user # 
Попробую через графический менеджер пакетов.

badazimer ()
Ответ на: комментарий от invokercd

решил проблему, правда совсем иным способом: дефолтный менеджер приложений Maemo позволяет устанавливать только полноценные пакеты, установка отдельных пакетов в нем заблокирована. Чтоб установить python-apt, про который Вы говорили - поставил Synaptic - начал лазить по менюшкам и нашел «Заблокировать версию». Заблокировал эти три пакета - теперь установка и удаление в терминале проходит без проблем. Вы натолкнули меня на решение - Спасибо!

badazimer ()
Ответ на: комментарий от invokercd

та не сложно, просто инструментарий немного ограничен и честно говоря у меня знаний часто не хватает

badazimer ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.