LINUX.ORG.RU

wlan0 ping


0

1

Добрый вечер!

Установил Арч на ноутбук Toshiba Satellite.

Настроил netcfg. Сделал два сетевых профиля:
1) eth0, dhcp (Atheros AR8151 v2.0 Gigabit Ethernet)
2) wlan0, dhcp (Atheros AR9285 Wireless Network Adapter PCI-E)

Указал на них в rc.conf, подключил демона net-profiles там же.
Запускаю сеть командой: netcfg <profile-name>

# ifconfig wlan0

wlan0 : flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500 metric 1
        inet 192.168.1.102  netmask 255.255.255.0  broadcast 192.168.1.255
        ether 68:a3:c4:e0:f2:59  txqueuelen 1000  (Ethernet)
        RX packets 778  bytes 98422 (96.1 KiB)
        RX errors 0  dropped 410  overruns 0  frame 0
        TX packets 45  bytes 4817 (4.7 KiB)
        TX errors 0  dropped 0  overruns 0  carrier 0  collisions 0

# ping -c4 192.168.1.102

4 packets transmitted, 4 received, 0% packet loss
rtt avg = 0.041ms

# ping -c4 google.com

4 packets transmitted, 4 received, 0% packet loss
rtt avg = 55.917ms

Но когда пингую с другой машины в локальной сети (проводное подключение к рутеру), пакеты теряются:

# ping -c4 192.168.1.102

4 packets transmitted, 1 received, 75% packet loss
rtt avg = 83ms
Рутер пингуется нормально отовсюду.

Что я неправильно делаю?

Спасибо.

Ответ на: комментарий от vladislav
# cat /proc/net/wireless

Inter-	| sta-	| Quality		| Discarded packets			| Missed	| WE

face	| tus	| link	level	noise	| nwid	crypt	frag	retry	misc	| beacon 	| 22

wlan0:	| 0000	| 51.	| -59.	| -256	| 0	| 0	| 0	| 0	| 307	| 0
papasha ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.