LINUX.ORG.RU

ядро не находит init-процесс


0

0

Доброго времени суток, многоуважаемый All!

У меня случилось несчастие. Загрузка Линукса не проходит по причине того, что ядро, поставленное вместе со всем остальным дистрибутивом, ушло вместе с разделом /boot, а новое ядро, с диска не хочет прирастать поскольку выдает сообщение что-то про "Unable to syncing. Try pass init= to kernel". За точность не ручаюсь, но ключевые слова те.

Настройки для grub`а следующие:
root (hd0,2)
kernel (hd0,2)/boot/gentoo init=/sbin/init
[makeactive]
[boot]

последние две строчки -- вводились опционально, без квадратных скобок. Результатов не давали.
Не подскажет ли кто-нибудь выход из данной ситуации?

Re: ядро не находит init-процесс

Попробуй указать параметр ядра root=

А hd(0,2) из строки kernel я бы убрал :)

tailgunner ★★★★★ ()
Ответ на: Re: ядро не находит init-процесс от tailgunner

Re: ядро не находит init-процесс

Так это grub`овский синтаксис, он только так и видит root-directory и kernel. строчка init=sbin/init -- это уже то, что grub передает ядру. Или стоит все свести к единообразному синтаксису и для этого перелезть на lilo?

seryj_slon ()
Ответ на: Re: ядро не находит init-процесс от seryj_slon

Re: ядро не находит init-процесс

> Так это grub`овский синтаксис

Насколько я знаю, в строке kernel писать hd(0,2) нет необходимости - grub сам знает, что ядро надо брать с раздела, указанного в строке root.

> Или стоит все свести к единообразному синтаксису и для этого перелезть на lilo?

Перелезать на LILO не нужно - уж во всяком случае, не ради синткасиса.

tailgunner ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.