LINUX.ORG.RU

Что делать с этими версиями библиотек?


0

0

Помогите, что ли. Ставлю себе Кванту на AltLinux при этом Gnorpm показывает конфликт библиотек: Кванте нужна libpng.so.3, а в системе стоит libpng.so.2. Заменить библиотеки не получается, старая версия нужна куче программ. Добавляться не хочет. И что делать?

anonymous

Re: Что делать с этими версиями библиотек?

Почитай man rpm. Там имеется опция обновления версий библиотек. (Все действия производятся из консоли, использование
терминала может быть допускается, а может быть и нет).

В качестве варианта могу предложить следующее:
1) Составить список программ, использующих эту библиотеку.
2) Ручками из консоли вынести все эти программы, после чего вынести и библиотеку.
3) Там же, тем же образом установить новую версию библиотеки, после чего поставить на место вынесенные программы.

P.S. Если по каким-либо причинам новую версию библиотеки установить не удалось. то в обратном порядке при помощи
дистрибутивного диска все восстанавливается.


Ikonta_521 ()

Re: Что делать с этими версиями библиотек?

Попробуй просто ссылку забацать libpng.so.3,-> libpng.so.2

anonymous ()

Re: Что делать с этими версиями библиотек?

Лучше скопируй старую библиотеку куда-нибудь, ставь новую (rpm -Uvh libpng*rpm --nodeps) и потом старую клади на место. Если какой-нибудь из файлов существет, то пропусти его.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.