LINUX.ORG.RU

Не видет библиотеки


0

0

При выполнении ./configure arts-1.5.5.5 выдает [code] checking for Qt... configure: error: Qt (>= Qt 3.3 and < 4.0) (library qt-mt) not found. Please check your installation! For more details about this problem, look at the end of config.log. Make sure that you have compiled Qt with thread support!

[/code] До этого я успешно собрал qt 3.5.5 Содержание файла .profile [code] # ~/.profile: executed by Bourne-compatible login shells.

if [ -f ~/.bashrc ]; then . ~/.bashrc fi

mesg n QTDIR=/usr/local/qt PATH=$QTDIR/bin:$PATH MANPATH=$QTDIR/man:$MANPATH LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH LIBRARY_PATH=$LD_LIBRARY_PATH CPLUS_INCLUDE_PATH=$QTDIR/include:$CPLUS_INCLUDE_PATH export QTDIR PATH MANPATH LD_LIBRARY_PATH LIBRARY_PATH export CPLUS_INCLUDE_PATH [/code] содержание файла ld.so.conf [code] /usr/X11R6/lib /usr/local/qt/lib [/code] file:/usr/local/qt - адрес qt 3.5.5 file:/usr/local/KDE/arts-1.5.5 -адрес arts Дитсрибутив debian 3.1 Пожалуйста помогите решить проблему. P.S. Полный вывод ./configure и ldconfig -p слишком большой.

Re: Не видет библиотеки

Ну оно поставило QT в /usr/local/qt По дефольту из сорцов все инсталится в /usr/local/... опцию configure дай чтоб оно искало QT в той дире. Или надо поставить libqt3-mt-dev пакет. А вобще зачем делать make install? Ты что слакофил?

qsloqs ★★ ()
Ответ на: Re: Не видет библиотеки от qsloqs

Re: Не видет библиотеки

Нет. У меня стоит стабл. Если я ставлю пакеты из тестинга,то апт тянет зависмимости. В самый первый раз когда я такое сделал мне убило систему при установке licq. Поэтому я решил ставить из исходников. Про команду: надо вводить ld -configure /usr/local/qt/tib ?

georgii ()
Ответ на: Re: Не видет библиотеки от georgii

Re: Не видет библиотеки

сделай ./configure --help и найди как нужно путь к библиотекам указать.

./configure --qt_lib=/usr/local/ - к примеру.

fugu ()
Ответ на: Re: Не видет библиотеки от fugu

Re: Не видет библиотеки

./configure --with-qt-dir=/usr/local/qt не помогает равно как и ./configure --with-qt-dir=/usr/local/qt/lib

georgii ()

Re: Не видет библиотеки

qt собирал с тредами? Файлы /usr/local/qt/lib/libqt-mt* существуют?

Dimez ★★★★★ ()
Ответ на: Re: Не видет библиотеки от Dimez

Re: Не видет библиотеки

Что такое треды? Я просто ввел ./configure выбрал лицензию. Потом make(вроде еще make install) вывод команды ls в каталоге file:/usr/local/qt/lib libdesignercore.a libdesignercore.prl libeditor.a libeditor.prl libqassistantclient.a libqassistantclient.prl libqnp.prl libqt.la libqt.prl libqt.so libqt.so.3 libqt.so.3.3 libqt.so.3.3.5 libqui.prl libqui.so libqui.so.1 libqui.so.1.0 libqui.so.1.0.0 ls qt.pc README home:/usr/local/KDE/arts-1.5.5# ./configure --with-qt-dir=usr/local выдала configure: WARNING: libjpeg not found. disable JPEG support. checking for perl... /usr/bin/perl checking for Qt... configure: error: Qt (>= Qt 3.3 and < 4.0) (library qt-mt) not found. Pleas For more details about this problem, look at the end of config.log. Make sure that you have compiled Qt with thread support! (До этого еще много строк.)

georgii ()
Ответ на: Re: Не видет библиотеки от georgii

Re: Не видет библиотеки

"Make sure that you have compiled Qt with thread support!" - ключевая фраза. При компиляции qt надо было читать ./configure --help, а лучше ставить дистрибутивные пакеты.

Dimez ★★★★★ ()

Re: Не видет библиотеки

Собрал qt 3.3.5 с параметрами Код

configure -qt-libpng -qt-libjpeg -qt-gif

Все собралось. Поставил libqt3-mt-dev. Ошибка исчезла. Но! Код

config.pl: fast created 21 file(s). config.status: creating config.h config.status: creating mcop/arts_export.h config.status: creating artsc/artsc_export.h config.status: executing depfiles commands

Good - your configure finished. Start make now

home:/usr/local/KDE/arts-1.5.5# make *** Creating acinclude.m4 make[1]: Entering directory `/usr/local/KDE/arts-1.5.5' make[1]: Nothing to be done for `acinclude.m4'. make[1]: Leaving directory `/usr/local/KDE/arts-1.5.5' *** Creating configure.files cd . && /bin/sh /usr/local/KDE/arts-1.5.5/admin/missing --run aclocal-1.9 /usr/local/KDE/arts-1.5.5/admin/missing: line 52: aclocal-1.9: command not found WARNING: `aclocal-1.9' is missing on your system. You should only need it if you modified `acinclude.m4' or `configure.in'. You might want to install the `Automake' and `Perl' packages. Grab them from any GNU archive site. cd . && /bin/sh /usr/local/KDE/arts-1.5.5/admin/missing --run automake-1.9 --foreign /usr/local/KDE/arts-1.5.5/admin/missing: line 52: automake-1.9: command not found WARNING: `automake-1.9' is missing on your system. You should only need it if you modified `Makefile.am', `acinclude.m4' or `configure.in'. You might want to install the `Automake' and `Perl' packages. Grab them from any GNU archive site. cd . && perl admin/am_edit cd . && perl admin/am_edit Makefile.in cd . && rm -f configure cd . && make -f admin/Makefile.common configure make[1]: Entering directory `/usr/local/KDE/arts-1.5.5' Can't open configure: No such file or directory. make[1]: Leaving directory `/usr/local/KDE/arts-1.5.5' /bin/sh ./config.status --recheck running /bin/sh ./configure --prefix=/usr/local/kde --enable-ltdl-convenience --with-auxdir=/usr/local/KDE/arts-1.5.5/admin --no-create --no-recursion ./configure: ./configure: No such file or directory make: *** [config.status] Ошибка 127

То есть ./configure проходит нормально,но make не идет! Что делать?!!!

georgii ()

Re: Не видет библиотеки

Тему можно закрывать - перешел на etch.

georgii ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.