LINUX.ORG.RU

Network Manager

 , ,


0

1

Пока устанавливал, пользовался wifi-menu, на ноуте обычно захардкодил netctl и был доволен. На старой машинке нужно чтобы все делалось кнопочками и само. Был выбран NM.

В итоге, делаю

systemctl enable NetworkManager.service NetworkManager-wait-online.service

После ребута сервисы стартуют, апплет сети вокруг видит, но по клику на нужную ничего не происходит. Попытка вручную через wifi-menu или netctl подключиться к сети вызывает ругань от systemctl, что нужный сервис-профиль уже запущен.

Выпил NM сервисов, ребут снова позволяют использовать wifi-menu.

В /etc/NetworkManager/conf.d/dhcp-client.conf прописал:

[main]
dhcp=dhclient

Пакет dhclient установлен.

Можете подсказать ЧЯДНТ?

На старой машинке нужно чтобы все делалось кнопочками и само.

Ставьте wicd

После ребута сервисы стартуют, апплет сети вокруг видит, но по клику на нужную ничего не происходит.

А попробуйте апплет запустить из терминала, может он какой-то полезный выхлоп дает.

micronekodesu ★★ ()
Ответ на: комментарий от xDShot

Тоже подумал, но удаление его не помогло.

Уточню как оно сейчас есть: все NM сервисы disabled, при загрузке выключены.

При загрузке системы nm-applet законно пишет, что NM не запущен.

Делаю systemctl start NetworkManager.service

Появляется список сетей. При клике на нужную мне сеть контекстное меню закрывается: ни ввода пароля, ничего.

Такое поведение и при существующем профиле netctl и при отсутствующем.

Запущенные модули такие:

# systemctl list-unit-files --state=enabled
UNIT FILE                 STATE  
autovt@.service           enabled
display-manager.service   enabled
getty@.service            enabled
lightdm.service           enabled
systemd-timesyncd.service enabled
remote-fs.target          enabled

6 unit files listed.

JAkutenshi ()
Последнее исправление: JAkutenshi (всего исправлений: 1)

После ребута сервисы стартуют, апплет сети вокруг видит, но по клику на нужную ничего не происходит.

Пакет gnome-keyring установлен?

Попытка вручную через wifi-menu или netctl подключиться к сети вызывает ругань от systemctl, что нужный сервис-профиль уже запущен.

Конфликт служб?

Shein ()
NetworkManager-wait-online.service

А зачем? Обычного NetworkManager хватает.

Ну и gnome-keyring не забудь, установить.

Попытка вручную через wifi-menu или netctl подключиться к сети вызывает ругань от systemctl, что нужный сервис-профиль уже запущен.

Выключи NetworkManager, выключи и включи ПК. Будет работать, не знаю с чем связано, но перезагрузка не помагает.

flappyright ()
Последнее исправление: flappyright (всего исправлений: 1)

А какое DE используешь?
Всегда юзал NM. Сводилось к тому, что на этапе установки юзал кабель, чтобы быстрее и делал systemctl start dhcpcd, после установки DE (или WM), dhcpcd больше не запускал, делал

systemctl start NetworkManager
systemctl enable NetworkManager
делал ребут и всё работало. указанного тобой файла вообще в системе нет, работает всегда из коробки. Единственноеб для WM нужен ещё пакет nm-connection-editor, ещё на выбор из этого: libnm libnm-glib networkmanager networkmanager-qt и можно сразу это на всякий случай: networkmanager-openvpn lib32-libnm-glib

fehhner ★★★★ ()

Тред не читал.
Покажи dmesg.
Недавно была такая проблема, когда одновременно были запущены NetworkManager и wpa_supplicant (случайно остался висеть после экспериментов).

bytecode ★★ ()
Ответ на: комментарий от Shein

Установлен не был, установил - особо ничего не изменилось.

Запустил nm-applet вручную, при попытке подключиться к сети получаю вот такое:

# nm-applet 

(nm-applet:445): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

(nm-applet:445): libnotify-WARNING **: Failed to connect to proxy

(nm-applet:445): nm-applet-WARNING **: Failed to show notification: The connection is closed

Конфликт служб?

Непонятно каких. Dhcpcd не работает, netctl тоже нету в сервисах... Опять же, wifi-menu работает, если ни dhcpcd, ни NM нету среди запущенных.

JAkutenshi ()

Я не знаю что произошло. Я просто еще раз сделал systemctl enable NetworkManager.serviceи перезагрузился. Теперь все работает. Последнее что я перед этим делал: поставил gvfs, udisks2, ntfs-3g и... все. Ненавижу такие ситуации, потому что если такое опять возникнет - я не знаю точно в чем причина и как чинить.

JAkutenshi ()