LINUX.ORG.RU

kernel2.4.19 + alsa 1.0.10rc3


0

0

Есть Mandrake 9.0 на 2.4.19 (пересобрано)есть sound blaster audigy es (sb160) скачал alsa 1.0.10rc3(draivers,utils,lib,tools) , сконфигурировал скоипилил проинсталлировал utils,lib,tools потом и draivers(./configure --with-oss=no --with-sequencer=no --with-isapnp=no --with-cards=emu10k1 ) всё OK . make В alsa-draivers в папочки modules появилось 9 модулей :

snd.o snd-ac97-codec.o snd-emu10k1.o snd-hwdep.o snd-page-alloc.o snd-pcm.o snd-rawmidi.o snd-timer.o snd-util-mem.o

которые были подгружены , в проке в asound вообщемто всё всплыло о звуковухе (названя ,цапы и т.д )в девфс появилась папочка snd ,алсамиксером также можно без проблем поигратся , но mpg123 музло крутиьт не хочет , ругаеться говорит что /dev/dsp нету ...... в прочем миксеров и всей прочей звуковой отрибутики в корне dev тоже нет.......

вобщемто при подгрузке модулей из постваки мандрюка звук поевляеться с соответствующими устройствами в dev (поддержка аудиги от 3rd party )

пожалуйста помогите вычислить мою лажу !!!!!!! плз

кернел 2.6.х не предлагать

anonymous

Re: kernel2.4.19 + alsa 1.0.10rc3

скрипт snddevices в дир. alsa-driver пробовали запускать? (честно, уже не помню что там на 2.4 надо делать)

kostian ★★★★☆ ()
Ответ на: Re: kernel2.4.19 + alsa 1.0.10rc3 от kostian

Re: kernel2.4.19 + alsa 1.0.10rc3

пробавал не помогло ,............... есть подозрения что надо докомпилить один модуль типа soundcore.o но как это зделать я не знаю... при конфигурировании под мою звуковуху он не компилиться , а при полной коипиляции алсы вылетают ощибки на компиляции модулей на USB звуковуху .............

anonymous ()

Re: kernel2.4.19 + alsa 1.0.10rc3

1. mpg123 -o alsa
2. Вообще-то ты забыл включить эмуляцию OSSв ALSA
3. А какой смысле сидеть на таком древнем ядре? Почему не 2.4.32?

Begemoth ★★★★★ ()

Re: kernel2.4.19 + alsa 1.0.10rc3

./configure --with-oss=yes --with-sequencer=no --with-isapnp=no --with-cards=emu10k1

Так, по-моему, будет правильнее, если хочется использовать /dev/dsp (за него, кстати, отвечает модуль snd-pcm-oss)

syber ()
Ответ на: Re: kernel2.4.19 + alsa 1.0.10rc3 от Begemoth

Re: kernel2.4.19 + alsa 1.0.10rc3

1.Непомогло , с мплэера звук есть , вердикт: всё до этого работало тока я об этом не знал 2. > --with-oss=no

Вообшемто я сам его и отключил намеренно ........

3. Методом патча доползу, (надеюсь)

Грамаднейшие Вам спасибо.........

anonymous ()
Ответ на: Re: kernel2.4.19 + alsa 1.0.10rc3 от anonymous

Re: kernel2.4.19 + alsa 1.0.10rc3

> 3. Методом патча доползу, (надеюсь)

Только патчей по объёму придется скачать больше, чем весит ядро 2.4.32!
Лучше уж сразу новое скачать. Только при установке нового ядра не убивай старого, ибо чревато!

archont ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.