LINUX.ORG.RU

Debian 7 + Ядро 3.9 + Broadcom wireless-bcm43142

 


0

1

Итак, друзья. Имеется Debian 7 и Broadcom wireless-bcm43142. И они отказываются дружить.
http://jas.gemnetworks.com/wireless-bcm43142/ - дрова отсюда не подходят. Не хочет работать вообще. На ядре 3.4 пашет.
Обновлен проприетарный драйвер broadcom-sta для беспроводных сетевых карт - дрова из этой темы собираются, но что дальше? modprobe wl сообщает, что этот самый wl не обнаружен.
Что делалось:
1. В sources.list добавлен deb http://ftp.debian.org/debian/ wheezy-backports main
2. aptitude update и aptitude search linux-image
3. aptitude install linux-image-3.9-0.bpo.1-amd64
4. aptitude install install linux-headers-$(uname -r)
5. Распкаковываем дрова, make, make install...

# modprobe wl
libkmod: ERROR ../libkmod/libkmod-module.c:791 kmod_module_insert_module: could not find module by name='wl'
ERROR: could not insert 'wl': Function not implemented
libkmod: ERROR ../libkmod/libkmod-module.c:925 command_do: Error running install command for wl
ERROR: could not insert 'wl': Operation not permitted

Что делать? Как быть? ЧТо в форумах по теме находил - пробовал, но толку ноль.

хмм.. а вообще сам модуль где лежит(если вообще лежит)??

modinfo wl? уверен, что модуль называется wl?

TODD ★★ ()
Ответ на: комментарий от daemonpnz

PS

l# dmesg | tail
[ 1731.185160] wl: Unknown symbol cfg80211_ibss_joined (err 0)
[ 1731.185195] wl: Unknown symbol cfg80211_michael_mic_failure (err 0)
[ 1731.185221] wl: Unknown symbol cfg80211_connect_result (err 0)
[ 1731.185263] wl: Unknown symbol wiphy_unregister (err 0)
[ 1731.185296] wl: Unknown symbol cfg80211_get_bss (err 0)
[ 1731.185329] wl: Unknown symbol __ieee80211_get_channel (err 0)
[ 1731.185383] wl: Unknown symbol ieee80211_channel_to_frequency (err 0)
[ 1731.185420] wl: Unknown symbol cfg80211_inform_bss_frame (err 0)
[ 1731.185451] wl: Unknown symbol ieee80211_frequency_to_channel (err 0)
[ 1731.185486] wl: Unknown symbol wiphy_free (err 0)

rinsvid ★★ ()
Ответ на: комментарий от daemonpnz

Разобрался

# modprobe lib80211 
# modprobe cfg80211
# insmod wl.ko

# modprobe ieee80211_crypt_tkip
FATAL: Module ieee80211_crypt_tkip not found.

2: Insmod the driver.

Otherwise, if you have not previously installed a wl driver, you'll need
to add a security module before using the wl module. Most >newer systems
use lib80211 while others use ieee80211_crypt_tkip. See which >one works for
your system.

# modprobe lib80211
or
# modprobe ieee80211_crypt_tkip

If your using the cfg80211 version of the driver, then cfg80211 needs to be
loaded:

# modprobe cfg80211

Then:
# insmod wl.ko

wl.ko is now operational. It may take several seconds for >the Network
Manager to notice a new network driver has been installed and show the
surrounding wireless networks.

rinsvid ★★ ()
Ответ на: комментарий от rinsvid

Да что ты? А как же ж это я живу на ядре 3.10, да ещё и с виртуалбоксом. Может стоить обновить виртуальнуюкоробку?

daemonpnz ★★★★★ ()

ЧТо в форумах по теме находил - пробовал, но толку ноль.

В свете того, что Обновлен проприетарный драйвер broadcom-sta для беспроводных сетевых карт и того, что в нем объявлена официальная „Поддержка ядер до 3.8.x.“ а неофициально и до 3.9 то вот там ты найдешь сам новый драйвер а вот там пару патчиков для него.

Успехов.

init_6 ★★★★★ ()
Ответ на: комментарий от daemonpnz

Последняя версия с оффсайта. DKMS стоит, собирается, после ребута система впадает в ступор. На 3.2 ядре все хорошо.

rinsvid ★★ ()
Ответ на: комментарий от init_6

Да, оттуда взял новый драйвер и он собрался и на 3.2 ядре, и на 3.9. Я смотрю и до 3.10 пропатчится можно. Стоит попробовать. Спасибо!

rinsvid ★★ ()
Ответ на: комментарий от daemonpnz

Странно. У меня при каждом запуске просит ввести команду для пересборки DKMS. При том вся система стоит в глубоком ступоре. Только файл манагер работает. И все. Остальное в глубоком ступоре.

rinsvid ★★ ()
Ответ на: комментарий от init_6

Поставил дрова. День ноут выключенный постоял - включаю - WiFi НЕТ! Переустановил дрова, конечно. Но это второй раз повторяется О_О

rinsvid ★★ ()
Ответ на: комментарий от rinsvid

3.2 ядро - стоит вырубить ноут надолго - загружаю, а WiFi нет.

У меня 3.10.11 работает с именно этой версией модуля великолепно. А по всем проблемам - ты в курсе где у твоего дистра багзилла.

init_6 ★★★★★ ()
Ответ на: комментарий от rinsvid

Я так понимаю, что ядро нужно с 3.6 начиная - в этом вся проблема.

А я так не понимаю поскольку в hybrid-v35_64-nodebug-pcoem-6_30_223_141.tar.gz черным по грязному сказано:

grep KERNEL_VERSION /var/tmp/portage/net-wireless/broadcom-sta-6.30.223.141/work/src/wl/sys/wl_cfg80211_hybrid.c  | sort | uniq 
#elif LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 36)
#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 33)
#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 37)
#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 38)
#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 39)
#if LINUX_VERSION_CODE > KERNEL_VERSION(2, 6, 39)
#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 6, 0)
#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 8, 0)
#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 9, 0)

иными словами в самом коде есть блоки специфичные для ядер с 2.6.33 и по 3.9.0

и в README.txt либо я слепой… но я нахожу только упоминания о максимальной версии ядра.

А вот там есть и еще патчи которые к официально-неофициальным с 2.6.33 и по 3.9.0 решают все проблемы и по 3.11*

init_6 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.