LINUX.ORG.RU

Проблема с подключением цифрового фотоаппарата


0

0

Я пытаюсь подключить цифровой фотоаппарат Sony DSC-P100. Насколько я понимаю, он должен монтироваться как usb-storage, поэтому я делал так, как советуют везде:

# modprobe sg
# modprobe usb-storage

Однако cat /proc/partitions не выдает ничего нового, только разделы на HDD. В /dev/usb и /dev/scsi пусто. cat /proc/bus/usb/devices в конце выводит следующее:

T: Bus=01 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#= 4 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=054c ProdID=004e Rev= 2.00
S: Manufacturer=Sony
S: Product=Sony PTP
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr= 2mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=06(still) Sub=01 Prot=01 Driver=(none)
E: Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=83(I) Atr=03(Int.) MxPS= 8 Ivl=8ms

О моей системе: дистрибутив Gentoo, ядро 2.6.9.

Может кто знает что еще можно попробовать сделать?

anonymous

Re: Проблема с подключением цифрового фотоаппарата

ну, вообще-то не обязана она так монтироваться

Зато есть такая штука gphoto2 и GTK2 фронтенд к нему - gtkam

WerNA ★★★★★ ()

Re: Проблема с подключением цифрового фотоаппарата

[verna@ontpc3 verna]$ gphoto2 --list-cameras | grep Sony
        "Sony DCR-PC100"
        "Sony DSC-F1" (EXPERIMENTAL)
        "Sony DSC-F55"
        "Sony DSC-F707V (PTP mode)"
        "Sony DSC-P30 (PTP mode)"
        "Sony DSC-P31 (PTP mode)"
        "Sony DSC-P32 (PTP mode)"
        "Sony DSC-P5 (PTP mode)"
        "Sony DSC-P50 (PTP mode)"
        "Sony DSC-P52 (PTP mode)"
        "Sony DSC-P72 (PTP mode)"
        "Sony DSC-P92 (PTP mode)"
        "Sony DSC-S75 (PTP mode)"
        "Sony DSC-S85 (PTP mode)"
        "Sony DSC-U20 (PTP mode)"
        "Sony DSC-V1 (PTP mode)"
        "Sony MSAC-SR1"
        "Sony MVC-CD300 (PTP mode)"
        "Sony TRV-20E"

странно, твоей нету, но у меня не самый свежий gphoto2 или может заработает как Sony DCR-PC100

WerNA ★★★★★ ()

Re: Проблема с подключением цифрового фотоаппарата

Странно, раньше пробовал -- gphoto2 не работал, а теперь нормально :-/ Правда может делать *только* --get-all-files и *только* с фотками, видеоролики не нравятся почему-то. Но мне пока и этого хватит, спасибо! :-)

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.