LINUX.ORG.RU

CentOS, не работают любые сетевые карты кроме встроенной


0

2

Сами девайсы определяются нормально, модули загружаются, интерфейсы поднимаются, но пакеты не идут вообще

CentOS 6.3, ядро стандартное 2.6.32. Сетевухи пробовал любые, начиная от реалтека 8139 и заканчивая интелом e100 и даже via rhine. Биос на материнке последний, мать десктопная на Z77

Проблема явно не в кабеле или порте на том конце, ничего не меняется даже если подключить напрямую ноутбук. Куда копать?

★★★★★

Ответ на: комментарий от vlb

как видишь бывает. Если для постановки диагноза нужны логи и результаты команд - все предоставлю

JB ★★★★★ ()
Ответ на: комментарий от vlb

вставлял в разные слоты. Для PCI-E карт под рукой нет

JB ★★★★★ ()
Ответ на: комментарий от dexpl

lspci покажи. С сетевухами и без

без то зачем?

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579V Gigabit Network Connection (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1c.4 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 5 (rev c4)
00:1c.7 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 8 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Z77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation G72 [GeForce 7300 LE] (rev a1)
03:00.0 PCI bridge: Integrated Technology Express, Inc. Device 8892 (rev 30)
04:00.0 Ethernet controller: Compex RL100-ATX 10/100
04:02.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22A IEEE-1394a-2000 Controller (PHY/Link) [iOHCI-Lynx]
05:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)
06:00.0 SATA controller: Marvell Technology Group Ltd. 88SE9172 SATA 6Gb/s Controller (rev 11)
JB ★★★★★ ()
Ответ на: комментарий от at

С роутингом все в порядке? С самой машины интерфейсы пингуются?

с самой да, с роутингом тоже все ок - я пингую адреса из той же подсети

JB ★★★★★ ()

А если одну из проблемных сетевых карт соединить напрямую с другим компом и начинать с него флудить пакетами - будет ли увеличиваться счётчик прерываний?

Deleted ()
Последнее исправление: Deleted (всего исправлений: 1)

И ещё надо бы запуститься с livecd других дистров с другими ядрами, чтобы исключить аппаратные проблемы.

Deleted ()
Ответ на: комментарий от JB

Тогда не понял какие именно пакеты не ходят? Если не устанавливается соединение возможно, что проблема в mtu

at ★★ ()
Ответ на: комментарий от at

Тогда не понял какие именно пакеты не ходят? Если не устанавливается соединение возможно, что проблема в mtu

пинги не ходят например

JB ★★★★★ ()
Ответ на: комментарий от JB

счетчик прерываний это где смотреть, в каком месте ifconfig?

Я знаю только про /proc/interrupts. Возможно где-то есть более детальные счётчики.

Deleted ()
Ответ на: комментарий от sin_a

Свой адрес пингуется?

сам себя да

selinux отключил, что еще вообще может мешать?

JB ★★★★★ ()
Ответ на: комментарий от Deleted

Я знаю только про /proc/interrupts. Возможно где-то есть более детальные счётчики.

сейчас пока проверить не могу, пришлось вернуть сервер обратно в рабочее состояние с одной сетевухой

JB ★★★★★ ()
Ответ на: комментарий от JB

Т.е. насколько понимаю ситуация следующая (в моем примере test — виртуальный интерфейс)

>sudo ip tuntap add dev test mode tap
>sudo ip a a 10.10.10.1/24 dev test
>ping -c1 10.10.10.1
PING 10.10.10.1 (10.10.10.1) 56(84) bytes of data.
64 bytes from 10.10.10.1: icmp_req=1 ttl=64 time=0.055 ms

--- 10.10.10.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.055/0.055/0.055/0.000 ms
Сам интерфейс пингуется, но не поднят
>ip a s dev test
16: test: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 500
    link/ether de:4d:fd:13:87:af brd ff:ff:ff:ff:ff:ff
    inet 10.10.10.1/24 scope global test

Из вне к нему доступа нет

at ★★ ()
Ответ на: комментарий от JB

Это иногда делают кривые скрипты инициализации :) А записи роутинга появляются?

ip r show table all | grep test
10.10.10.0/24 dev test  proto kernel  scope link  src 10.10.10.1 
broadcast 10.10.10.0 dev test  table local  proto kernel  scope link  src 10.10.10.1 
local 10.10.10.1 dev test  table local  proto kernel  scope host  src 10.10.10.1 
broadcast 10.10.10.255 dev test  table local  proto kernel  scope link  src 10.10.10.1
У меня на сентоси были с этим проблемы при использовании алиасов/вланов на интерфейсе.

ИМХО нереально, чтобы несколько сетевых вели себя подобным образом. Проблема на шине — тогда бы сетевухи не определялись вообще.

at ★★ ()

И не будет работать, сначала надо запустить мост PCI. Пользователи интела должны страдать.

AlexVIP ()
Ответ на: комментарий от JB

03:00.0 PCI bridge: Integrated Technology Express, Inc. Device 8892 (rev 30)

давай полный вывод lspci -vvv по этому устройству.

AlexVIP ()

cat /etc/sysconfig/networking/profiles/default/ifcfg-*

fbiagent ★★★ ()
Ответ на: комментарий от AlexVIP

И не будет работать, сначала надо запустить мост PCI. Пользователи интела должны страдать.

запустить что простите?

JB ★★★★★ ()
Ответ на: комментарий от JB

Шину PCI, ее внезапно нет в чипсете Z77 и представлена на этих материнских платах отдельным мостом.

AlexVIP ()
Ответ на: комментарий от at

в общем все магическим образом починилось на тестовом стенде. Внешней сетевухой поставил интеловскую на e100, внутренняя сетевуха смотрит в локальную сеть 192.168.1.0/24, внешнюю подключил напрямую к ноутбуку. Пинги ходят, связь есть. Что именно стало решением я так и не понял, эту же сетевуху я ставил и до этого и она так же не работала

давай полный вывод lspci -vvv по этому устройству.

карта поменялась, сейчас интеловская. Ради интереса менять обратно не буду

04:00.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 08)
        Subsystem: Intel Corporation EtherExpress PRO/100+ Management Adapter
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 32 (2000ns min, 14000ns max)
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at f7305000 (32-bit, non-prefetchable) [size=4K]
        Region 1: I/O ports at e000 [size=64]
        Region 2: Memory at f7200000 (32-bit, non-prefetchable) [size=1M]
        Expansion ROM at f0100000 [disabled] [size=1M]
        Capabilities: <access denied>
        Kernel driver in use: e100
        Kernel modules: e100

cat /etc/sysconfig/networking/profiles/default/ifcfg-*

% cat /etc/sysconfig/networking/profiles/default/ifcfg-*
DEVICE="eth0"
IPADDR=192.168.1.19
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
NM_CONTROLLED="no"
ONBOOT="yes"
TYPE="Ethernet"
DEVICE="eth1"
IPADDR=217.66.88.107
NETMASK=255.255.255.224
NM_CONTROLLED="no"
ONBOOT="yes"
TYPE="Ethernet"
JB ★★★★★ ()
Последнее исправление: JB (всего исправлений: 1)
Ответ на: комментарий от JB

А у меня похожая проблема кажется наклевывается, а точнее уже. Только нет у меня интелловой сетевухи, только D-Link DGE-530T, причем работает по меньшей мере странно. Встроенная сетевуха работает без проблем, а вот вставленная... Вот что выдает lspci -knn :

...
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 06)
        Subsystem: ASUSTeK Computer Inc. P8P67 and other motherboards [1043:8432]
        Kernel driver in use: r8169
        Kernel modules: r8169
...
05:01.0 Ethernet controller [0200]: D-Link System Inc DGE-530T Gigabit Ethernet Adapter (rev 11) [1186:4b01] (rev 11)
        Subsystem: D-Link System Inc DGE-530T Gigabit Ethernet Adapter (rev 11) [1186:4b01]
        Kernel driver in use: skge
        Kernel modules: skge
При этом ifconfig:
eth1      Link encap:Ethernet  HWaddr 00:15:E9:39:BB:65  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:326 errors:0 dropped:0 overruns:1 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:28396 (27.7 KiB)  TX bytes:0 (0.0 b)
          Interrupt:16
Ядро 2.6.32-279.14.1.el6.x86_64 Очень надо ее заживить и как всегда со сроком «вчера» :( Пожалуйста подскажите как оживить сетевуху! Заранее спасибо!

MakPol ()
Ответ на: комментарий от MakPol

В добавок чуть не забыл еще и вывод lspci -vvv:

05:01.0 Ethernet controller: D-Link System Inc DGE-530T Gigabit Ethernet Adapter (rev 11) (rev 11)
        Subsystem: D-Link System Inc DGE-530T Gigabit Ethernet Adapter (rev 11)
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr+ Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ >SERR+ <PERR+ INTx-
        Latency: 64 (5750ns min, 7750ns max), Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at f7ffc000 (32-bit, non-prefetchable) [size=16K]
        Region 1: I/O ports at e800 [size=256]
        Expansion ROM at de000000 [disabled] [size=128K]
        Capabilities: [48] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=1 PME-
        Capabilities: [50] Vital Product Data
                Product Name: DGE-530T Gigabit Ethernet Adapter
                Read-only fields:
                        [PN] Part number: DGE-530T
                        [EC] Engineering changes: Rev. 1.1
                        [MN] Manufacture ID: 44 2d 4c 69 6e 6b
                        [SN] Serial number: DGE530T49BC36
                        [CP] Extended capability: 01 10 cc 03
                        [RV] Reserved: checksum good, 31 byte(s) reserved
                Read/write fields:
                        [RW] Read-write area: 121 byte(s) free
                End
        Kernel driver in use: skge
        Kernel modules: skge

MakPol ()
Ответ на: комментарий от MakPol

Видимо я зря написал в имеющуюся тему, хотя плодить темы ИМХО еще хуже. Очень прошу помогите!

MakPol ()
Ответ на: комментарий от MakPol

у меня был немного наоборот, RX по нулям, а TX нормально

Как мне кажется проблема в irq, попробуй загрузить ядро с параметром irqpoll. И как вариант можно отключить acpi и apic, хотя бы временно

JB ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.