LINUX.ORG.RU

Глухой вис при пуске вебки

 ,


1

1

собственно проблема - при попытке включить вебку в любом приложении система наглухо виснет и ни на какие кнопки не реагирует, приходится выключать лонгпрессом кнопки вкл
нагуглил два прецедента точь-в-точь как у меня, и нигде до решения не добрались
первый - http://www.calculate-linux.org/boards/21/topics/15745?r=15761#message-15761
второй - http://forums.fedoraforum.org/archive/index.php/t-278453.html
помогите сделать, чтобы работала
под форточками пашет, исправна, раньше тоже работала.. с какой версии перестала - не помню, долго не было надобности использовать, а вот сейчас образовалась
у меня - lenovo 3000 G530 6KS-B, камера определялась раньше по lsusb как Lenovo EasyCamera, в качестве системы стоит Arch Linux
ЛОР, спаси!

★★★

апну

вот, как дела у меня:

[kostett@lenovo-sielab ~]$ dmesg | grep video
[    0.205926] pci 0000:00:02.0: Boot video device
[    8.966261] Linux video capture interface: v2.00
[    8.997909] uvcvideo: Found UVC 1.00 device Lenovo EasyCamera (090c:3371)
[    8.999358] usbcore: registered new interface driver uvcvideo
[kostett@lenovo-sielab ~]$ lsusb
Bus 003 Device 002: ID 090c:3371 Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) 
Bus 003 Device 011: ID 19d2:0016 ZTE WCDMA Technologies MSM 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

kostett ★★★ ()

Недели две назад была похожая ситуация на ноутбуке samsung в Fedora17. Вылечилось как в этой инструкции - добавить параметры для загрузки модуля.

Note: With WebCam SCB-0385N (usb ID 2232:1005) and WebCam SC-0311139N (usb ID 2232:1020), you might need to add some configuration to the module if the usage of the camera makes the system freeze : 

/etc/modprobe.d/uvcvideo.conf
options uvcvideo nodrop=1

justAmoment ★★★★★ ()

наблюдал что-то похожее у сотрудников на Lenovo, при запуске скайпа. Решалось отрубанием модуля uvcvideo

Harald ★★★★★ ()
Ответ на: комментарий от justAmoment

спасибо, попробую)
сейчас в поезде, как до места отдыха доберусь, так обязательно займусь..

kostett ★★★ ()
Ответ на: комментарий от justAmoment

спасибо :)

/etc/modprobe.d/uvcvideo.conf
options uvcvideo nodrop=1

спасибо помогло :) archlinux i686, та же камера на ноутбуке lenovo что и у TC

oldbay ()
Ответ на: спасибо :) от oldbay

о, спасибо что запостил, я вспомнил про вебку свою, тоже сделал так и все работает
з.ы. может, сюда из гугла придут, так вот, для чайников:
# touch /etc/modprobe.d/uvcvideo.conf
# echo 'options uvcvideo nodrop=1' > /etc/modprobe.d/uvcvideo.conf

kostett ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.