LINUX.ORG.RU

Ubuntu не видит картридер и nikon s9100


0

1

Доброго дня. Столкнулся с небольшой проблемой: на ноутбуке Acer Aspire 5620 установлена убунта (обновления последние). При подключение внешнего картридера через usb с флешкой:

dmesg:

[ 3065.144240] usb 1-3: new high speed USB device number 13 using ehci_hcd
[ 3065.280192] scsi5 : usb-storage 1-3:1.0
[ 3066.281599] scsi 5:0:0:0: Direct-Access     Generic  USB SD Reader    1.00 PQ: 0 ANSI: 0
[ 3066.282214] scsi 5:0:0:1: Direct-Access     Generic  USB CF Reader    1.01 PQ: 0 ANSI: 0
[ 3066.282850] scsi 5:0:0:2: Direct-Access     Generic  USB SM Reader    1.02 PQ: 0 ANSI: 0
[ 3066.283484] scsi 5:0:0:3: Direct-Access     Generic  USB MS Reader    1.03 PQ: 0 ANSI: 0
[ 3066.313023] sd 5:0:0:0: Attached scsi generic sg2 type 0
[ 3066.320473] sd 5:0:0:1: Attached scsi generic sg3 type 0
[ 3066.324155] sd 5:0:0:2: Attached scsi generic sg4 type 0
[ 3066.324542] sd 5:0:0:3: Attached scsi generic sg5 type 0
[ 3097.136119] usb 1-3: reset high speed USB device number 13 using ehci_hcd
[ 3107.384277] usb 1-3: reset high speed USB device number 13 using ehci_hcd
[ 3123.628201] usb 1-3: reset high speed USB device number 13 using ehci_hcd
[ 3123.876153] usb 1-3: reset high speed USB device number 13 using ehci_hcd
[ 3134.128185] usb 1-3: reset high speed USB device number 13 using ehci_hcd
[ 3134.261788] sd 5:0:0:0: Device offlined - not ready after error recovery
[ 3134.261882] sd 5:0:0:0: rejecting I/O to offline device
[ 3134.261910] sd 5:0:0:0: rejecting I/O to offline device
[ 3134.261926] sd 5:0:0:0: rejecting I/O to offline device
[ 3134.261937] sd 5:0:0:0: [sdb] READ CAPACITY failed
[ 3134.261944] sd 5:0:0:0: [sdb]  Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
[ 3134.261956] sd 5:0:0:0: [sdb] Sense not available.
[ 3134.261970] sd 5:0:0:0: rejecting I/O to offline device
[ 3134.261982] sd 5:0:0:0: [sdb] Write Protect is off
[ 3134.261990] sd 5:0:0:0: [sdb] Mode Sense: 00 00 00 00
[ 3134.262002] sd 5:0:0:0: rejecting I/O to offline device
[ 3134.262014] sd 5:0:0:0: [sdb] Asking for cache data failed
[ 3134.262021] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[ 3134.262407] sd 5:0:0:0: [sdb] Attached SCSI removable disk
[ 3134.271810] sd 5:0:0:1: [sdc] Attached SCSI removable disk
[ 3134.272565] sd 5:0:0:2: [sdd] Attached SCSI removable disk
[ 3134.273313] sd 5:0:0:3: [sde] Attached SCSI removable disk

lsusb:

Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 09da:000e A4 Tech Co., Ltd 
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 011: ID 058f:6362 Alcor Micro Corp. Hi-Speed 21-in-1 Flash Card Reader/Writer (Internal/External)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

fdisk карту не видит.

Тоже самое с фотоаппаратом Nikon S9100:

dmesg:

[ 2635.413101] usb 1-3: USB disconnect, device number 11
[ 2649.080203] usb 1-2: new high speed USB device number 12 using ehci_hcd
[ 2670.476237] usb 1-2: usbfs: USBDEVFS_CONTROL failed cmd gvfs-gphoto2-vo rqt 33 rq 102 len 0 ret -110

lsusb:

Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 09da:000e A4 Tech Co., Ltd 
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 012: ID 04b0:0186 Nikon Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

fdisk опять же не видит. При этом при подключение этих карт через другой фотик никаких проблем не возникает. Что картридер, что s9100 под виндой определяются. С этим можно что-нибудь сделать? Заранее спасибо за ответ.


Судя по «Device offlined - not ready after error recovery» и «rejecting I/O to offline device» выглядит как аппаратная проблема с портом или контроллером. Пробовали втыкать в тот порт, на котором сейчас мышка висит?

RussianNeuroMancer ★★★★★
()
Ответ на: комментарий от RussianNeuroMancer

Тоже самое, сначала доходит до sd

[ 3066.313023] sd 5:0:0:0: Attached scsi generic sg2 type 0
[ 3066.320473] sd 5:0:0:1: Attached scsi generic sg3 type 0
[ 3066.324155] sd 5:0:0:2: Attached scsi generic sg4 type 0
[ 3066.324542] sd 5:0:0:3: Attached scsi generic sg5 type 0

потом на протяжение секунд 20-30 идёт

[ 3097.136119] usb 1-3: reset high speed USB device number 13 using ehci_hcd
[ 3107.384277] usb 1-3: reset high speed USB device number 13 using ehci_hcd
[ 3123.628201] usb 1-3: reset high speed USB device number 13 using ehci_hcd
[ 3123.876153] usb 1-3: reset high speed USB device number 13 using ehci_hcd
[ 3134.128185] usb 1-3: reset high speed USB device number 13 using ehci_hcd

далее выбрасывается оставшаяся часть. Это с картридерем, с фотоаппаратом схоже - первые 2 строки сразу после вставки в usb, третья - через секунд 30

Kif
() автор топика
Ответ на: комментарий от Led

То есть D60 через этот кабель нормально работает, в винде кабель тоже работает, а вот конкретно в линухе и с конкретно картридерем он не пашет? Для s9100 вообще другой кабель, там разъем micro-usb

Kif
() автор топика
Ответ на: комментарий от Kif

Попробовал с еще одним кабелем - тоже самое.

Kif
() автор топика
Ответ на: комментарий от Kif

>То есть D60 через этот кабель нормально работает, в винде кабель тоже работает, а вот конкретно в линухе и с конкретно картридерем он не пашет?

Ну вот и здОрово - пользуйся только виндой.

Led ★★★☆☆
()
Ответ на: комментарий от Led

Блин, реакция какая-то неадекватная. Я приплёл к теме винду, так как там оно пашет. Если бы хотел, давно бы там поставил мастдай и имел бы кучу других проблем. Интересует же конкретно решение под линух. Если есть какие-то нюансы в проводах, из-за которых под разными осями один и тот же провод может работать и нет - так и скажите.

Kif
() автор топика
Ответ на: комментарий от Kif

По тому, что наблюдается в логах - кажется где-то присутствует аппаратная проблема. Возможно какие-то стандартные настройки работы USB-контроллера в Windows позволяют драйверам не замечать её (например при обнаружении ошибок может автоматически снижаться скорость работы до уровня USB 1.0; ну или что-то такое в этом роде).

Попробуйте подключение через качественный USB-хаб. Попробуйте, чем чёрт не шутит, LiveCD Ubuntu 11.10 Beta. Может были всё же какие-то баги в драйвере вашего USB-контроллера (хотя это крайне меловероятно), которые могли исправить.

RussianNeuroMancer ★★★★★
()
Ответ на: комментарий от RussianNeuroMancer

Ок, спасибо за ответ. Попробую на днях, как будет возможность. О результатах отпишусь.

Kif
() автор топика
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.