LINUX.ORG.RU

WiFi & Aircrack-ng


0

0

Доброе время суток! Проблема в следующем: Wifi Карта rtl8187su, на данный момент Линукс ее поддерживает абсолютна, подключает к точи доступа с Wpa защитой но по непонятной мне причине не работает в режиме мониторинга с airodump-ng, не видит не одной точки доступа и уж тем более не перехватывает пакеты. Единственный способ добиться работы в айродампе это переl переводом в режим мониторинга подключится к известной Wifi точки и уже после запустить airmon-ng при этом в консоли возникает список процессов включая wpa_sopplicant. Вопрос следующем, можно ли запустить службы которые нужны айрокрэку (и нужны ли они ему) без подключения к точки доступа, ведь не всегда под рукой есть известная точка чтоб проворачивать такое?

Ответ на: комментарий от GROMrusSPECIAL

> что значит «$iface»?
«$iface$ значит переменная iface. В данном случае вместо неё нужно было подставить имя нужного интерфейса (т.е. Вы всё правильно сделали).
Если это не помогает, возможно, следует сделать ifconfig wlan0 up.

AITap ★★★★★ ()
Ответ на: комментарий от GROMrusSPECIAL

А каким образом Вы подключаетесь к уже известным wifi-точкам? NetworkManager? Какой версии ядро используется (uname -a)?

AITap ★★★★★ ()
Ответ на: комментарий от AITap

в Backtrack`e # /etc/init.d/wicd start потом через менеджер wicd в Slackware поставил wicd и тоже через него, пробывал через тот который по дефолту, но по моему он не распознает интерфейсы с именем «wlan0»

в BT ядро 2.6.30.9 в SW 13.1 не помню, но наверняка не старее

GROMrusSPECIAL ()
Ответ на: комментарий от GROMrusSPECIAL

> пробывал через тот который по дефолту, но по моему он не распознает интерфейсы с именем «wlan0»

«По дефолту» - это какой? Который в KDE?

AITap ★★★★★ ()
Ответ на: комментарий от AITap

Через wpa_gui пробывал. Ха страно щас wpa_gui врубил (у меня wicd сам конектится к вайфай после включения KDE) и он, при уже включенном соединении, как и airodump-ng работает, распознает wlan0 и показывает что я уже соединен с роутером. Может я что то не включаю, что включается само сабой в wicd? В Backtrack'e же не запустиш Wicd'шный NetworkManager пока не введеш это: # /etc/init.d/wicd start

В Slackware ядро 2.6.33.4.

GROMrusSPECIAL ()
Ответ на: комментарий от GROMrusSPECIAL

Попробуйте поискать что-нибудь интересное в системном журнале (/var/log/syslog) и в журнале ядра (dmesg) и сравните вывод при попытках включить airodump до и после подключения.
Возможно, имеет смысл также спросить на #linux сети RusNet.

AITap ★★★★★ ()
Ответ на: комментарий от AITap

Я попробовал, пока сохранил пару файлов с логом, но не вникал в них, но зато вот кое что сохранил: Found 2 processes that could cause trouble. If airodump-ng, aireplay-ng or airtun-ng stops working after a short period of time, you may want to kill (some of) them!

PID   Name 6030   wpa_supplicant 6434   dhclient Process with PID 5881 (airodump-ng) is running on interface wlan0 Process with PID 5898 (airodump-ng) is running on interface wlan0 Process with PID 6030 (wpa_supplicant) is running on interface wlan0

Interface   Chipset      Driver

wlan0      RTL8180/RTL8185   r8180 (monitor mode enabled)

Это предупреждение и список процессов выдается только если, с начало включить Wicd Без Wicd когда ничего не работает, выдает только это: Interface   Chipset      Driver

wlan0      RTL8180/RTL8185   r8180 (monitor mode enabled) И еще постаяно в dmesg поевляется эта строчка, даже иногда до запуска KDE (только верхняя строка) в страке для логина или пароля: This is enable turbo mode IE process Associated successfully Using G rates

GROMrusSPECIAL ()
Ответ на: комментарий от AITap

Не помогло wpa_supplicant -iwlan0 при вводе выдает хелп-страничку, а iwconfig wlan0 mode Monitor и iwconfig wlan0 54M auto и вовсе не влияют не на что. iwconfig wlan0 54M auto дополнил iwconfig wlan0 rate 54M auto. P.S. Я не подумал и выложил Iwconfig до airmon-ng, так что дело не в режиме мониторинга

GROMrusSPECIAL ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.