LINUX.ORG.RU

OLIMPUS C-220ZOOM проблемы


0

0

Имеется сабж цифровая фотокамера. Возникли проблемы при подключении его через usb. Система просто виснет через несколько секунд после подсоединения кабеля. У меня ядро 2.4.20-gentoo-r9.
Вот содержимое /proc/bus/usb/devices после подключения.
[code]T: Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
D: Ver= 1.00 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0000 ProdID=0000 Rev= 0.00
S: Product=USB UHCI-alt Root Hub
S: SerialNumber=d800
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 8 Ivl=255ms
T: Bus=02 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#= 2 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=07b4 ProdID=0102 Rev=10.58
S: Manufacturer=OLYMPUS
S: Product=C2Z,D520Z,C220Z
S: SerialNumber=150232174
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E: Ad=01(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=82(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
D: Ver= 1.00 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0000 ProdID=0000 Rev= 0.00
S: Product=USB UHCI-alt Root Hub
S: SerialNumber=d400
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 8 Ivl=255ms[/code]
Удалось сохранить только дав команду cat /proc/bus/usb/devices > usb.txt;sync (вот в чем сила линуха: имееет замечательные средства для решения проблем которые сам же создает :))
То есть видно что определилось: производитель, модель, серийник и еще чего то, а вот в /proc/scsi/scsi непорядок.
[code]Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
Vendor: Model: Rev:
Type: <NULL> ANSI SCSI revision: ffffffff[/code]
Ну и кусок из кернел лога.
[code]Jan 14 19:49:30 [kernel] hub.c: new USB device 00:07.3-2, assigned address 2
Jan 14 19:49:30 [kernel] scsi1 : SCSI emulation for USB Mass Storage devices[/code]
Имеется флэш усб диск работает без проблем.

Что делать. Менять ядро, или у меня имеющееся сконфигурено неправильно?

★★★★

Re: OLIMPUS C-220ZOOM проблемы

Проблема решена. kernel 2.6.1-r1

ip ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.